Can't Alt+Tab once VR Mode initiated

Brief description of the issue: Once I’ve started VR mode I cannot alt-tab Flight Sim whatsoever, task manager won’t even appear on top of it. Necessitates quitting Flight Sim entirely to use other programs. I usually manage a few things during flights so this makes things difficult for me.

Provide Screenshot(s)/video(s) of the issue encountered: None required.

Detail steps to reproduce the issue encountered: Enter VR Mode. Press alt+tab. Curse the skies!

I’ve mapped a button on my yoke to toggle VR so if I need to do something on the desktop I can, then just toggle it back on. Works for now.

I can alt-tab fine? You do need to alt-tab, because in VR your mouse cursor is captured, but a simple alt-tab should bring you back to the desktop.

1 Like

Will have to try some things maybe it’s particular to my machine right now. None of the windows would take focus for me! Hadn’t had this problem previously.

Just want to add that I’ve tried restarting my PC, making sure everything is up to date. When I alt tab I can see the panel to switch windows but Flight Sim itself retains focus. Ctrl+alt+delete and selecting task manager has it blink up before flight sim grabs focus again. Additionally, even when switching back to non-VR mode the problem remains (though if I never switch to VR it doesn’t happen). It’s pretty quirky!

1 Like

I have same issue! And also after I ‘CTRL + TAB’ back to PC version, I still cannot get any windows into focus that’s under MSFS. To solve it, I go into settings and change MSFS from fullscreen to windowed and then back to fullscreen. If I don’t do it, my Corsair mouse doesn’t change its profile from MSFS to Default one either

2 Likes

Same here, I can alt-tab but the mouse doesn’t let go from the FS2020 window. That’s why I just toggle VR for now. Still annoying though, I can do it in X Plane, but it’s still tricky if you move your head.

Same here. I cannot do any alt+tab. How I can check my flight charts meanwhile I am in VR… :frowning:

A common alt-tab workaround is to use Ctrl + Esc which activates the start menu, but will also deactivate focus.

1 Like

I had this - I changed the non vr settings to window not full screen and then it was fine for me?

I confirm this issue too. Even when I exit out of VR, I still cannot open anything outside of the sim. I can see the windows task bar by pressing the windows keyboard button but no other window or task manager can be displayed on top of the sim window. Quite annoying.

This is the workaround at the moment for the people who experience this issue. With non VR settings set to windowed I can operate as I’d expect (but hopefully they can fix whatever causes this problem)

Confirmed. When in fullscreen mode, it is not possible to alt-tab away from FS after you enter VR mode and exit it again. The only workaround I’ve found is to switch to windowed, then back to fullscreen, after which you can alt-tab until you enter VR again. Makes using external apps (e.g. Neofly) onerous and usually no longer worth it.

On a related note, I’ve tried repeatedly to run VR with FS windowed, but it causes mouse and windowing issues that eventually crash FS, cause WMR to lose its mouse cursor, and put Windows into a state that requires holding the power key down to restart my computer. This happens in fullscreen too, but much less often.

That said, VR is a great start. Just needs some WMR integration love before we can use it for mission critical missions (e.g. multiplayer meetups). Can’t wait until it’s ready for prime time.

Do an ALT-Enter to take it out of full screen first, then the ALT-TAB will work.

3 Likes

Great tip! Mapped it to my controller and it’s a lot less onerous now. :grinning:

Setting the non-VR interface to window mode can really prevent SIM from being forced to stay at the top. But it will also bring new problems-VR performance drops sharply.