Cant change weather

Just found this trick.
Invite yourself into a group.
When you see yourself just remove yourself from the group…
Let me know

how do you invite yourself to a group?

Not so easy. Ask someone here or on FB to invite you. You can’t invite yourself.

When I joined my friend, which I had never join a group before, It does not allow me access the weather to tweak it and now it’s stuck in a presets weather and it’s not logging my flight hours now?!

That sounds like the typical Multiplayer issue.
Join your friend again and leave the group before him. That should solve the problem.

when click on group nothing shows up

Plus it’s not loading texture packs and the taxi ways and runaways look un-rendered, kinda like offline. And the terminals are not detailed.

Looks like a bigger issue. Sorry can’t help from here. Am on holidays in Denmark.

I have the same issue. However it seems to be not with the weather but with the server. I’m not recognized as logged in and too can’t access live settings like traffic and weather. How frustrating. When I first purchased it last month it worked. I can’t access group settings either. I can only select local options.
I honestly don’t know why a few servers aren’t running when I can hop on to other servers on games that are 10 years old. I think this might be a local issue that will have to be updated on a new release meaning we will be stuck like this until the next version.
Thanks for posting.

1 Like

I found a fix! Go to Options > General Options > Data > Online Functionality && ensure this is toggled to the “on” position !!

1 Like

Hi All! I have the same problem, am currently waiting for my friend to be online to re invite me to a group. I also know that when we make new groups it always says left group first. I will also make a bug report.

I’m having a similar issue. I have tried a wide range of fixes after researching these forums and filing a bug report on zendesk.

I first encountered the bug after doing a group flight with a friend. The next day I could not open the weather menu unless I turned off all online functionality including Bing streaming. My friend had exactly the same issues. We are both on Xbox Series X.

Interestingly, I have MSFS installed on my PC as well, and when I launched that copy, it picked up the same glitch as soon as it accessed my account on the Asobo servers. So it’s a server side issue.

Eventually I was able to clear this by having my friend invite me to a group then leaving the group. This cleared up everything for my friend. But I’m still having problems. My problems now are: Can open weather menu, but changes to weather or time revert back after a few seconds. Can change multiplayer modes but it reverts back as well. Cannot open group menu at all. Therefore joining then leaving a group is not possible.

In response to my zendesk ticket, they told me to invite a friend to an Xbox party, then I need to leave the party. It was supposed to reset my account. This did not help. I let them know of this but haven’t received another reply in two days.

Oddly, it seems to have suddenly resolved itself. I still have an open ticket, and my last post requested that they do some sort of reset on my online account. They have not responded yet but I’ll see if perhaps they did do a reset. I have not been able to test whether the group menu drops down (friends not online) but I can change the weather and time now and the settings stick. Crossing fingers this is behind me, and will certainly try to manually leave group after multiplayer play before logging off!


Welp, I’m back to square 1. I joined a group hosted by my friend, did some flying, then it was time to go. But I still could not drop down the group menu. So I found another way to exit. I logged off my account using the in-game menu.

Today I find that it’s glitching again. Any changes I make to weather or time won’t stick.

One thing I can do on my Xbox is sign off then sign into my daughter’s secondary Xbox account in the game menu (my primary account must still be active for the game license). Once I do that, MSFS multiplayer and weather controls work normally.

I have always the same issue on my xbox Series X with the weather and time. If I change the time to the actual date and time, it will be change in a few seconds always to the old date and time (18 November 2021 22.03 UTC)!
What‘s the problem and how can I solve this? :pensive:

Have you been in a group flight?
If so, you must exit from it.
To do that you need to be invited into any group flight.
Then properly exit the group.

Yes I was but when I start again, I‘m not in that group anymore. Maybe a must go in another group an then go out of the group?

That is correct.
Get an invitation to any group!

1 Like

It works, thank you for your help! :sunglasses::+1:t3:

1 Like