Cant download SDK 19.3 or its documentation

There is an error with sim update 10 in which i cannot download the SDK or its documentation from the Sim or the Developer menu.

Any links to working versions would be appreciated

Me too can not download SDK update. Nothing hapends when click on download.

I’ve managed to get it downloaded in stages. 1 download. Reboot sim. A bit annoying but nearly got it all now.

Could you explain the steps you took in more detail? Thanks

Edit: I restarted MSFS and it just worked :man_shrugging:

Something that works for me… just change the aircraft you’ve selected in Profile → Hangar. Hopefully works for you.

Well, fire up sim. Try to download SDK from top right, doesn’t work. Nothing happens. With dev menu try downloading. 1 option worked. Reboot sim. Try again, this time only 2 options worked from the dev menu only. Reboot sim tried again to download, 0 options worked. Got fed up wasting 8-10 mins every time I wanted to try a download. Stopped trying.