Can't even launch MSFS since august 2021

When I launch MSFS a message appears : “compulsury update has to be made in Microsoft Store”.
In Microsoft Store everything is updated.
When I launch again MSFS the same message still appears…
Xbox support says to reinstall MSFS (of course !!!)
Microsoft technical support has no solution until now.
Does someone have any suggestion ?

I have the exact same issue. There is another post where someone proposes a method to uninstall and reinstall gaming services but it did not work for me. The bottom line is we are stuck and cannot even open Flght simulator anymore

1 Like

Try this…

Go to the store and under the my Library section click on the All owned options

This will bring up a list of all your owned apps.
Find the Microsoft Flight Simulator one and click on it

This will bring up a screen which will probably show “This product is installed” and with a play option .

Don’t click anything, just leave it on this screen for 10 or 15 minutes, you may eventually see it starts to update in this screen

1 Like

Unfortunately, that doesn’t work.

1 Like

Thanks for the suggestion but no, I confirm it does not work

1 Like

Same problem here. Very annoying.

1 Like

Oh well it worked for me on Su5 update and a few others

1 Like

I don’t think this would work but worth a try. Go to the MS store click on the 3 dots upper RH corner select download and updates and see if MS needs updating and then click on the option.

1 Like

This is Corcky37,I’ve had the same problem ,before, try running it with the internet off .You don’t have to run it with internet on.and if you get along with the download,there are 2 places that will appear in blue,click both ,ok.if you do get get in running, after a few times it may say something about internet,or quit ,then you quit and turn. internet on and let it check for updates,iI hope I worded it so you can try it,let me know if that helped,Thanks

1 Like

Thanks Corcky37, tried your way but no luck… the point is I’m unsure of what they changed but MSFS 2020 updates used to be managed within the game and not through the MS store and it used to work perfectly… they have definitely to fix this


I confirm, it doesn’t work. Flying this simulator is more complicated than flying a real aircraft !

Install or update xbox app.
Also update or reinstall gaming services app.

Already done - I used the “repair” option. No effect

DO you get any errors in the Windows 10 Event Viewer?

i had the same problem

for me i have 2 Microsoft accounts and i was logged into the wrong 1

it still showed i had msfs installed but it would not launch

i realised what was happening and logged in on the correct account and all became good
i hope this works for you

Has anybody ideas? I have the same issue… MS Store does not have an update but the Sim tells me I have to download the update from the Store.

1 Like

I have sent a request to MSFS support. Their reply was not helpful. I am still waiting for a new one. It’s quite annoying.

fixed it……signed out of ms store. Downloaded Xbox app. Reboot. Signed into ms store account. Updated anything that need updates. Clicked on get update on top right. Up popped a flight sim update. Downloaded the mandatory update and it is loading now.
The only difference is I re-downloaded the Xbox app-even though I’m on a pc. I guess that did it- what a relief.
It is a ms store issue- not asobo or flight sim.
Good luck.


Same for me… finally! the only thing I did is to (again) run Windows update which updated something. Enough to run MSFS 2020 where the content mgr appeared and I could make all the updates within the content mgr.
Agree it is a MS Store issue with this famous Xbox app we did not have to deal with before
Hope everyone will get this sorted out as well

I also got it to work yesterday. I dont exactly know how but I launched the Sim via the XBOX-app (which also showed me the error message that the sim has to be updated) and I also reset the Windows Store App. At some point the update for MSFS was downloading.

1 Like