Can't Install - October Edition

I finally caved in and bought MSFS after seeing that a VR beta program is opening up. I was an alpha and beta tester before if that makes any difference. The alpha / beta was fully uninstalled as far as I can tell.

I assumed that all the initial “can’t download”, “stuck downloading content” issues were just a problem in the first few weeks and soon fixed. Seems I was wrong.

I tried an install, left it overnight and woke up this morning to it stuck on 9.6gb. I closed and rebooted, now when I start, I press the “Any key” (why, MS why) and I just get a spinner in the bottom right corner. That’s it no error message.

Of course, someone will say “Google for solutions” but most articles are from near the launch date. I have no idea now much of it is still relevant.

I’ve tried

  • Setting English (US) as my default language
  • Rebooting numerous times
  • Disabling antivirus
  • Running as administrator

My internet speed is only ~60mbs so I don’t think I need to try the ‘Net Limiter’ stuff?
What else should I try before I refund this? I’m pretty shocked that things are still in this state after two months.

Search Download won’t begin.
In the search bar there’s a lot of recent activity there.
Regards Dean

as customers it is not our place to search for solutions, we purchased this product in good faith, the least they can do is deliver a robust hassle free experience, at this rate, I am surprised they are making any revenue, or perhaps they just sit back while the customers rectify their issues for them