Cant re-install mfs error Error 0x80073d12, 0x80070005

cant re-install msfs2020. error msgs appears in the xbox app or ms-store
also ms-store wont download any updates!
what to do?
i have done already troubleshooter, sfc, dism, reset store etc!

ASOBO is currently experiencing server connectivity issues.
Did you check to see if your server is OK?
What error message are you getting?

what error msg? u kidding! u didnt read my topic ???

no, and no again, servers are ok!
i have that issue now for 6 days!

but for u again: Cant re-install mfs error Error 0x80073d12, 0x80070005

its an security privilege thing with their weard ms-store rights system!!!

Hi

Please try :

# FIX: Microsoft Store error code 0x80073d12

regards

this ends up in this: error 0x80070005 didnt install gaming services

I’m getting the same error messages from my sim computer which I uninstalled MSFS this morning. Errors out when it tries to download. On my laptop the download is fine…but it does not give me an opportunity to install to a network drive so this avenue is useless ! Anyone have a solution for this?

0x80070005 = windows update error

Try to force windows update
Open Windows Update window, by hitting the Windows key, type “Windows update” and click on it.

In the command prompt type (but, don’t hit enter) “wuauclt.exe /updatenow” (this is the command to force Windows to check for updates).

Back to Windows Update, click on “Check for updates” - you should see the following message “Checking for updates…”. While this is happening, go back to the command prompt and enter the command you typed before

Windows is telling me it’s Up To Date.

EDIT: My error is slightly different 0x80070003 and for the Digital Ownership 0x80073D12 Freshly installed Windows Pro just before installing MSFS.

Please be respectful. People are trying to help you. He was talking about the message, not the error codes.

1 Like

the error msg is the code!
yeah, but now, after 6 days with no success, my nerves are blank!

same here. that didnt do anything. windows is up to date

yeah, the error codes differ sometimes. but its all about the same ■■■■ of that **** owenership rights!

Indeed, that was what I was wondering.

OK. I’m out of ideas. Sorry Guys…

I am trying to download the Premium Deluxe Version and the Digital Ownership. Does it matter which one you choose first? I’m wondering if my un install was incomplete so it still sees remnants of MSFS on my HD?

i did an new account on same machine:

same but ownership was installed. i cant see the gaming services there-.-

It seems like you have done a lot of searching already, but if you haven’t seen this, this link could offer some advice.

last idea. :slight_smile:
the only thing that could help is an in-place upgrade which i did few weeks ago. solved all my problems.
have you tried this?

Yes, according to the install guide, install the ownership last.
https://flightsimulator.zendesk.com/hc/en-us/articles/360015760620-Download-Installation-guides

1 Like

Thanks. Good to know.