Can't run FS through SteamVR?!

Hi all,

I bought MSFS via Steam some time ago and have been running it via WMR+OpenXR with my Reverb G2 up to now, that is, completely bypassing SteamVR. Now I wanted to give this a go to see how performance compares, but until now I have not been able to do so. I tried two ways:

  1. Launch SteamVR. Then, in 2D on my desktop, I tried to launch FS via Steam because the 2D SteamVR app won’t give me the option to launch FS. However, I was prompted that “Flight Simulator is not a VR game” (translated from the German output) and that FS will be run in desktop mode. If I do and then switch to VR in-game, it will just be the standard WMR VR mode which means that If I close SteamVR, FS will keep running in VR mode.

  2. Launch SteamVR and launch FS from inside the 3D SteamVR environment. FS first seems to start but actually launches in desktop 2D mode. In the 3D SteamVR environment, however, FS is tagged as “playing”, but when I try to switch to it in 3D, I’m only getting a sort of popup window with the FS logo including a button which says sth. like “proceed to application” (again translated from German). However, I can’t click that button because at that moment, neither mouse nor keyboard nor VR controllers can’t be used.

Any ideas & suggestions what I am doing wrong are much appreciated!

Meanwhile I’m able to answer this question myself: The only way I got WMR to recognize SteamVR (or vice-versa) was to uninstall OpenXR entirely. I had already set SteamVR as default in SteamVR settings, but that did not pan out. So with OpenXR uninstalled, as soon as I switch to VR mode in MSFS, WMR and SteamVR will launch.

However, after trying different settings I have to confirm that SteamVR gives worse performance than WMR+OpenXR, both in terms of average FPS as well as stutters.

Hope this will be helpful if someone encounters similar issues.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.