Carenado Piper PA-34 Seneca V - FLAP ISSUE

Hello to all the community.
I have a problem with the Seneca V from Carenado.
Everything is perfect, except, when I extend the flaps, the plane immediately nose-down and violently. In my real life experience, I have never had this type of behavior.

Do you have the same problem ?
Is there a solution?

Hope Carenado can fix this problem because the plane is wonderful and it ruins everything.

1 Like

That’s sounds like the issue the Piaggio had when we had the MSFS flaps issue. It would do a somersault with a single notch of flaps.

Log it with Carenado Zendesk.

Are you on “modern” flight model?

2 Likes

Thank you for this feedback. I will try this “modern” flight model.
It was really not clear in the settings. I found on the forum a guide to activate it. I hope this flight model is realistic.

LINK FLIGHT MODEL “MODERN”

Thank you for this tip, I hope this will solve my problem while keeping the realism. I’ll keep you informed. :+1:

Modern is the default, so at some point you switched to Legacy for some reason.

A common one was seing the “realism” sliders, and mistakenly believing that 100 realism was the way to go.

1 Like

I experienced this last night as well. On approach, well under Vfe, I extended my flaps and the plain very violently nosed down. I 100% am using Modern flight model. I believe it’s a bug Carenado will have to fix or work with Asobo to fix. Interestingly, it doesn’t always seem to happen.

This is exactly it. I chose this mode to have 100% realism. The “Modern” flight model is no more explicit than that

For my part, this is produced each time in a configurable flight model. You’re right, Carenado should be able to work in parallel with Asobo. I will try today with the “Modern” flight model and you will have my feedback

Yes, that’s wrong. Do not ever use the “Legacy” flight model unless you have been specifically instructed to use it with a specific aircraft add-on that isn’t implemented natively for MSFS 2020.

In other words, NEVER use “Legacy” mode.

2 Likes

All it needed was a note on that page indicating it should only be used with FSX planes. This is t the first time this has happened.

That is true. There is no exlication in MSFS
:+1:

Hello,
After trying the “Modern” flight mode, I can confirm that the aircraft’s handling is perfect. No more worries about FLAP. There are even the vibrations that were not present before and I also think of other effects that I will find.
Thank you for your help.
Good flight everyone :grinning: :grinning: :grinning: :grinning:

5 Likes

How to switch to modern flight model ? Thanks

It’s under General/Flight Model, if memory serves.

1 Like

If you don’t know how to switch flight models, it is set to modern.:wink:

1 Like

Just watched the video, incompetent nonsense, nothing else.

As the others have mentioned, MODERN is the only useable flight model for MSFS aircraft.
All default aircraft have been designed with the modern flight model.

The funny thing is that you can easily loop a four engined airliner IRL (and in Level-D sims), the difficult part is staying within the g-limit.

By comparing the loops, this incompent guy actually proved that the modern flight model is the more realistic one :rofl:

Il etait sur Legacy…la je l’ai changé…:wink:

What do you mean with ‘STILL broken’? It was never broken and the solution has been posted in this thread.

Confirm that you are unable to extend the flaps?
If yes, that’s a completely different problem than the one in this thread.

1 Like

deleted my post. i was having same issues as OP but didn’t understand the modern flight model. i have just installed MSFS2020 and never changed any flight model settings so it’s odd that it defaults to the one that breaks things.

but i changed to modernand the flaps and AP seem to be working now!

1 Like