Cessna 152/172 pitch control after last update

We’re multiple having this issue as per comments here (FR website) https://www.simflight.fr/2020/10/30/microsoft-flight-simulator-sortie-du-patch-n5/, but can’t find anything on official forums.
We’re basically having pitch control issue with those aircrafts and a user reported having same issue with 320 neo too

WHat I experience is :

Controls seems OK to start with, so takeoff starts but you really can’t pitch more than 5° and if you release the controls, the aircraft pitchs down. Scenario looks pretty much like if you were having a trim wheel working against the pilot (or an AP willing to level the aircraft at all cost against the pilot - but there’s no AP on the 152 so …)

This happened following the last update, everything was working like a charm before.
I do suspect an issue with the controller settings as when I swap my Saitek Yoke with a Saitek X52 (unknown to FS prior to this event) it’s working OK again, but I couldn’t manage finding how to reset those settings.

Using SpadNext or not using SpadNext makes no difference at all btw so … no idea what’s going on !
Changing the flight model from legacy to modern makes it functional again, but that’s at the cost of any realism so that’s a no-no to accept as a solution :slight_smile:

Thanks guys !

eehm… no.

Modern is the realistic new flight model created for MSFS.
The legacy modes are, and should only be used for backwards compatibility with (badly) ported FSX planes.

You even get this warning when switching away from the Modern model:

image

1 Like

@Emaginn

As @MortThe2nd wrote.

Don’t forget that the new, modern FDMs are still WIP.

Hmm … that’s not really the topic, but nevertheless, a few things here :slight_smile:

  • unless my memory fails, I haven’t done configuration prior to this update to choose legacy over modern, so I think it’s the default ?
  • It worked great before the update, and still does with a controller swap so it should work still with the update right ?
  • (I don’t try to be controversial here at all !) - I’ve never flown that aircraft in real life, but x-plane 11 cessna aircrafts are supposed to be pretty close to reality, and I’ve myself found the legacy model closer to x-plane 11 model over the modern one … so …

Anyways, apart from that model vs model discussion, it should keep operating OK regardless of the model in use I’d think :smiley:

Modern is the standard setting, not sure why yours was set to legacy.

Thing is, the legacy models were put in for backwards compatibility reasons, and are not developed further as far as I know.

The modern model is still being improved/optimized. The MSFS plane models (which were designed for the modern flight model) might receive changes as well, which might explain why the legacy modes sort of ‘worked’ before.

It appears that for some unknown reason, the default modern FDM switched to legacy for some users with the latest patch.

1 Like

Ah, specifically to this;

No worries about ‘being controversial’, it’s fine to have a discussion.

In general terms; the FSX model seems to be more ‘on rails’. The main intention with the modern flight model is that it’s modeling wind (and its effects on the planes) more realistically. Things like wind sheer, turbulence over mountains/hills, ground effect, cloud turbulence etc.

Not going to go into the whole rabbit hole of how successful they’ve been at this so far, but that’s the gist of it.

Anyways, main point is, the plane models and modern flight model are still being worked/iterated on. So if you’re using the MSFS planes, I strongly suggest using the modern flight model, since they were designed to work together.

Right - so I’ve switched to that model, and the take-off works OK, and overall is workable.
But I do confirm definitely that is not solving the issue that must be with the way the controller now works as for example, the Flaps fully extends automatically during the flight, while there’s nothing done in particular except flying the aircraft using solely the yoke on a trimmed aircraft (no touch at all at keyboard, mouse, on the mixture/throttle or radio panels)

Any idea on how to reset those controller details as I’m anticipating that’s the way to go ? (I’ve done a complete FS2020 re-download a week ago without success and have nothing in the Community folder)

Thanks !

Stacy was not the default for me, and I’ve never seen any patch change my my flight model, which is why I am a little sceptical of the “patch changes flight model” explanation.

But it does change my graphics settings every time, so who can say for sure?

No. The default airplanes in MSFS are designed from the ground up (pun intended), to work specifically and only with the Modern flight model. They will not, (and cannot), fly or perform as intended by Asobo with the Legacy model active.

The Legacy model is only compatible with aircraft imported from FSX.

Since MSFS release, the Modern model has always been the default setting in the UI. For some reason, after patch 5, that setting changed by itself to Legacy for some users.

It is probably good practice to make a note of all your various graphics and controller settings in the UI, and re-check them after installing a new patch to be sure nothing has been changed by the patch itself.

I did not have an uncommanded change to the Legacy model after the last patch, but I did have some controller assignments change. I have a yoke, throttle quadrant and rudder pedals for my primary flight controls. I also have an X-Box controller, which I use only for the drone camera. When I first installed MSFS, I unbound all assignments from the X-Box controller except the assignments for the camera. For some reason, after Patch 5, the X-Box controller ended up with flight controls and throttles re-assigned. I had to clear all those unwanted assignments out again.

The assignments for my dedicated controllers remained unchanged, but the new (uncommanded) assignments to the X-Box controller caused several conflicts.

So, i’ll consider this problem is solved by now with the modern flight model change (I dislike, but it works)

Definitely though with this update controls have been changed to really weird things and I had to remap them.
Only my flaps issue was actually not due to MSFS but to Spad.Next, which for whatever reason I’ve had the mixture mapped same as flaps control. I wrongly assumed that was because of the controls configuration within MSFS as the aircrafts were behaving weird regardless of Spad.Next usage or not, and missed that one for a few days.

Thanks guys for the replies, appreciate the help here, the last unexplained thing to me remains why with the legacy flight model and the saitek x52 joystick instead of the yoke it works, but I won’t be searching any further on that as I’ve really wasted enough time troubleshooting that thing and will keep using sometimes MSFS & sometimes x-plane

Salut les Gens , je suis français je m’ennui a traduire vos commentaires , je vous souhaite bien du plaisir a traduire le mien …
De plus les développeurs étant français le message passera tout aussi bien …

Depuis ma première heure de jeu j’ai basculé le jeu en “historique” ou “legacy” pour les english …
Clairement le mode “moderne” me paraissait trop “arcade” , le mode “legacy” déverrouillant une quantité d’option non négligeable et recherchant la simulation la plus poussée possible , plus il y a d’option mieux c’est…
Clairement le mode “legacy / historique” propose l’option “réaliste” donc plus de simulation …
Les gens qui raconte que le mode "historique / legacy " sert a faire fonctionner les avions de FSX doivent certainement fumer de bons produits…

En tout état de cause pour avoir une sensation de simulation le mode " legacy / historique" est clairement le mieux , et c est validé par une pilote professionnelle de carrière a la retraite et aussi accessoirement instructrice de vol …

Ceci étant dit, depuis la dernière mise a jour il y a un gros bugs sur la mise a cabrer des cessna 152 et 172 effectivement a la mise a cabrer de l’appareil la gouverne de profondeur vient bien en butée le manche aussi dans le cockpit mais l’appareil lutte contre une butée virtuelle l’empêchant de ce mettre en chandelle .
Pire il lutte pour conserver son assiette horizontale une fois tout les volets rentrés … Bref ces deux avions sont cassés en mode “historique réaliste” et ne rencontre plus aucun probleme en mode "moderne / arcade " mais c’est ennuyant comme la mort …
Merci de fixer ça les gars …
Des bisous pour les développeurs de Bordeaux vous êtes les meilleurs les mecs …
Un landais réfractaire

<replying to this topic in French and to the French speaking community once with this “solution”>

A cela près que je doute qu’un développeur ne vienne traîner dans ce coin du forum qui est “community” :slight_smile: et s’ils le faisaient qu’ils se prennent la tête à traduire ensuite car ils bossent sûrement en anglais uniquement.
Bien que Français moi-même j’ai ouvert ce topic en anglais pour que plus de monde puisse en profiter mais c’est vrai que je n’ai jamais vu une réponse en français non plus sur aucun forum donc …

Ma conclusion pour que les francophones qui chercheraient ce topic puissent en profiter sans utiliser google trad - le mode modern fonctionne, apparemment c’est voulu par les dev et le legacy s’il a fonctionné par le passé n’est pas censé le faire et personne ne passera de temps à fixer un pbm qui n’en est pas reconnu comme en étant un - si ça fonctionnait dans le passé tant mieux pour nous, si à l’avenir c’est mort, tant pis pour nous.

Donc, pour ma part, ça sera alternance MSFS et X-Plane sauf quand/si le modèle “modern” s’améliorait à l’avenir.

Installed todays update and now after take off and several turns the yoke becomes unresponsive…?

Pour ta gouverne tu te trouve bien sur le site officiel de Flight Simulator et oui les développeurs se baladent de topic en topic de temps en temps c est d’ailleurs le principe même du forum sur le site officiel d’une simulation.
Les développeurs sont 100% francais et Asobo studio se trouve au 23 Parvis des Chartrons, 33074 Bordeaux , a minima ils sont francophones …
Donc cette affirmation est totalement fausse "ils se prennent la tête à traduire ensuite car ils bossent sûrement en anglais uniquement " …
Au sujet du bug rencontré depuis la mise a jour :
Clairement la buté virtuel qui s’applique sur Cessna 152 et 172 " et que tu décris comme une "sensation d’autopilote qui empêcherait de cabrer " ne s’applique pas au autres avions .
Ils s’agit clairement d’une erreur de codage et non d’une simulation de physique souhaité par les développeurs …
Quand un mode de jeu fonctionne et se retrouve cassé suite a une mise a jour, la normalité c’est que quelqu’un fixe le probleme justement …
“si ça fonctionnait dans le passé tant mieux pour nous, si à l’avenir c’est mort, tant pis pour nous.”
Tu as une approche très particulière de quel suivis doit être apporté par les développeurs a une simulation a 70€ pièce …
De plus je persiste a dire que le mode “historique” n’est pas un mode dédié a faire tourner les vieux mods d’avion des anciens FS …
Clairement prend le DR 400 fait le voler en mode “Moderne” puis essaye le en mode “historique option réaliste” et là tu va voir la différence entre ce que j’appelle le mode arcade et le mode simu…
C’est d’ailleurs la seule option pour passer le jeu en simulation pure …