Cessna 172 Elevator Trim Wheel is damaged

I fly a Cessna 172 in real Life. Since the Simupdate 5 and also after the Hotfix the Elevator Trim Wheel in both Cessna’s 172 is damaged. I only fly these two planes. The Elevator Trim Wheel reacts to sensible, jumps and makes a strange click sound. Its absolutely not like in real life.

Before Sim update 5 everything was fine and the elevator trim was like in real life. Why did Asobo change a working Trim Function? I don’t understand…

Please repair it fast. For me it is now unplayable and not realistic.

Please Vote for this problem at the beginning. Perhaps it will be fixed soon.

Same happened to me. Only the non g1000 172 was effected though.

1 Like

I have found this too. I can’t trim to level flight as it is too sensitive even using the cockpit gui. I end up having to adjust power for fine trimming.

1 Like

I’ve got this issue in the classic 172
Trim wheel white line position marker jumps to either very top or bottom. Impossible to set visually for takeoff. Trim seems totally stuffed - g1000 variant works perfectly fine

1 Like

Just tried the C172 Classic, after not having flown her for a while.

Sorry to hear your problems. It works for me, though.

Maybe this trim wheel config helps some of you:

Is this going to get fixed at all? The C172 is unplayable for anybody, like me, using a 10 turn potentiometer as a trim wheel. This is ridiculous.

1 Like

I have been having trouble getting my aircraft trimmed with the Cessna Trim Wheel, and noticed today MSFS had Auto Trim option set to ON in the Assistant Menu. I have never used the Assistant/Co Pilot, preferring to fly it myself, but in desperation , I went checking everything I could find, including all key assignments, and discovered this option set to on. When I turned that off, I could once again trim correctly.

If this is your problem, it is an easy fix.

But yes, it is very sensitive and you do need to experiment with the sensitivity settings in the Controls Menu too.

Are you on Steam or Microsoft Store version?


Are you using Developer Mode or made changes in it?


Brief description of the issue:

The Cessna 172 trim wheel still behaves erratically, moving twice forward and once backwards, and produces an unrealistic clicking sound when being adjusted.

As a result of the erratic behaviour, precise adjustment is impossible when using a 10 turn potentiometer.

Detail steps to reproduce the issue encountered:

  1. Use the Cessna 172
  2. Adjust the trim wheel

Build Version # when you first started experiencing this issue:


Use an encoder rather than a pot, even a 10 turns.

I use the trim wheel encoder on my Logitech multi panel, and have no issues with trim. It sounds like an issue with the physical device rather than the sim.

Using the trim wheel on my Bravo on the 152 I can spin it a few times but only get a few clicks worth of trim.

1 Like

The issue only appeared after SU5, prior to this a 10 turn pot worked fine. I appreciate a 10 turn pot will have a more variable value than an encoder but I don’t think this issue is with the pot or setup.

Aside from the pot, there is still the clicking sound which is unrealistic.

1 Like

Same problem After SU6, my honeycomb bravo trim wheel is useless.

Bought MSFS 2020 from MS Store.
Deluxe (NOT premium) Edition
Saitex Cessna Trim Wheel (worked perfectly in SU5 but broken in SU6)
Issue is SU6 when trim is bound to an Axis. Several turns with no response and then sudden trim movement.
When binding trim to button you get immediate trim movement but it returns without command to center all by itself

What can be done about this. I have not been able to use the trim for several weeks now. I am confused regarding how Asobo had it right and then broke it and amazingly cannot fix it. Really thinking of moving to X-plane 12.

1 Like

Have you guys tried using an axis on the Bravo for trim instead of the wheel? I find it annoying that the wheel sends button impulses (rather than acting like an encoder or potentiometer). With a physical lever on an axis you can quickly dial it in, or see where it’s set without looking at the virtual cockpit trim control. The changes to the controls update to update are indeed frustrating though.

Trim wheel in Saitek Multipurpose Panel works fine for me.

1 Like

Sure, mine too.
It’s an encoder (digital) not a potentiometer (analog) !

1 Like

I can confirm X-Plane 11 handles this just fine, if you haven’t already tried.

This is definitely an issue with FS2020.

But specific to a pot driven interface?

In my case yes, specific to a pot driven interface. I’m not sure whether the Bravo trim wheel uses a pot or encoder, can’t find any teardown videos or tech specs that go into detail.

When I first built the pot trim wheel several months ago I tested via breadboard and Arduino and had no issues, I actually have a test video from then that I can upload if needed to show what I deem to be the correct behaviour.

1 Like