Cessna Citation CJ4 Issues and Support

Anyone got a full Check list please?

I have these two:

Checklist 1
Checklist 2

The first is from @JayDee6281 and is probably a bit old.
The second I don’t remember where I got the link form.

About to return to CJ4 after 1+ years so currently working on a new checklist which is essentially what Sharpe put together for WT CJ4 about 1.5 years ago with some improvements of my own after dozens upon dozens of hours flying with this aircraft in VATSIM. Haven’t finalized it yet and I’d also like to cross check it with JayDee’s (his checklists & procedures are always a must).

Mine can be found here for the time being, I should think it’s 99% done and will go 4 pages long (I was using it for WT CJ4 so it has inherited some stuff that wasn’t transitioned to the current aircraft version, e.g. SimBrief and PAX briefing):

Updated 2023-03-14: CJ4 Checklist v1.8 Cpt Zeppos - Google Docs

I take it that no one has managed to turn on these cabin lights indirectly via an LVAR or event or similar, assuming the official product even support cabin lighting in the background. I particularly dislike the lack of cabin lights as I do 90% of my CJ4 flights at night and it feels unrealistic. To me there’s no good reason to not have this implemented via FMS or at the very least a hidden LVAR which can be triggered by those who care about such tiny things as cabin lights. If an official product is not a place for such hacks, then it sounds like parts of the official product are simply a step backwards.

Let’s just hope that popular CJ4 mods like the wooselmod will bring this functionality back at some point.

Often when I fly the CJ4, I select the departure and destination and take off.
Then I activate the autopilot and go to Nav mode, and the aeroplane will follow the flight plan. Now I can’t enter the NAV mode. It says ROL mode on the screen. This may have began after the last update (118gB wifi). Or am I doing something wrong?

I am having the same problem since the last update. Have you found in solution? I don’t find that if I use a flight plan from the world map and engage Nav before takeoff I get LNV1 in green and it starts following the plan but after several way points the FMS system just clears itself and the flight plan is replaced by dashes.

This is related to the AAU1 update, where they are starting to make the avionics more realistic. Two of the more frustrating changes are how NAV mode only follows the flight path when in close proximity, and route discontinuities. If you are far from the route, you have to hand fly or use heading mode to get back before NAV will take over. Discontinuities happen when you get to a point you would realistically get vectored to the next waypoint in the real world. I created this video covering these and other changes on the CJ4. It’s long, but I tried to keep from getting too deep into the weeds and has a walkthrough from cold and dark, planning a route, to flying it.

I have also found out that you must be on the waypoint track for NAV to work. LNV1 may be white until you get close enough to the route. Discontinuitys can often be deleted by pressing CLR and the the discontinuity button.
Another problem with the CJ4: Emidiately after setting on the ground it sets full throttle and takes off again.
What can you do about that?

The CJ4 has no autothrottle so its nothing to do with the aircraft itself. It is more likely to be a keybind conflict in your profile/set up (ie have ‘MAX THROTTLE’ bound to the same button or key as ‘MAX SPOILERS’. But you would need to provide more information. Its certainally not a behavior that others have reported.

Would be great if they could implement state saving for physical switches (I understand there’s been some state saving implementation for the displays).

Often, but not always. That’s why I covered an alternative in by entering a waypoint in its place. You can also wait until in route and at the waypoint prior to a discontinuity, then use the direct to button and select the waypoint after the discontinuity

Hello!
I’ve been flying the new cj4 for some time now and I have a few questions

-im trying to set my v-speeds but the keys required to set them are “not active” is this just a wip function? Or is there a step I’m missing

-since the aau1, I’ve noticed a lack of TAWS callouts, normally I’d get a few altitude warnings once I’m on final but these are no longer there.
In a similar fashion to my first question, is this normal or am i doing something wrong?

-lastly, I’m not too sure if this is a bug specific to the cj4 or not, but 8/10 times, whenever I’ve pulled up the home screen (usually to switch over to either Spotify or Microsoft edge) I will come back, unpause, and the plane will suddenly thrash around and spin out of control, I’ve had to turn off stress damage because it has (on several occasions) killed over 3 hours of flying, simply because I wanted to change the music.
Again I’m not too sure if this is cj4 specific but it would be nice to hear if this will get patched soon

Otherwise I’m very happy with the new update and I’ve had a blast learning the new fmc and flight model
amazing work by asobo and team as always :grin:

Can you explain how you are trying to set your reference speeds?

With this update, you shouldn’t set them directly. You go into the takeoff performance screens in the FMS and enter things like your passenger weight (including pilot), cargo weight, weather info, runway conditions, etc. If you have the runway set in your departure screen, that info will automatically populate in the takeoff perf screen. The FMS will take all this info into account to calculate your reference speeds automatically on the second page of the takeoff perf screen. You’ll see a SEND option in the lower right as well. Press that and it will send those speeds to your PFD next to the speed tape.

I go over this programming in more detail in my video I linked a few posts above. It starts at 30:45 “QoL FMS performance work.” It takes a bit because that’s when I also discovered the battery capacity is now modeled and I had to restart the Flight to get back on track. Lol

Unfortunately I can’t help with the other stuff.

First I set the runway from the DEPP/ARR panel, then I go into the takeoff ref page where it has automatically filled in the runway length and ID
But the next page where the v-speeds are located I get greeted with this

Ive tried to input a speed manually but it tells me the keys are not active. It’s the same deal when I press “send”

Did you enter the temp on page 1 of the takeoff section?

Both of these issues were my own inexperience. As discussed in this post you have fly pretty close to the vector for the first way point before LNV1 turns green and it locks in. Previously it would just find it no matter where it was. The other problem was a discontinuity. Though I deleted it, I forgot to hit execute. The plane is now switching flawlessly from waypoint to waypoint.

Like @GlitteryGecko5 mentioned, you need to enter at least the weather info for the FMS to make the calculations. I don’t think you’re supposed to be able to enter the reference speeds manually anymore.

And for what it’s worth, it’s not a necessary step. The plane will fly perfectly fine without those values. It’s just an optional setup if you are wanting to increase the realism.

Hi,
today was any problem with rudder while taxi. Pedal was turning to the left, but the chassis was not responding (animation in cocpit was correct).
Was there any MSFS update or CJ4?

Sometimes for some strange reason, MSFS stops recognising control inputs, particularly for the rudder . It seems to happen randomly and across all controller types and aircraft. The good news its not persistent.

2 Likes

The throttle in CJ4 behaves weird in other ways to. It often flickers and flutters rapidly.
Sometimes the plane is positioned on the grass besides the runway at start. If so it becomes difficult to taxi to the runway, and if that succedes there is not enough trust to take off. The beech king air or the airbus 320 for example has none of these problems.