Cessna Citation Longitude

Currently, when I use auto-throttle, I’ve been keeping the SPD knob set to “FMS” (not “MAN”) and it’s been working fine when I turn the dial to increase/decrease the speed bug. The aircraft adjusts its speed to that target.

In the past, I would have to switch it to “MAN” to get this behavior. I wonder if this is a new issue?

1 Like

Really? I haven’t noticed that yet. I just took note to not turn it when it’s on MAN because it doesn’t change. Never tried it with autothrottle engaged. Will crosscheck.

Thanks for this great Mod. I did the install/file replacements as directed on the download site. I do not have any Livery’s installed but have all the Working Title mods installed. My problems is that when I am within say 20nm from my arrival airport the sim will loose sound for a second or two and then CTD, up until then all is 100%. I am sure it is a conflicting mod and would appreciate any advice. Need to mention this only occurs with the Longitude (Mod).

Thanks in advance.

I just read the SOPs from our friend, and it looks like according to real life, one should be able to fly a Vref+3kt from 500 feet (plus wind component correction), but no matter how heavy or light I am, I have to stay close to the Vapp all the way. If I keep the Vref, AoA stays in the red.

Further Test : Removed all mods kept only FDFix. Landing/Taxi Lights and Working’s G3000 and no CTD

results-torn

For those interested in seeing the results of my fuel efficiency test using @Dakfly0219’s mod on an intracontinental flight from the Los Angeles area to Miami, you can view it here:

https://forums.flightsimulator.com/t/longitude-fuel-efficiency-test-flight-results-using-the-mod-fix

Is it just me or does anybody else get a CTD when you enter any new destination airport into the FMC during flight? Could not find any reports in this thread.

Greetings, Alex

I know I’m late to the news, but just saw the 12/22 update as of now includes performance fixes for the neglected Longitude. Praying Asobo doesn’t make this disaster worse than it currently is.

1 Like

Where did you see the 12/22 update? Sorry, I can’t find the news.

1 Like

The release of the Longitude fixes on December 22 was announced in this Dev Update:

And from the Development Roadmap:
image

Really looking forward to it :smile:

3 Likes

Yes, and also random CTD mid flight (changing camera from outside to cockpit triggered it). But I was experimenting with the mod linked above. Not had that with the defualt aircraft but I did trigger a CTD entering a flight plan from scratch and adding the destination airport

1 Like

Not having any CTD problems I did 2 flights today with the mod.

Anyone having any issues with the FLC mode in climb? I start out of a climb with 4000 VS and then switch to FLC and it blows right past my 205 KTS that I put in the FLC mode. This is with the Longitude Flight Dynamics version 1.3 as well.

same here. also happens with the default longitude.

You’ll have to reach a desired speed using autothrottle speed mode and then set FLC. I’ve not seen a solution where FLC hold properly if you simply turn it on without use of autothrtottle. IIRC, I’ve also noted if you subsequently turn off FLC and then turn it back on or attempt to adjust autothrottle speed settings during the climb, it doesn’t necessarily do what you’d expect. I don’t believe it’s modeled very well. When I have been performing testing on my modifications, I first set desired altitude. Then I set autothrottle to desired speed hold and once I’ve reached that desired speed, turn on the autopilot and FLC mode. Oh, and then once I reach around 30k feet where the speed mode needs to be switched over to Mach hold, the FLC will not adjust the Mach number with altitude, so it will continuously drop the nose as the effective Mach speed gets unreasonably high effectively ending the climb early. I believe this is a known bug. I have to switch over to VS hold and then babysit the VS until reaching cruise. So, in summary, FLC is hard to use and doesn’t work particularly well in the upper flight levels.

If anyone else has better procedures for getting FLC to work properly please let us know.

1 Like

You can also periodically click the speed knob twice to move it out and back into Mach mode. Then readjust the desired Mach number. Also, just change the Mach number up and down again manually periodically will do. Basically, any kind of change to the Mach value will get the aircraft to re-compute everything.

I’ve been able to get FLC to work without auto throttle being on also. But you can’t use full throttle. You have to adjust your throttle to produce a reasonable vertical speed.

I’ve done that too, and then the FLC makes “bounces” the nose up and down as it recomputes the climb angle. Wouldn’t be a particularly smooth ride IRL. LOL

In my mod I actually played around with limiting the autopilot max pitch rate to avoid this problem. Otherwise, I’ve seen climb rates over 8000 fpm - that would be an interesting ride for your discerning executive class passengers.

Oh really? Sounds like the pitch PID could use some adjusting. I’ll look into it.