Cessna Citation Longitude

Also get the WorkingTitle G3000 mod. They both work together very well.

I used to fly with TBM, A320 and DR400…Tried the Longitude for the first time so…No, it was not modded yet.

Pretty much anyone who’s attempted to operate the default Longitude since initial publish has been quite frustrated with performance, weight, range, handling and autopilot deficiencies. My mod addresses a significant number of the issues.

3 Likes

I pre-set climb speed and use VS mode to control rate of climb below 10,000 since I find FLC mode always blows by the 250knot speed restriction when you are below 10,000 regardless of what speed is dialed in. In FLC mode I get some crazy rates of climb after takeoff which probably would be uncomfortable for the passengers ! I tend to use FLC mode above 10K when climbing out to cruise altitude. Do you find this behavior as well ?

I find that FLC is buggy in general, especially when tied to auto-throttle. I’ve even seen the engines go over 110 percent in transient spikes as the FLC / auto-throttle combo will redline the engines and then some. I haven’t found a way to fix this in my mod or using controls within the sim - I believe the problem is embedded in those still encrypted xml files. Conversely, especially when taking off light, the auto-throttle won’t hold the set speed and will start to bleed off airspeed below the target KIAS setting as the a/c climbs into the FL200s. It seems the FLC mode in the sim for the Longitude will choose whatever climb attitude maximizes climb for the given airspeed, but since the engines are running well past red-line, I do see some very high climb rates, especially when the a/c is light. In my mod, I’ve limited the autopilot climb angle to 12.5 degrees just to keep the a/c from trying to go into the vertical (the default setting was 25 degrees, and I would see that early in my experimentation with the configuration files), but it still seems to just want to go full out with no N1 limit respected.

Anyone else seeing this type of behavior too?

1 Like

For version 1.4 of the mod, I’ve flown it almost 6000 miles, for almost 12 hours over the course of two flights at FL450. Both flights had very similar (if not the same) fuel efficiency (see Bangkok and Darwin below)…

All the prior flight segments used v1.3 or older.

.
For those that are curious, here’s what I’m currently doing with the Longitude (with both @Dakfly0219’s mod and Working Title’s GX000 mod…

My “Seven Continents of Flight” tour:
https://forums.flightsimulator.com/t/seven-continents-of-flight-in-the-citation-longitude

1 Like

Somehow it became hard for me holding altitude. FLC is weird so I am using VS. At FL it’s bouncing up and down and the ATC is having a hard time telling me to descent or climb. I did not change anything after fix 1.3 but installing 1.4. I changed weather, reiinstalled AC and fix and even the game but with no luck. Remembers me of the original AC. All I do is set speed with autothrottle armed. Bevore the fix it was an issue with the pumping AT and now it seems also holding altitude. I wonder if that is my problem, or sombody else is experiencing this. I am at the point moving back to the original. Anyway, the 22nd is soon.

I’ve had one other report of this issue. Are you interested in testing a configuration change to see if the problem can be resolved?

Yes please. Anyrhing is better than the default one.
EDIT: Pls PM me, I’m done and it’s past midnight over here. Pls with a short “how to install”.

Yes, I’m happy to help too

This early morning I tried several times to takeoff from Sydney and the plane got somehow berserk. Never expirienced anything like that. I thought - this is it. I deinstalled the mod and then the AC. Reinstalled and everything smooth like a charm. ± 10ft at altitude. Why all this? Don‘t ask me :joy:. For the moment no cfg change needed - thanks.

Anyone know how to confirm mod is installed? I downloaded 1.4 and I think I have everything in correct file locations, but I cannot find this: "When Livery selections are made, the Longitude will display the following in the variant area “FDE Fix V1.4’” Where do I look?

Also there are two layout.jso in the longitude folder (one in main asobo longitude and one in Simobjects/airplane subfolder) do I replace both?

You only need replace layout.json with the one at top level of install file package. Not both.

FDE fix v1.4 will appear on the aircraft selection screen when in the liveries selection area for the Longitude. The default Asobo livery will show this description.

Hmm…when I replaced the layout.jso at the top level (Official/Steam/asobo-aircraft-longitude) with your .jos file the longitude disappears as an aircraft choice in the game?

Did you follow the instructions included on how to install it? Did you also install the mod in the community folder?

Yes. the mod is in the community folder. I have installed many mods in community without a problem and this one seems straightforward too. So I am not sure what I am doing wrong with this one? It seems to be that somehow I am not putting the .jos file in its proper location?

OK, just to clarify, you are putting the longitude mod, a sub folder, in the community folder. And you’re putting one .JSON file in the official Longitude folder replacing the existing . JSON?

And you removed any existing Longitude mod first, correct?

Here are screenshots of locations. The json location is where I replaced original and now the longitude does not show in the game.

Yes…the only mod I did not delete was the lights mod, which I believe is a separate mod.

Usually when that happens it’s a problem with the official aircraft. I suggest you delete it and use the content manager to download it again. Then verify the aircraft is back. Then replace the .JSON file in the official folder again.