Cessna Citation Longitude

Make sure you set your speed and don’t use the FMS speed. Use the manual speed and adjust as needed. 185-230 on the ground and after takeoff and gear up, depending on restrictions, adjust to 250 till 10,000, then 270 till you reach mach 0.80. I also engage FLC as soon as I get to 210. Works like a charm each time.

It just does not work for me.
Meanwhile, I can see this in the patch notes 1.8.3.0 :
“Cessna Longitude : auto throttle is now inhibited during take off and until 400 feet AGL”
So, I understand that the fact it does not work for me is normal…But how is it possible that it’s working for you? :slight_smile:

Are you using the mod package I’ve created or the default Longitude?

I’m just now exploring the Longitude and I love it. Incredible power, yes. And I remember early on I was forgetting to back off the throttles during climb out and would get, “Overspeed, overspeed…” but for some reason, multiple flights later, I don’t hear that anymore. Even when I’m clearly throttled into the red/white zone. Did I just ■■■■ the guy off or something? I kind of miss him.

Jim-Sim

Default…

Others are using the mod package I created. It doesn’t limit autothrottle on ground - it’s one of the few autopilot / autothrottle flags I have available to adjust and I felt better for now to leave that capability than remove it.

OK. Thanks for the answer. I’ll have a look at your mod.

What?! You’re not using the mod? Thou hast sinned greatly, but I forgive thee in the name of me, and of me, and of me! Go and sin no more :smile:

Also get the WorkingTitle G3000 mod. They both work together very well.

I used to fly with TBM, A320 and DR400…Tried the Longitude for the first time so…No, it was not modded yet.

Pretty much anyone who’s attempted to operate the default Longitude since initial publish has been quite frustrated with performance, weight, range, handling and autopilot deficiencies. My mod addresses a significant number of the issues.

3 Likes

I pre-set climb speed and use VS mode to control rate of climb below 10,000 since I find FLC mode always blows by the 250knot speed restriction when you are below 10,000 regardless of what speed is dialed in. In FLC mode I get some crazy rates of climb after takeoff which probably would be uncomfortable for the passengers ! I tend to use FLC mode above 10K when climbing out to cruise altitude. Do you find this behavior as well ?

I find that FLC is buggy in general, especially when tied to auto-throttle. I’ve even seen the engines go over 110 percent in transient spikes as the FLC / auto-throttle combo will redline the engines and then some. I haven’t found a way to fix this in my mod or using controls within the sim - I believe the problem is embedded in those still encrypted xml files. Conversely, especially when taking off light, the auto-throttle won’t hold the set speed and will start to bleed off airspeed below the target KIAS setting as the a/c climbs into the FL200s. It seems the FLC mode in the sim for the Longitude will choose whatever climb attitude maximizes climb for the given airspeed, but since the engines are running well past red-line, I do see some very high climb rates, especially when the a/c is light. In my mod, I’ve limited the autopilot climb angle to 12.5 degrees just to keep the a/c from trying to go into the vertical (the default setting was 25 degrees, and I would see that early in my experimentation with the configuration files), but it still seems to just want to go full out with no N1 limit respected.

Anyone else seeing this type of behavior too?

1 Like

For version 1.4 of the mod, I’ve flown it almost 6000 miles, for almost 12 hours over the course of two flights at FL450. Both flights had very similar (if not the same) fuel efficiency (see Bangkok and Darwin below)…

All the prior flight segments used v1.3 or older.

.
For those that are curious, here’s what I’m currently doing with the Longitude (with both @Dakfly0219’s mod and Working Title’s GX000 mod…

My “Seven Continents of Flight” tour:
https://forums.flightsimulator.com/t/seven-continents-of-flight-in-the-citation-longitude

1 Like

Somehow it became hard for me holding altitude. FLC is weird so I am using VS. At FL it’s bouncing up and down and the ATC is having a hard time telling me to descent or climb. I did not change anything after fix 1.3 but installing 1.4. I changed weather, reiinstalled AC and fix and even the game but with no luck. Remembers me of the original AC. All I do is set speed with autothrottle armed. Bevore the fix it was an issue with the pumping AT and now it seems also holding altitude. I wonder if that is my problem, or sombody else is experiencing this. I am at the point moving back to the original. Anyway, the 22nd is soon.

I’ve had one other report of this issue. Are you interested in testing a configuration change to see if the problem can be resolved?

Yes please. Anyrhing is better than the default one.
EDIT: Pls PM me, I’m done and it’s past midnight over here. Pls with a short “how to install”.

Yes, I’m happy to help too

This early morning I tried several times to takeoff from Sydney and the plane got somehow berserk. Never expirienced anything like that. I thought - this is it. I deinstalled the mod and then the AC. Reinstalled and everything smooth like a charm. ± 10ft at altitude. Why all this? Don‘t ask me :joy:. For the moment no cfg change needed - thanks.

Anyone know how to confirm mod is installed? I downloaded 1.4 and I think I have everything in correct file locations, but I cannot find this: "When Livery selections are made, the Longitude will display the following in the variant area “FDE Fix V1.4’” Where do I look?

Also there are two layout.jso in the longitude folder (one in main asobo longitude and one in Simobjects/airplane subfolder) do I replace both?