CH pedals fine.... until reboot

I plugged in my CH Pro pedals, set them up in FS2020 and they worked fine , until…
The next time I rebooted the computer, they were ‘dead’.
I checked in the device manager and they were reported as ‘OK’, but I couldn’t calibrate them or anything.
FS2020 also reported them as installed and properly set up, but nothing.
The only way to get them to work was to come out of FS2020, unlpug the USB, reboot the computer and plug the pedals USB in again. the ssame happens each time I turn the computer off. I’ve also tried all the available USB ports, but get the same results so it can’t be the pedals themselves.
Any ideas…? Thanks!

Do you have them plugged directly into the PC USB ports or into a USB hub?
I have the same CH products pedals and they wont work through my USB hub, only work plugged directly into the USB on the back of the computer.

I also downloaded the latest CH control manager and set it up through that first.

Hope this helps, worth a try. Good luck.

Hi - thanks for the response.
They’re plugged directly into the computer, although I have tried them through a USB hub but got the same problem.
The issue seems not to be with the sim, but with the computer (Win10). The device manager reports them as being ‘OK’ but on properties, can’t calibrate them as they’re ‘dead’.
I’ve also installed CH control manager and tried again, but still get the same symptoms - they’re recognised as being there, but no functionality…
As long as the computer is on when you plug them in, they’re fine. But as soon as you turn the computer off or reboot it, they’re there but dead until you unplug them and start the cycle over again.

Somewhat related to the original post. After the most recent mega-update, my CH Products Pro Pedals no longer function in-game. This is referring to the tor breaks, not the rudder, the rudder is fine. When I am taxiing or landing and I push down on my toe brakes, they do not slow down the aircraft. This is weird because when I go to the sensitivity tab in the settings, they are shown as working. PLEASE HELP!

My 15 year old CH Pedal toe-brakes work flawlessly in the Sim since the update, so there must be something else going on. In the Control Options within the Sim, do you have the brake axis “Reverse Axis” button checked?