CH Pro Flt Yoke Help needed

Just bought second hand ch products flight sim yoke. Tried in several sims and worked perfectly. In FS2020, I assign Ailerons Axis Joystick L -Axis X and Axis Y for Elevator. All other assignments function well: throttles Axis buttons ext. Have Ch pro pedals too which work perfectly. When you push on rudders in Conrol menu white bar moves. When I do the same with yoke no movement in bar; Yet, in Sensitivity display view all Axis including x and y yoke move perfectly. Then in game everything works except the xy yoke Axis.

when I use the scanner option and move the yoke, I then get X+, Y- ext. Yoke then responds but left or right yoke movement on my physical yoke will produce ONLY left or only right in game.

Saw videos of others having success assigning x and y Axis but in my case FS2020 wont respond. Like I said, Iknow it’s not the yoke since it works in other games. Also clearly FS2020 recognizes x and y Axis since it responds smoothly in “Sensitivity” just not when assigned.

Please help! Getting so frustrated especially since all other joystick functions work except the most essential.

Would appreciate any suggestions or at least suggestions for another yoke that will be plug and play withMSFS2020 if I can’t figure out the issue with the CH Yoke. Thanks! And this is my first post by the way.

Happy Flying!

In Sensitivity, are the following set as listed here for JOYSTICK L-AXIS X and Y?

SENSITIVITY- 0% (slider at midpoint)
SENSITIVITY+ 0% (slider at midpoint)
DEADZONE 0% (slider all the way to left)
NEUTRAL 0% (slider at midpoint)
EXTREMITY DEAD ZONE 0% (Slider all the way to left)
REACTIVITY 100% (slider all the way to right)

If not, adjust manually or click RESET.

The graph above each should show a right leaning diagonal line, with the dot on the line at or close to center of the graph.

Hope that helps.

Beyond that, only thing I can think of would be to uninstall/reinstall.

Managed to get it working by using CH control manager. It acts as an intermediary between the driver and the game I believe. For some reason when I use mapping mode in the control manager, FS2020 recognizes the yoke x and y Axis. The first time the yoke worked the ch pedals worked as well. Now I can only get one or the other to function. Guess it’s progress. Haven’t tried reinstalling the game yet.

Thinking about selling the CH yoke and getting a new one. Are there any yokes that FS2020 has profiles for. Was looking at Logitech G Flight Yoke System with throttle quadrant. Does anybody know if this would be simple plug and play with MSFS2020. Any other yoke recommendations for reasonably priced yoke sure to work?

Thanks

Do you have any devices plugged in other than the Yoke & Pedals?

When I had symptoms like you described, they were caused by having multiple devices assigned to the same axis. I have four separate CH devices (Yoke, Pedals, Throttle, FighterStick). I leave them all plugged in because I will switch to the Stick/Throttle/Pedals for IL2 Great Battles. I also use the throttle for MSFS for the buttons but not the throttle itself.

In my CH Control Manager profile I had to make sure that I set my unused axes (Throttle slider and FighterStick X/Y/throttle) to DX Device “None” and DX Axis “None”.

Sorry if this is a bit hazy; I got it working months ago and haven’t really messed with it since then!

No I unplugged everything accept the pedals and yoke. Ill take a closer look at my profile settings. When you used CH Control Maneger, did you have it in Mapping Mode? When I do that, FS2020 calls it something like Control Device 1 instead of CH Flight Yoke. Only then will it take input from the X and Y axis. When I don’t use Mapping Mode all other buttons and axises work (throttle mixture ext) except Axis X and Y. However when I do use mapping mode, it won’t detect my Pedals except for one time. I dont know what I did that one time differently but at least it shows it has the potential to work. Ill keep at it a little longer before I throw in the towel. Thanks for your input!

I am using Mapped Mode as well.

Apologies in advance for the long-winded stuff below. Hopefully something in here will be helpful.

In CH Control Manager, take note of the “DX Device” setting for each axis. Those are in a drop-down box that can have values None, CM Device 1 through CM Device 16, and Mouse. The name in that box is the name that Windows sees for that device. This also tells you where to look in the MSFS Controls page, which names your devices “CH Control Manager Device 1”, “CH Control Manager Device 2”, etc. CH Control Manager may not assign those names in the way that you expect, but you can change them.

Likewise pay attention the the values of the DX Axis setting for each control axis. Each CM Device can have six axis values (X, Y, Z, R, U, V) or None, or Slider values which I don’t use. Those names don’t quite line up with the names in MSFS.

If you don’t see the DX Device and DX Axis drop-downs in CH Control Manager, check to make sure that the “DX Mode” check box is enabled.

In my case, my pedals are old so neither toe brake axis works. I should probably take it apart and try to fix them. In any event, this leaves me with six axes to map. So, I used “CM Device 1” for both my Yoke and Pedals, like the table below.

Axis CH Control Manager MSFS (CH Control Manager Device 1)
Ailerons CM Device 1 X Axis Joystick L-Axis X
Elevators CM Device 1 Y Axis Joystick L-Axis Y
Rudder CM Device 1 Z Axis Joystick L-Axis Z
Throttle CM Device 1 R Axis Joystick R-Axis Z
Propeller CM Device 1 U Axis Joystick R-Axis Y
Mixture CM Device 1 V Axis Joystick R-Axis X

Yes, Axes R, U, and V in CH Control Manager map to MSFS R-Axis Z, Y, and X in that order. Don’t ask me why; the Help file in CH Control Manager just says that’s the way it is.

Make sure the “Centered” check box is set for the control surfaces, but not set for the T/P/M levers.

If you’re also mapping your toe brakes, you’ll probably want to make your Pedals CM Device 2 in CH Control Manager and therefore CH Control Manager Device 2 in MSFS. The important thing is to make sure the name in the CH Control Manager drop-down matches the device name that appears in MSFS!

The other thing to double-check is that each axis is assigned at most once among all the CH Control Manager devices listed in MSFS. Setting the “Filter” to “Assigned” lets you quickly flip through each device and make sure the only mappings are the ones you expect.

I also experienced the same issue. “Joystick L -Axis X” and “Joystick L -Axis Y” assigned to Ailerons and Elevator. In the Sensitivity window I see dot move from changing the Yoke X and Y. But in the parent mapping window where Ailerons and Elevator are assigned the white range bar would not move.

I installed CH Control Manager and tried the idea of switching from “Direct Mode” to “Mapped Mode” but no luck there. I created a CH Control Manager profile without configuring any changes and “downloaded” it to the CH Control Center. That worked but for some reason did not sit with me right as the solution so I uninstalled all of it and started over.

However what I saw during all these experiments (a solid 5 hours worth of hitting the head against the wall) had tipped me off to what the real problem was… Using the FS2020 default suggested/predefined mapping as the starting point to map the Yoke causes the problem.

The solution to all this madness is just start with a new/empty/blank FS2020 yoke mapping profile for the Yoke and add each axis/button fresh. As you add each axis you will notice it works immediately moving the white range bar. I think the default predefined mapping FS2020 provides as a starting point has incompatible values in the xml config file it generates which prevents the X and Y from working.

I think this is a good point. IIRC, MSFS did not include a default mapping profile for CH Products gear at initial release. So, I also created my profile in MSFS by manually assigning each axis and button to the functions I wanted.

Thanks everybody for your help. I finally got it to work! I found a different solution before I got a chance to try some of the suggestions above. I used a mapping program called Joystick Gremlin. It allows you to map a joystick to a “virtual joystick” called Vjoy. So, using the software, I mapped the X and Y axis of CH Flight Yoke to Vjoy. Then, in MSFS2020 controller settings, I saw 3 devices: CH Pedals, CH Flight Yoke, and Vjoy. Assigned everything as default except for Elevator and Aileron Axes. I assigned those axes to the X and Y axis of Vjoy.

I think its basically the same process that @KellyHrdina described above using CH Control Manager. I just used a different mapping software. Might want to checkout Joystick Gremlin. Pretty useful program. Anyways, just glad I finally got it working. Thank Again!

Edit: Upon playing with it further, realized rest of axes weren’t working either. Mapped them all to Vjoy. Names between Vjoy axes and MSFS2020 didn’t necessarily correspond. Used the scanning option instead of picking axes manually. May not be the best solution but did the trick.

2 Likes

@CaptainJack8155 you can mark your own last post as the Solution rather than editing your title by hand. Select the … menu on that post and use the Checkmark symbol. It will append a Solved to the title and post a copy/link of the solution inside the first message on this thread. Or let us know if we can assist you with that.

I’m glad you got it sorted; happy flying.