CH Pro Pedal Configuration Issues

Good morning forum,

I recieved my pedals yesterday and (for the most part) they seemed to be plug and play. The rudder is working right out of the box but the brakes do not seem to work.

I have followed a few videos and what I am seeing is that it is setup as an axis, but when I press the brakes the axis does not move, nor do the brakes move in game.

If I re-map it (clear the config and then let it auto detect when I press the brakes) it switches from an axis to a button, but this doesn’t work either.

The only way I’ve managed to get the brakes to work is to apply it to a brake button and then one brake comes on.

Am I missing something?

Thanks in advance.

Search for “Set up USB game controllers” in the windows search (not a browser) and run the control panel applet.

DO NOT CALIBRATE - calibrating CH pedals in Win10 messes them up (if you already calibrated reset the pedals to defaults)

Observe the brake pedal movement and see what it does, report back here

1 Like

Thank you!

I will give it a try shortly, I have not calibrated in Windows as I saw mixed mesages on here and other places as to whether or not I should.

I’ll let you know shortly.

That seems to have done it,

I launched it and the pedals wern’t listed, unplugged and re-pluged and up they came. Then went into controls in MSFS.

So as an “axis” they do not seem to work (pressing the pedals doesn’t make the axis move) if I go into sensitivity I do see it move.

I tried various options and the one that made it work was instead of using axis, use Right Brake and Left Brake (without axis).

Is that how it should be? The video’s I was watching all had the axis but this seems to work?

One other thing to be aware of, you may have to check the Reverse box. I can’t speak for all the different rudder pedals out there but on mine if I don’t check that box the brakes are released when I press the pedals and set when I don’t press them.

1 Like

I am not sure. You may be getting an "all on or all off " thing rather than degrees of braking.

Test them, and if they are working as expected then leave well enough alone. However, if touching the brakes seems to jam them fully on you may need to revisit it.

1 Like


You’re right, it isn’t gradual it’s all on / off (like a parking brake).

So, don’t beat me, but…

I just did what you said not to do (calibrated) and it’s working with the axis now and varying degrees of pressure as I believe it should.

1 Like

Thank you sir, yes I also had to check reverse to get them in the correct orientation.

Thank you for the reminder.


Not sure you’ve already got the answer or not. My pedal initially the break is not smooth. I need to download an app from CH call CH Manager and install it. The break gone smooth after that.