CH Pro Yoke Pedals not recognized by MSFS after OS reinstallation

Hi there, I had problem launching the simulator so Zendesk recommended a reinstallation of Windows 10, and of course all the programs/Apps on it. My Ch Pro Yoke and pedal worked perfectly before, but after all the hassles of installing the OS and programs MSFS20 no longer recognizes the devices in the Option/Controls panel. I unplugged and plugged back in, the computer makes a sound indicating they were connected well. I did some research but fruitless. Any help is greatly appreciated.

Does Windows recognize them? Run the “Set up USB game controllers” app and check.

1 Like

Thanks. I have figured it out. In case anyone has the same problem, here is the solution: go to CH Products website, download the control software and install. Though the devices are plug and play, in my case probably the OS didn’t automatically install the driver, the control software has its built in driver to install.

Closing topic as solved.

There is also a topic of the same in this category: #self-service:peripherals