CH Throttle Quadrant + TBM930

I have a 6 lever CH Throttle Quadrant and it works just fine in any plane except the TBM930 and just cannot seem to get it operating right.

The issue is, when i use the throttle lever when cold and dark still, i it goes right out of the Feather in low Thrust power. Then if i try to move the Prop Pitch Level, its the throttle in game jumps to about everywhere, and cannot be controlled at all, it just keeps jittering.

I tried to make a whole new profile for the TBM with the Quadrant, disabling 4 levers, and only keeping Throttle and Prop Pitch, but same result, as soon i move the Pitch lever the Throttle in game goes jittering.

One throttle lever with 5 ddisabled, works, but i dont get the full range suddely, and the Throttle keeps idling at 20% power mark

OFC, i never tried to fly the TBM with the Quadrant, as its obvious thats impossible due the weird acting of the throttle, and if i want to fly it, i have to disconnect the Quadrant and use my Yoke’s throttle lever
Alse tried adjusting it in SPAD.NEXT but i just cannot figure out how to make the Quadrant work with the TBM.

I do notice the Quadrant uses the lever range differently as the throttle lever on the Yoke, wher it follows Z0 to Z+ while the Quadrant goes from Z- to z+ axis, and i think it has to do with that. why it isnt working, but havent figured out how the quadrant go from z0 to z+ range instead of z- to z+

Anyone else using the Quadrant having this issue ?

I use a 6 lever axis as well and fly the TBM too. Use only 1 lever for throttle. I slide all the rest of the levers to full forward before starting and then do not touch them, they like to kill the engine. You must use the mouse to bring the sim lever into LO/ HIGH Idle and also to cross into taxi range. I have not yet been able to get the reverser to work properly so I simply brake hard.

Thrust reverser i use (For the King Air 350i) with button 1 at “Hold for Thrust Reverser” and then just have to apply throttle again to engage thrustreverser.
And i see the TBM throttle slide into reverser using the same key combo as well, but as i said havent flow the TBM with the quadrant, the response is just too irregulair to be trusted atm IMHO…

And use button on my yoke for hold reverser and just apply throttle on my yoke for the reverser on the TBM

So it seems if i read you correct, that you have the same issues… atm i have been able to change the behaviour of the throttle in SPAD.NEXT to the range used by my yoke, but MSFS somehow overrides this again to -z to +z axis :frowning:


I know this is an old post but I’m having the issues described here- ie jittery throttle but only in the TBM- is this a known problem? Thanks.