"Checking for updates"

There are a lot of topics in here about this and none of them have a solution. Randomly today I opened my game and it’s been stuck at a “checking for updates” screen for 35 minutes… my internet is fine. I’ve restarted my computer, I’ve logged out of Xbox, relogged in and the problem is still happening. This is the first time this has happened and I’ve had the game since release.

Does anyone have a VALID solution that does not include reinstalling my entire game?

3 Likes

I am having issues today and also looking for a fix which doesn’t require a full reinstall. I’m stuck at the Monument Vally screenshot with busy icon continually after multiple attempts. Tried emptying community folder but no muck…

MS Store bought:
Go to Win 10 Settings and then Apps. Uninstall FS2020.
Then go to Microsoft Store and install FS2020.

MS Store will download the initial 1.06GB and then run FS2020.
It will not download the additional 109GB if yours is still intact.

I don’t know about Steam bought.

Did you empty your community folder and then try?
Log in and out of MSStore?
How much Ram do you have?

Re-installing may not help.
Most of your settings are kept “In the Cloud” and are restored when you re-install.

2 Likes

SHould probably add to remove the small flight sim app and not the actual large game app file.

@biggathebeast I know you say the internet is fine but might be worth just trying a internet reset, sometimes it can look fine but not always consistent.

Hi!

I had the same problem yesterday morning. When I came back home, In the evening I restarted the modem and everything came back to normal.

Thanks for the replies everyone. My community folder only has liveries, no additional mods so I don’t think that was the problem. All I did again was log out of the Microsoft Store, restart, and then I relogged in and it loaded into the game shortly after the “checking for updates” screen… so weird.

1 Like

Try relogging in, that’s the only thing that worked for me.

1 Like

after playing around with combos of add ons in the community folder, I gave up and ran some windows and os updates - all running fine now…

3 Likes

Yes, it sounded to me like your login to your Xbox account was messed up.

I had an issue a while back where an update screwed up, which in turn corrupted my log in. I had to go so far as to log out, uninstall the Microsoft Store and the Xbox app, reinstall them, then log in again and that fixed it.

A lot of times, however, just logging out and logging back in will fix things.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.