Choosing between Mouse and Optimized VR is the question?

[English translation of the original text below]


I come to expose my concern of setting for MSFS 2020 (Microsoft store version) in VR mode (virtual realie).

First of all my hardware configuration:

  • AMD ryzen 9 3900x processor
  • X570 gaming plus motherboard chipset
  • Ram 32 go 3200 Mhz
  • HDD SSD for drive C:
  • DD 2to for cache storage msfs2020
  • RTX 3090 graphics card for 1st FOX SPIRIT curved screen (3840x1200 resolution in 120Hz)
  • GTX 1060 TI 6GB RAM graphics card for 2nd screen for the remote display of aircraft landglass in Home mode COCKPIT
  • HTC VIVE COSMOS headset
  • SAITEK lifter


  • Windows 10
  • Premium version MSFS2020
  • Latest up to date NVIDIA GAMEREADY drivers.
  • SteamVR updated with the latest BETA version, options developed on 350% oversampling.

What is happening:

1st CASE:

-When I plug in my VIVE COSMOS headset, steamVR opens and recognizes it correctly, I don’t turn on my controllers because I know MSFS2020 does not support them at the moment. I run MSFS2020 which opens on my desktop. I switch to VR mode with the CTRL + TAB key combination. I get my display in my headset + on the Windows 10 desktop of my WideScreen screen. I can set up my new flight and get started. I get a slightly blurry view that does not allow me to correctly read the various instruments on my aircraft’s dashboard. The mouse is visible in my helmet and allows me to operate any activatable button in the cockpit. On the other hand as soon as I move my head the movements are not fluid (jerky) and give me air sickness.

2nd CASE:

-If I minimize the MSFS window that is on my Windows 10 desktop, then I no longer displayed a mouse in my headset. I can therefore no longer use it to operate the activatable cockpit buttons. However, the quality of the display is superb and the movements of the heads are fluid with a very good sharpness which makes it possible to read the instruments well and to have a clear landscape, to see superb.

Conclusion: If I set the maximum number of buttons on my HOTAS I can do quality simulation in VR but if I need to use the functions of the instruments of the G1000 for example, which can only be adjusted with the mouse , I have to go back to degraded mode (CAS 1) with a movement which is not smooth and which gives me seasickness during the settings and then switch back to good config (CAS 2). Which is not obvious during a flight.

Observations: I have tried changing advanced settings in SteamVR developer mode and also switching to direct mode or without it without success.

QUESTIONS: Is there a way to have a good display quality like in my first case with the possibility of using the mouse? Is there an external plugin that must use one of the 2 controllers supplied with the VIVE COSMOS headset?


=== Texte original en français ===

Je viens exposer mon souci de réglage pour MSFS 2020(version store Microsoft) en mode VR (realie virtuelle).

Tout d’abord ma configuration matĂ©riel :

  • processeur AMD ryzen 9 3900x
  • chipset carte mĂšre X570 gaming plus
  • Ram 32 go de 3200 Mhz
  • DD SSD pour le disque C:
  • DD 2to pour stockage Cache msfs2020
  • carte graphique RTX 3090 pour 1er Ă©cran incurvĂ© FOX SPIRIT (rĂ©solution 3840x1200 en 120Hz)
  • carte graphique GTX 1060 TI 6GO de RAM pour 2Ăšme Ă©cran pour affichage dĂ©portĂ© des landglass des avions en mode Home COCKPIT
  • casque HTC VIVE COSMOS
  • palonnier SAITEK

Logiciels :

  • Windows 10
  • MSFS2020 version premium
  • Dernier pilotes NVIDIA GAMEREADY Ă  jour.
  • SteamVR Ă  jour avec la derniĂšre version BETA, options dĂ©veloppeur rĂ©glĂ©e sur 350% de supersampling.

Ce qui se passe :

1er CAS :

-Quand je branche mon casque VIVE COSMOS, steamVR s’ouvre et le reconnait correctement, je n’allume pas mes contrĂŽleurs car je sais que MSFS2020 ne les prend pas en charge pour l’instant. je lance MSFS2020 qui s’ouvre sur mon bureau. Je bascule en mode VR avec la combinaison de touches CTRL + TAB. J’obiens bien mon affichage dans mon casque + sur le bureau Windows 10 de mon Ă©cran WideScreen. Je peux parametrer mon nouveau vol et commencer. J’obtiens une vue lĂ©gĂšrement floue qui ne permet pas de lire correctement les diffĂ©rents instruments du tableau de bord de mon avion. La souris est visible dans mon casque et me permet d’actionner n’importe quel bouton activable du cockpit. Par contre dĂšs que je bouge la tĂȘte les mouvements ne sont pas fluides (saccadĂ©s) et me donne le mal de l’air.

2eme CAS :

-Si je rĂ©duit la fenĂȘtre de MSFS qui est sur mon bureau de Windows 10, alors je n’ai plus l’affichage de la souris dans mon casque. Je ne peux donc plus l’utiliser pour actionner les boutons activables du cockpit. Cependant la qualitĂ© de l’affichage est superbe et les mouvements de tĂȘtes sont fluides avec une trĂšs bonne nettetĂ© qui permet de bien lire les instruments et d’avoir un paysage net, voir superbe.

Conclusion : Si je paramĂštre le maximum de boutons sur mon HOTAS je peux faire de la simulation de qualitĂ© en VR mais si j’ai besoin d’utiliser les fonctions des instruments du G1000 par exemple, qui ne peuvent ĂȘtre rĂ©glĂ©es que grace Ă  la souris, je suis obligĂ© de repasser en mode dĂ©gradĂ©(CAS 1) avec un mouvement qui n’est pas fluide et qui me donne le mal de mer le temps du rĂ©glages et rebasculer en bonne config(CAS 2) ensuite. Ce qui n’est pas Ă©vident pendant un vol.

Observations : J’ai essayĂ© de changer les rĂ©glages avancĂ©s dans SteamVR mode dĂ©veloppeur et Ă©galement en passant avec le mode direct ou sans celui-ci sans succĂšs.

QUESTIONS : Existe t il un moyen d’avoir une bonne qualitĂ© d’affichage comme dans mon premier cas avec la possibilitĂ© d’utiliser la souris ? ou existe t il un plugin externe qui permettrait d’utiliser un des 2 contrĂŽleurs fournis avec le casque VIVE COSMOS ?


A quick test for you: what about leaving the FS2020 window open, but turning off your monitor instead?

The reason is the headset cameras are looking at the monitor screen which is changing as you’re moving the head and making the tracking algorithm loosing ‘tracks’. This is quite typical by the way and I had this sometimes with the G1 but no longer with the G2, most likely thanks to the side cameras.

Worth trying out.

very good thinking! I’ll be sure to test your solution and get back to it on this thread. I wonder if we can deactivate the face cameras of the Vive COSMOS? given that there are still 4 cameras on the side and up and down maybe that would be enough for the motion tracking?
To have


1 Like

Hello CptLucky8,
I tested your solution without success by turning off my screen without minimizing the active window of MSFS and it does not work. I have the mouse in my cockpit but still tremor in the tracking level in the VR headset. Whereas, if I reduce my MSFS window, I no longer have a mouse, but I have a magnificent view in VR with very clear instruments. It’s still a shame! Hopefully ASOBO is working on an improvement allowing either to be able to use the mouse or the controllers which would allow to use the instruments such as COM or GPS or other 

I don’t know if other simors have managed to find a workaround with maybe third party plugins? Who knows ?
In any case, it leaves a feeling of no success for VR for the moment.

1 Like


  • you can ALT-ENTER to toggle maximize MSFS screen or not, see what the VT resolution does.
  • you need to set the equal “PC” graphic options exactly as your “VR” graphic options

1.5 cts

Hello VoteablePlains8,
I have already made all of these settings without success.
But besides the problem does not come from the quality of restitution in VR (with the VIVE SOSMOS headset) because as I indicated, in VR, I have a magnificent and precise view if I reduce the window of MSFS2020. If I do not minimize the window and therefore want to have the mouse functional inside my cockit view at this time, I get a blurry view and with lags (shaking) even reducing the quality of the images to a minimum. graphics settings at the minimum stage of MSFS and even changing the options in the NVIDIA control panel for 3D management.
I think that for this to work correctly, the VIVE COSMOS VR headset would have to be considered as a full screen to have the view (MSFS active window) only in the headset and not at all on the PC screen . I have tried the “Direct mode” or “disable direct mode” functions in the developer functions of steamVR without success. While I think that this is precisely where it should be possible; But it looks like these two functions have no effect.

I’d guess something seriously has gone wrong with your installation (of drivers? of MSFS?). Of course your mouse needs to work in VR.

In fact the mouse works in the VR view of the headset if I activate the MSFS window on my pc screen but in this case the graphics quality is bad as if I pushed the graphics settings too far while reducing the MSFS window on the PC screen (so by not leaving it in active window) or by turning off the screen there I get an impeccable view graphically speaking in the VR headset but I no longer have the mouse visible (normal more that my MSFS window is no longer the foreground application of Windows 10. a bit like opening a browser such as firefox and a word processing editor side by side on my PC screen if I click in the editor of text it is this window which is active consequently the interactions of my mouse only have an effect on this window for example a right click will present me a contextual menu linked to the text editor and not to firefox.
Well there it is the same thing. If I have the view of my headset (in mirror mode for example) and the view of the MSFS window side by side on my wide screen when I click in the MSFS window I make my window active and therefore the displacement of my mouse in this window is taken into account and is also visible in my helmet but the view of the VR helmet is not optimized why ???
Whereas if I click on the window that displays the mirror mode of the VR headset, in this case it becomes the active window or if I click anywhere on the Windows 10 desktop, the desktop becomes active and in this case the mouse is no longer displayed in the VR headset but the view in my headset becomes optimized again, clear and without shaking.
I must specify that I tested the VR on another simulator called CONDOR 2 (gliding simulator) which does not take the mouse into account at all and this is recognized by all users. So I’m guessing that a correct mouse implementation shouldn’t be straightforward otherwise it would have been done in this other simulator.

Will test this afternoon and report back.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.