Cirrus SR22: Can't start the engine!

After the latest update, I can’t start SR 22 engine. I saw a video on YouTube, followed the checklist. But can’t start engine. Only way to start is: Control E. Also can’t change fuel selector position. Please help.

@DaffodilWeb9333
Not being able to move the fuel selector is an indication that only your core MSFS has been updated correctly.
Most likely you have to separately update/re-download your premium deluxe package via the content manager.
Simply exiting and restarting MSFS might trigger the update.

I have the same issue and I’ve shut down on numerous occasions and it still doesn’t work. I also have issues with the King Air Bat amps CAS message that never goes away and eventually shuts down the PFD’s and MFD. Also have the issue where the fuel selector doesn’t work in the Arrow or 172 6 pack.

Go to the content manager (ingame —> profile) and check for content updates. The sim often doesn‘t update everything and we have to do it manually.

Thanks, it works now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.