Cloud Pixels / Shimmering - "Film Grain"?


I would appreciateany help regarding Cloud - Clouds issue i have.
At the beginning everything was working great, no issues , nothing. Great game! But since yesterday i experience this shimmering - grainy taxture - pouder clouds - Pixels in clouds.

Mostly visible with scattered clouds above 6000 feet at bright daylight.

What i tried.
Change Resolution of desktop / in game.
Change rander scalling
Change graphics settings (low-ultra)
Reset Nvidia Settings, change Nvidia settings.
Reinstall drivers.
Restore Point.
Remove usercfg
Remove manual cache, rolling cache.
Turn off online settings.

And i dont remember what else…

My Specs are i7700k / 1070 / 16gb ram.

The issue apperead suddenly after selecting “live weather” and “fly”.

P.S yes, clouds are on ultra, anti aliasing is TAA, 16x

Believe this is solely a rendering technique for volumetric clouds, i’ve seen this, i’ve seen it in a various amount of games that also have volumetric smoke. The higher you put the settings for the cloud, better it will be but its nothing untoward.

Well i dont see it on everyone’s vid/screenshots. Also it was fine 2 days ago. The issue probably started when the live weather started to work for me. Before when i was using preset’s i didnt had this issue. Since working live weather even the presets looks the same.

I have it as well. Hadn’t noticed it in the first few days of flying in the sim though. Only noticed it 2 days ago. I guess I was too busy exploring and it was there all along?

1 Like

I have this aswell, I thought it was normal, or something to do with my monitor or something. If it’s not then could do with knowing what I need to change to make them look better cos it’s very off-putting.

EDIT: Could it be Nvidia drivers?


It is possible… but because i am very picky on the anti aliasign/shimmering thing in game i would notice it day one. So probably it apperead “suddenly” . First days the clouds weere “woooow” now i feel like i am flying on cauliflower with mold on it :smiley:


:rofl: Yeah it does a bit. I too thought the clouds looked great at first. I tried everything but they simply won’t go back to their original state. I´ve also noticed that the shadows have something similar. Have a look.


I have this too, using a 5700XT on high-end settings

1 Like

Well i searched some day one screenshot’s from others. And it seems that the “issue” is from the beginning but now it is more noticable, maybe it has to do something with data steraming ?

Probably i noticed it yesterday since the live weather started to work … I hope there is some fix for that, somehow. Probably somebody who can 4k 200% render on big tv will not notice it.

I had this issue and i could not figure it out myself. Setting TAA helped and upgrading to 1440p also wich id been meaning to do for a while for me they looked like boxy pixels up close was shocking im unsure exactly what changed it but as soon as i got this monitor and changed res yo 1440 and some guys said to me about taa for fuzzy reflections and grass etc i was happy and clouds look decent

1 Like

Also depends on the lighting. I noticed it for the first time at high altitude when the sun was shinning. Before that I had always been flying at sunset so it makes sense that I couldn’t notice it.

1 Like

I also noticed this from the start.

Mostly if I look up and over the front dash onto the front cowl of my aircraft (don’t do this much) it’s always grainy or pixelated like that.

1 Like

This is how reflections are computed and “traced/cast” - its very common to get grainy like look within it.

1 Like

I see this too and not just on clouds, but in every area where there is diffused light

Here is a cockpit example in the ICON A5


I am getting Tired…

Navigate to your user.Cfg text file in Users\yourname\AppData\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache

Near the bottom you will see a line “FilmGrain 1”
Change this to “FilmGrain 0”

and the problem is solved. It looks so much better. It would be nice to have this option in the actual UI


for steam users I think the file is ‘UserCfg.opt’ from ‘C:\Users\Yourname\AppData\Roaming\Microsoft Flight Simulator’ I think? The option is there at least.
Not tested this myself.

Removing the film grain does improve things nicely in my opinion. Some have reported that turning the sharpen feature off in the same config file improves the overall image. Unfortunately for myself on a 2k monitor, it makes everything look far too soft.

I had changed something in my nVidia control panel in search of more performance which has seemed to cause the worst pixelation yet.

I had switched Texture quality to high performance. I switched it back to high quality and the cauliflower clouds are now gone.

Granted there is still slight pixelation around th edge of the clouds but it’s not nearly as bad.


Disregard…still cauliflower…