Clouds tank performance

Am i the only one where clouds tank performance? It seems okayish below and above but when im going through them or on a sid or star and i cloud surf its not the nicest of experiences. Or is this a sim update 9 issue? Ive noticed worse perfotmance after sim update 9. The sim just doesnt feel like its running as efficient as before.

Thanks!

1 Like

Try turning Volumetric Clouds down from what ever you have it set to in MSFS VR options.
You give no information as to your PC specs or your current settings so it is hard to give you any useful advice.

2 Likes

Clouds tank my VR performance too. I have them set to high and going through them drops FPS by about 1/3. SU9 is no worse than SU8 with this IMO.

Of course. Cloud is one of major fps eaters. Recommend to lower your setting as other people said.

1 Like

I’ve often seen a memory leak in clouds when set to high or ultra under live and preset weather. Usually I just set it down a notch, click save and then back up a notch and click save again. Seems to fix it until Asobo do. Maybe try that?

1 Like

SU9 is definitely worse. The high clouds are putting a larger load on the GPU for sure, but Ultra is just murderous. Granted that’s always been true. I was flying the DC6 in VR and the CRJ a lot this past month and since I am in larger cities and airports it’s brutal if you have any live weather cloud density. If you do direct testing you are 100% losing about 10-12 FPS with high clouds in VR, they act like Ultra in 2d, but shadows also play a role in that so it gets complicated. I am guessing most people fly around in smaller aircraft at smaller airports so it’s not as noticeable. In 2D mode see below for what the clouds actually do to FPS. It’s mostly GPU though so I think that’s ultimately a good thing going forward. With airliners, I fly with LOW clouds at this point, so I can consistently have 35 FPS. I have a 3090 and 5800x3D.

3 Likes

If clouds kill your performance when you go through them, that is when the “clouds” actually fill up all your screen, but not when you’re above or below them, then it might be linked to your antialiasing settings. Check if your “transparency antialiasing” is turned on in your video card settings. If yes, you might want to turn it off.

yes it is a new problem , i noticed it right away after the latest patch yesterday , i hv always set clouds to high , never went below this setting and it was very good till su9 now with that patch its the worst, over EGLL with clear skies its smooth , i then set the clouds preset to BROKEN and it was a slide show ,so its not a hardware problem its just Asobo changes to clouds

specs
2080ti
i9 9900k
32gb rqam
ssd
G2

I have clouds at Ultra but I haven’t seen a big hit. Sometimes I run them at High but I haven’t noticed too much of a difference. I’ve been worried because I see it’s a big complaint.

3080ti
5800X
G2 with final resolution around 3000x3000