Cockpit Look Left/Right somehow hard locked to Flight Controls?

Well, I’ve been trying to enjoy FS2020 since launch, albeit with many horrendous bugs, but now it’s not even flyable. This happened 1-2 months ago.

Somehow the Left-Shift Left or Right Arrow ( “Cockpit look left” or “Cockpit look right”) became HARD LOCKED to flight controls and aileron roll left or right!!! These were and had been cockpit view controls, but at some point 1-2 months ago no longer worked as cockpit view controls but rather became mapped to the ailerons. Same thing with Left Shift Up/Down arrow becoming locked to elevator control. No matter what I do for cockpit view controls on the keyboard, they direct flight controls instead and I crash!

I know I’m not doing anything wrong, and this confirms what’s supposed to be what!

https://flightsimulator.zendesk.com/hc/en-us/articles/360016003159-Camera-Overview
Rotations

  • Cockpit look left” (Left shift + left)
  • “Cockpit look right” (Left shift + right)
  • Cockpit look up” (Left shift + up)
  • “Cockpit look down” (Left shift + down)
  • Or you can press & hold the right mouse button and move the mouse to control the eyepoint

I played the game at launch and that’s exactly how it worked. Took a break for a few months hoping for a lot of bugs to get fixed, and came back and now even this doesn’t work.

I have tried everything. Reset all controls to default multiple times, confirmed that “Left Shift Left/Right” in the keyboard control menu is indeed mapping to cockpit views and not ailerons, and that flight controls are somehow not mapped to this (they’re not!). I’ve tried different keyboards, tried unplugging my joystick (Thrustmaster HOTAS). I’ve uninstalled and reinstalled the application, and today I completely nuked the entire installation and re-downloaded all 100GB again, to no avail. Nothing works.

Left Shift Left/Right will not adjust the cockpit view and instead rolls the aircraft no matter what, and I can even see the yoke moving when it’s not supposed to be. The only way to shift my view is with that POV hat control on the joystick, or with the right-click hold on the mouse, which is clunky and annoying. Anything on the keyboard for cockpit view shifts the flight controls instead and I crash.

System specs:

  • i7-9700K
  • RTX 2080 Super 8GB
  • 32GB RAM
  • latest Windows updates, NVIDIA drivers, etc.
  • no add-ons

I empathize with you completely as this happened after the second or third update and I even sent a request to Zendesk explaining everything you just described with no real fix, albeit a fix to get back the arrow keys to adjust the seating height up and down and left and right.

Eventually, I removed what was set for numbers 1, 2, 3, 4 and mapped in cockpit look left, right down and up, respectively.

Takes some getting used to as I have grown accustom to History of Flight, FSX and Flight Gear with similar keyboard controls as you described.

You are doing nothing wrong and your pc seems similar to mine.

Other then the getting use to the new keyboard mappings, MSFS works well with nice graphics and it seems Microsoft is gearing to hardware yokes and controllers and VR.

Thanks for the reply! I figured I wasn’t alone.

Funny thing is, straight Left/Right/Up/Down arrow keys DO shift around the seat position accordingly. But hit Left Shift + Up/Down/Left/Right and now it’s driving the flight controls, no matter what. Totally bizarre.

I haven’t tried a re-mapping workaround.