COM1 frequency changing on it's own (VATSIM)

Hi there,
I know there already is a topic quite similar to this one, but I get really annoyed whilst flying on VATSIM, when my COM1 frequency changes itself all the time without me doing anything. I am basically kicking myself off the controllers frequency.

I’ve already turned “Delegate ATC to AI”, as well as the whole AI/Copilot thing off and nothing happens.

I’d be very grateful, if someone could help me out :slight_smile:
Regards!

Yeah man keeps happening to me too

Remove any key or button assignments that control the radio (if you don’t use them, of course).

1 Like

I don’t have any keys/buttons assigned to the radio and the com 1 freq still randomly changes. Suggestions?

Manage Radio Comms turned off in the AI menu?