'Connection lost' error since last update. Can't play the game

Anyone has this as well, and perhaps got a solution?

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
All removed (even a full re-install of the game), didn’t change anything

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Since the last update, Microsoft Store updated the FS 2020 game. Now, everytime I launch the game, after the loading screen (with the rhinos) the installation manager opens with a “checking for update” prompt. After a few seconds I’d get a “connection lost” error. Continue crashes the app, Stay offline just doesn’t load anything.

Interestingly, first time I launched the game after last week’s update, I got a message from my firewall saying that the MSFS 2020 app did not have a digital certificate. I’ve whitelisted the game and even tried with firewall fully disabled or uninstalled. Did not change anything.

Tried with community folder emptied, as well as a full re-install, but getting the same error when trying to install the full game.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
As described above

PC specs for those who want to assist (if not entered in your profile)
AMD Ryzen 5 2600 six-core
GeForce GTX 1660

Build Version # when you first started experiencing this issue:
Not sure how to find this, but happens since the update last Tuesday (27 July)

Are you on the Steam or Microsoft Store version?
Microsoft Store (through Game Pass Ultimate)

Did you submit this to Zendesk? If so, what is your ticket #?
Yes, no reply so far. Ticket # 112606

I may have the solution to this, or at least it seems to be working for me now…
With the game closed, log out of Xbox Game Pass account, and then launch the game. It will ask to login again, and after that the update started downloading. It’s now at 15% so we’ll see how this goes but at least I’m one step closer again :slight_smile:

1 Like

Also had this problem after updating to, can’t play the game, it gets stuck at the main menu because it thinks there is no connection.

I can confirm that logging out the XBox Game account will solve this problem.

Also, if this problem occurrs, reinstalling the game did not help. After uninstalling the game and deleting related folders, temp folders etc, the game would not even download the initial content.

You can also logout from the XBox Game Bar if you have it installed. Press Windows Key + G to bring up the Game Bar and log out from there.

Before logging out, please make sure the game app is completely closed. When the game was stuck I had to go to the task manager to force close it.

After logging out, simply relaunch the game, and the game will ask you to choose an account to login. And everything works fine after the login is successful.

1 Like

same problem here,… tried every possible solutions (including like yours) for the past 3 days… nothing happened. Now cannot play the game.

The sane here.

It works! Log out of xBox Game bar, sign out of xbox account and install it!

tried that days ago, no joy!

1 Like

Try to re-activate Bing data in general options datas menu
It seems to work

okay i don’t know if cursing is allowed on this forum, but i’ve been having the same problem (haven’t played since october 2020, and upon reinstalling it via the xbox app on pc (i use game pass pc for msfs) it said connection lost and then got endlessly stuck on the rhino-screen without loading anything) and now I FINALLY FOUND SOMEONE WITH THE SAME PROBLEM!!! AND YOU HAVE A FIX!!! FFFFF**K YES, thank you so much!! :))

Same issue since last update. Nothing works. Spent half the day trouble shooting. Its a far more common problem than you may think most occuring since the last update. No Connection … can only use it off-line. Very dissappointing it wasnt addressed in the Fix Updates considering how many times Ive seen the issue around the place.

Same problem. I have deleted & re installed the game, get to the Rhinoceros screen & it says connection lost, press ok then quickly hit the download button, goes back to Rhinoceros screen & can see down the bottom a blue line indicating its downloading information the blue line reaches the end & nothing. I haven’t been able to play the game for months now & paid over a hundred dollars AUD. How do I fix thus problem??

My internet connection is fine to

I had same issue, but find a way to make it working again. First I run ccleaner to fix register, then I go to xbox app and logged out from my account. Then I delete xbox app. At last I go to xbox game bar options to reset settings. After rebooting computer I start msfs, it offered safe mode, I choose normal and surprise, it start download updates again. Nothing worked for me before this. I think it could be that resetting xbox game bar or just pure luck? Worth to try if nothing else has worked.

Same problem, I tried everything, re-install etc, no way !