Constant auto switching between MSFS and Oculus home

I am using an Oculus Rift S and the Xbox game pass version of the game.

When I load a flight I am in VR mode but almost instantly what happens is auto-switching between Oculus home and the flight sim. It’s like rapid alt+tabbing. I see the sim for a split second with the “Ready to Fly” button and then I see the Oculus desktop before being switched back to the sim.

I am using v27 of the Oculus app (also tried with v26 with same results). Windows is up to date, the game is up to date.

I have been struggling to find anyone else with similar issues.

Same here HP G2 running on Steam vr…don’t know how to stop it!!!

I have this intermittently as well. I believe it’s poor programming. How do I know? Because this is the ONLY flight game that does it.


Same problem here.

Oculus Quest 1

1 Like

Make sure HAGS is off. It caused similar issues for me or wouldn’t work at all when HAGS was on.

same issue for me:

Excuse my ignorance what is HAGS and where do I find it?

Thanks I’ll try it🤞🏻

Same problem here. Tried the hags fix, unfortunately a no go. Every other VR game works great. Hopefully a patch is in the works.

Oculus Rift S
AMD 3950
GeForce 2070 super
64 gb ram

Same problem here, it’s very annoying go back to oculus home unexpectedly and with no aparently reason, I thin that turn off HAGS not solve the problem and just affect FPS, I’m expecting the oculus original cable but I don’t know if it will hepl me with this issue

anyone fixed this ??

Nope, I haven’t found a workaround, and I have been all over these forums trying every suggestion for the last two days. Nothing works, rolling back drivers, Rolling back Oculus Software versions, Running OTT, Adjusted Nivida 3D settings, uninstalled/reinstall the game, Uninstalled/Reinstalled Oculus app, and keeps doing the same thing. The screen on the monitor flickers quickly and I’m just looking at my dashboard with the headset on. Once I switch it into VR mode the flicker is so bad I have to ALT-F4 the game to get out of it.

I am having the same issue with my Oculus rift s. When it happens I get a momentary flicker of the vfr map window a few times on the 2nd monitor and the whole program crashes.

the solution is to disable atc and camera menu

the solution is to disable atc and camera menu , this seem to affect people who usually play on 2 monitor

By ATC you are meaning Air Traffic Control correct? AS far as the camera I did not see any options in the camera options to disable the camera.

in the top menu once in flight you can disable the atc and camera

This one , go on the right on the little wheel and see

Ah that’s the problem I can’t get to it due to the flickering. The only thing to I can thing is get the start up and then disable them, then try enabling VR.

yes you have to do it in this order it doesnt matter ^^ , disable in 2D, then switch VR