Constant CTD every flight now (ntdll.dll)

I have never had a CTD since I bought FS in 2020 and today, after installing GSX PRO I have had the 1st one. Memory can not read error. I have also installed USA update 10, so one of these two, should have generated the problem.

I just voted for this beug, CTD when the online services are active with SU9.
I have disabled all the online service of Microsoft is not CTD.
It’s coming from Microsoft’s servers

1 Like

“Memory can not be read”
It appears that MSFS uses the virtual memory from C.
It happenned that my C was very crowded, so there was a lack of space.
I removed som programmes from C and made a cleaning in order to recover space.
After that I tried the sim and no more CTD’s.

and today, somewhere over england I got also the: ntdll.dll / 0xc0000374

My first not expected CTD since two years :slight_smile:

Only thing I changed compared with yesterday, where 4h flight without issues: I installed the update for World Update VI Germany, Switzerland…

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 1.26.5.0, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: ntdll.dll, Version: 10.0.19041.1806, Zeitstempel: 0x1000a5b9
Ausnahmecode: 0xc0000374
Fehleroffset: 0x00000000000ff609
ID des fehlerhaften Prozesses: 0x26c0
Startzeit der fehlerhaften Anwendung: 0x01d8b544be47a569
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Pfad des fehlerhaften Moduls: C:\WINDOWS\SYSTEM32\ntdll.dll
Berichtskennung: 26b83b60-6b00-4e7a-97f0-58dbd6dd0b43
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:

Do you have any mods installed? If so, which one(s)?

only the H135 helicopter, but should not have impact here

What plane were you flying?

PMDG DC-6

What were your departure and arrival airports?

started at EGPH , crash half away to VOR LEE

Did you have live weather enabled?

yes

Did you have live traffic enabled?

yes

Are you on SU9 or SU10 beta?

SU9

Are you using DX11 or DX12?

DX11

What is your GPU and what driver version are you using?

Nvidia 2080Ti / 516.94

Are you on Windows 10 or 11?

Windows 10
Steam Version

Server

Europe West

So what we’ve seen is that people get this on:
Windows 10 and 11
Live weather on and off
No addons
Live traffic on and off
SU 9 and SU 10 beta

Any Xbox users also getting this issue in the past few days? Happens for AMD GPU users too?

I noticed that only the airport loaded in, not the rest of the scenery and then it crashed maybe 20 min into the flight.

@SeedyL3205
Test flight no 1 - live weather off - no CTD.
PMDG 737 EPPO-LGKR
XIDNA MISKA L616 DESEN VALPI OSDUK RODON N732 PITAS

Test flight no 2 - live weather off - CTD ntdll.dll :frowning:


PMDG 737 LGKR-EPPO flight time 02:06
OLGAT CRAYE GISAM NETKO GUBOK VEBAL XOMBA BILNA SOPAV REGLI EPOPA L617 ARMEX NILPU

I endured 3 CTDs yesterday - 2 with GSX and one with GSX uninstalled - all sudden and unexpected. Initially though it was something to do with GSX until I saw this post last night and have had further discussions with others. I’ve entirely removed GSX today, ran SFC Scan and Dism repairs etc. and will fly today to see if I get another CTD

As time goes on it seems to be on MSFS/Asobo’s side but not being too techy I wouldn’t know where to begin to diagnose beyond looking at Event Viewer!

4 Likes

This appears to be the common error. I’ve had it myself once, and I see a few other users have had this particular one also.

1 Like

The last few days I had 2 CTD. I’m not using GSX.
I’m running Windows 10 with the latest updates installed. Also I have a Nvidea RTX 3070 with the latest driver 516.94 installed.

The error from Event viewer is:

Faulting application name: FlightSimulator.exe, version: 1.26.5.0, time stamp: 0x00000000
Faulting module name: ntdll.dll, version: 10.0.19041.1806, time stamp: 0x1000a5b9
Exception code: 0xc0000374
Fault offset: 0x00000000000ff609
Faulting process id: 0x5e00
Faulting application start time: 0x01d8b48d8db1e297
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: bd842b42-2505-4940-8426-a1636685c888
Faulting package full name:
Faulting package-relative application ID:

Lot of people here assuming that the problem came from the last thing they added to their sim, and it’s more simple than that. It’s clearly anything out of our control, you just have to read the variety of configurations among the people starting to suffer CTDs in the last days.

Also don’t claim victory too early if you are making some troubleshooting, as I said before I managed to finish a 3,5 hours session flight with two steps (Madrid to Mallorca and back) without any problem between the first two CTDs and the last one and I haven’t changed anything. Also the last one came after a 3 hour session, unlike the two first (30 and 45 minutes each one).

2 Likes

Same. Tried differents settings. It’s totaly random.
Reinstalled from scratch MSFS (deleted all remaining files manually) and without addons.
Constant CTD appeared suddently without MSFS updates, addons updates or Windows/Drivers updates…
It’s since few days before the update of datas for WU6 package.

There’s that same error code again. I had CTD’s rarely, but without fail they were the 0xc0000005 type, where the sim has accessed memory that it shouldn’t.

Could it be that all the scenery/map related online services might be the culprit? Maybe Asobo and/or Microsoft are preparing their servers for the SU10 update, or changing something in general. Obviously this would be something no user has control over and would result in those erratic CTDs.

Someone on GSX forums tested with offline functionality without CTDs, of course this could be a coincident

I never had so many crashes in the last two years like I had and have since Friday… I am getting angry.

Tried a number of fixes - Got a 2nd CTD yesterday due to ntdll.dll. From what I have noticed when it happens on my end - It’s typically happens when I am close to the approach stage or descending for the destination. The other parts of the fight seem fine. It doesn’t matter what route it is - Aircraft both times has been the Fenix.

I’ve not changed any settings or hardware at all. I will need to see if it happens in other aircraft as well. But my friend also has a very similar situation.

I know the ntdl.dll is normally more related to drivers/hardware but it does seem strange I am seeing an increase of these crashes being mentioned caused by the same module on various forums/discords.

Faulting application name: FlightSimulator.exe, version: 1.26.5.0, time stamp: 0x00000000
Faulting module name: ntdll.dll, version: 10.0.22000.832, time stamp: 0x3907dfbc
Exception code: 0xc0000374
Fault offset: 0x000000000010c9a9
Faulting process ID: 0x4fd8
Faulting application start time: 0x01d8b4cb75957eb6
Faulting application path: F:\SteamLibrary\steamapps\common\MicrosoftFlightSimulator\FlightSimulator.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report ID: 571d8ae0-3b64-49f3-a827-5f1059543594
Faulting package full name: 
Faulting package-relative application ID:

1 Like

Yesterday and today morning I had also couple of CTD´s, with or without GSX (SU9)
Did now 2 flight using weather liver OFF and both were successful. 1 flight without and 1 flight with GSX running.
Maybe coincidence

update: had a CTD also with weather services off using the hpg H145 helicopter now

1 Like

I had exactly the same issue on Hawaii yesterday night with the beta. Even the airport buildings were not displayed. Only the parked cars.

Cheers

The selected server only affects multiplayer data. Not Bing/PG/Weather. Since it happens with Multiplayer off, I don’t think it will help.
My crash yesterday was on West Europe, a streamer got crashes on Friday on South-East Asia.

Since which update? This thread is about CTDs started without having an update installed.

Perhaps he is talking from the Update WU VI Germany, Austria, Switzerland, which is since Friday available in the “Content-Manager”