Constant CTD every flight now (ntdll.dll)

I still crash and I have nothing new installed. I experience also missing ground textures since Friday… that is a first for me. Though I am online connected (with a ping of 31 ms) the respective fields under my signature are grayed out, but the ping is displayed. I am on the west european server. I also crashed on the north european server.

1 Like

I was just quoting @SeedyL3205

Yeah I guess I am on of those people not flying either and waiting until it’s fixed but then just noticed there was less complaining ha, but you’re right people won’t fly and waste their night if there’s a risk it’ll crash. I’ll probably do one today at some point though, in the hope it’s solved itself, and report back.


Yes I googled ntdll.dll errors and there are mentions (not FS related) of corrupted file and how to fix, but if it were a corrupted file that caused my CTD on Saturday then you would think something like that would impact all subsequent flights, and I’ve now done 4 or 5 GA flights yesterday and an airliner flight this morning with no issues, which would be unusual if a file had been corrupted. All done with online everything ON. Albeit still restricting myself to UK flights.
I will try out a longer international flight tonight that crashed for me on Saturday and see if I get a CTD. I remember the exact spot it happened.

1 Like

Good luck, I’m going to try a flight UK to this morning and will report back
I only mentioned FSX dll issue as that was a big cause at the time but there was no support from Microsoft back then as they dropped the franchise and it was left to the community to sort it out
That corrupt dll back in the day didn’t affect every flight weirdly enough so it was a bit hit or miss if one got a CTD or not

I actually think the ntdll.dll is a bit of a red herring here. I think all of these CTD’s whether that be from ntdll.dll, memory read/ memory write errors are all linked - these aren’t separate issues.

I have had both a ntdll.dll CTD and a memory read CTD in recent days. Something server side is causing these CTD’s which are showing in different ways our ends.

I have seen a lot of people say turning ‘off’ the online servers in the sim cures the CTD’s which is yet more evidence this is a server side issue.


Screenshot 2022-08-22 212651


Bing server issue?

Well if you are feeling brave enough you can delete and reinstall this dll in command prompt

Just Google it , I am definitely going to run sfc /scannow to see if I have any corrupt files and run DISM too

I might even reinstall this dll and see if things improve

I’m confident enough knowing this is a server side issue that I’m not going to bother messing with .dlls.


Yeah fair enough, I don’t blame you, not something I fancy doing either tbh

Server locations greyed out have nothing to do with Live Weather, Bing streaming, etc. The server selection is only available when Multiplayer is enabled. When the server is greyed out you are considered “offline” for Multiplayer only. All other servers are available without enabling Multiplayer.

1 Like

I dont know how else to say it. I did not blame any plane! I just said I hope a solution is found! It would be terrible to have the 737-800 come out and not be able to fly it because of this CTD issue. I dont know why you are attaching blame to any planes or add-on to my statement! It has no sense or context to what I said. I know it happens with any plane!

I just hope we can find a solution to this.

1 Like

Its something wrong with the sim, not addons.

Yes but ■■■ is wrong, my issues started on Sunday, never had a CTD before that for maybe 6 months+

The same for most off all the posters in this topic.
You are not alone!

“we” are not the ones to find the issue. Lots of people tried all they can.
It’s up to Aosbo/MS to figure it out.

1 Like

Overclocking is not the reason of this CTD event.
I have run my CPU en GPU overclocked whitout any CTD’s for a very long time.
The CTD’s I have now are not related to my hardware and operating system.
The problems fall out of the sky 3 days ago. :upside_down_face:


I’ve run overclocked since day 1, so this isn’t the issue in this case.


I know, I was just responding to the post saying that xmp should be disabled etc

1 Like