Constant CTDs after flying a bit

We wait, and see if things improve soon. But don’t hold your breath.

Too soon to know for sure but today, I managed doing 3 flights without the CTDs midair I’m used to.

I did 5 things prior to this where one (or more) of them was likely the culprit:

  • performed a repair of MSFS via ‘Add or remove programs’ in Windows

  • cleared out everything from …\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalCache\SceneryIndexes

  • deleted Content.xml and allowed the installation of Navigraph AIRAC recreate it. I noticed how I had some old entries in that file. Pointing to items no longer in the Community folder

  • reset objects LOD in UserCfg.opt to the default max value of 2. Before, I had it set to 6. In order to be able to see objects such as the GSX Pro bags further out

  • removed everything in my Community folder except for the PMDG 737, Navigraph, SPAD.neXt, GSX Pro, FSLTL and my origin and destination airports

Hopefully, this will help someone else. Because I haven’t seen or heard some of the things I mention elsewhere.

Will do more testing tomorrow and if things continue to be good, I’ll start adding things back to the Community folder. Very carefully and one by one. With at least a couple of test flight between each item added. Until I feel confident the CTDs are truly gone for this time.

I was without CTD for some time, I started having almost every flight, after habiting the rolling cache, yours is active? if so, do the test by disabling…

Modified my last post above by adding some items to the list of things I did which I think has helped me solving the CTDs up to this point. Hopefully, this list can help someone else who just like me tried all other tips to no avail.

I now had some additional time flying without any CTDs and will continue to add things back to my Community folder. Keeping my fingers crossed the CTDs truly are gone for this time.

That’s one thing I don’t have to worry about as I have my cache on an 8GB ramdisk. A PC’s default behaviour is to clear ram but then starting MSFS it automatically sets up a clean cache.

I too have had some significant improvement with CTDs. In the last 3 days I have completed 8 flights in about 9 hours of sim time without a CTD. This was done in the DC 3 starting at Frankfurt to Zurich to Innsbruck cross the Alps to Italy then over to Venice back to Lugano then down to Nice.The only change since the last time I had a CTD was to go into Nvidia settings and set MSFS as the only program running in performance mode. This morning I installed the new Little NavMap update. I have had some long runs without CTSs a few times, let’s see how long this one lasts.

1 Like

I was starting to get very hopeful but last night I was back with the exact same CTD I always see. Same module, same offset same everything.

The last thing I added to my Community folder was Brussels from Aerosoft including the extra modules required by some of Aerosoft’s products.

Thought I would start by removing those extra modules. Tried again, another CTD and gave up for the night.

Today I’ll give it a try again. This time after having removed the beta version of Navigraph in-game panel. This was what I added back just before Brussels.

Even when I was able to fly with it without any CTDs, it was just one flight and about an hour long. I also find it more likely the beta of the Navigraph in-game panel would be the culprit rather than the Brussels scenery. Even more so when I had the second CTD when I was still parked at my origin, hundreds of miles from Brussel.

Will keep posting about my CTD adventures here. Both for myself and others.

I’ve had the power setting in Nvidia set to maximum performance but on the global level.

Will add what you did to my list of things to try.

Hi.
I am also having the exact same problem as you have described, which started following the recent updates. I am using the beta version. Flights would suddenly freeze in flight at anytime between 10 - 19 minutes. The a/c involved were the PMDG 700, and the FENIX A320. No reason or notification was given for the CTD, except for the last Flt, of which this notification popped up. ‘’ Instruction at, 0x0000 7ff765447609 Referenced memory at 0x0000002100000000 the memory could not be read. Click OK to terminate program. ‘’ Following this l removed everything from the community folder. commenced a disc optimization, deleted all unnecessary files on a disc clean up. removed all unnecessary log files. restarted pc. put back the PMDG 700 into community folder tied a Flt in excess of 1Hr. Result all OK. no problems encountered. Will now put back all items back one by one, and monitor the results. Having done and said all this. I still believe there is a BUG in there. A very frustrating problem both for you and me, and l suspect many other’s. Best of Luck. Ps. ( I reduced all the ultra settings on Nvidia )

1 Like

Thanks buddy and I wish you luck as well!

As I said before, having a title (MSFS) being this prone to CTD for all kinds of reasons and now when the title had more than 2 years to mature, Asobo really needs to implement some form of debugging option that could be enabled when having these kind of issues. To help the user pinpoint what exactly is causing the CTDs in their specific situation. Or at the very least, some form of log where people could get more information vs what is found by looking in the Windows Event Viewer log. Where you get ZERO help understanding what caused the CTD.

Possibly even easier and something I also suggested before, Asobo should reach out to MS for help. I’m sure MS already have the tools available for troubleshooting these kind of issues. This way, Asobo could offer people having these kind of issues some small debug utility to install on their systems. Depending on how informative the result using such tool would be, the user could possibly diagnose their systems themselves. Or if not, Asobo/MS could use the tool to collect the data needed to figure out what as going on and what Asobo need to change in their code. For MSFS to be able to handle these kind of things. Simply have a more robust error handling. Leaving us customers with a software less prone to constantly crashing.

The way it is right now and has been since MSFS was first released is nothing short of crazy. Having people spend hours, days, weeks or even months in trying to figure out what is going wrong behind the scenes. As a customer, you shouldn’t have to spend your time on such things. I think the main reason for this being “accepted” by people is how FS people are quite used to these kind of things. For most other software, a situation like this would simply not be acceptable.

With all this said, I’m now about to give my system another go. Let’s see if I get all the way to Brussels or if I once again end up…on my Windows desktop.

Wanted to ask you about this statement, is this the Navigraph in-game panel beta (version 8) you’re referring to?

…and here we go again, almost made it to EBBR this time with only 10 minutes to my TOD or something like that. Unfortunately though, my destination turned out to be my Windows desktop also for this flight. I can imagine my virtual passengers are starting to get slightly frustrated by now…

This was with Navigraph in-game panel 1.3, after having removed the beta version (8) out of the equation.

So…I’ve now removed both Aerosoft EBBR incl all Aerosoft modules for VDGS, data exchange etc and put Navigraph in-game panel version 8 back. Meaning I’m at the state when things last time seemed to work…

Next thing is to find somewhere else to fly. Will avoid anything Aerosoft for the time being. Not because I have a clue if that would be the culprit here. Simply because I don’t know what else to do. Should also mention I also tried setting power mode to performance only for MSFS. As suggested above. So doesn’t look to cure the issue I’m having.

What I would really like to understand when getting all these CTDs is if this fault offset code means anything of value. Anyone in here who knows? I’m getting more and more interested in this once. Since it’s always the exact same code. Again though, I don’t really have a clue what this code means. Just fumbling in the dark here.

Asobo and MS, I (we) could really need some help here. And by help, I’m not referring to spending days on reinstalling my PC from scratch to make your software work. If you’re lucky… By help, I’m referring to having your help finding a method which can be used to actually pinpointing the real culprit. For each and every one of us having this issue.

Hi WebMaxxximus.
I’m using the MSFS Beta version, and also the Navigraph in game panel beta ( V8 .)
Had reinstall the Fenix A320, apart from that a successful Flt. Relating to your comments in the one from last paragraph, relating to time spent. l have accrued some 2600 Hrs, actively spent on this sim, of which, only 840 hrs are shown in the flt log, l reckon to have lost approx 200hrs due to bugs in the log.This may give an idea as to how much time is involved attempting to remedy various problems which constantly pop up within msfs.
Just read your latest post, re EBBR. I am using Navigraph on an lpad at the moment, haven’t put it back into the Flt Sim yet. As to the code, all ‘’ Gobbledygook ‘’ to me. I will now try a 2hr+ flt. I also sincerely hope the right people take note of your comments, and act on it. Best Regards.

For visibility, I posted a new thread over in the General forum. Where I addressed Asobo and MS in the topic and linked to this thread. Keeping my fingers crossed the right people as you say will act on all this.

Sorry to hear how much time you’ve spent troubleshooting rather than flying and enjoying yourself.

Think I’ll try to get in touch with MS tomorrow rather than Asobo. To hear if we can get any help from them.

I’ve had ctds off and on since launch, but nothing like in the past bit (SU11) It’s rare now that I finish a flight. I get the audio artifact, then freeze, then an audio pop, then desktop. Usually after about 30-40 mins of flight. Once recently I had one just after take-off. But most often I get them when within 4-5 miles of landing as I typically do short hops inside of an hour. I did however recently change soundcard. I was using a Native Instruments Maschine Mk3 and have switched to a Universal Audio external soundcard. I’ve tried in different bitrates, thinking I might have had it set too high and dropped to 48, 000k with no avail. Will try running with the Maschine again and see if this persists. This sux!!! I use my PC for flight sim and for audio production. My Mobo soundcard has been disabled in BIOS, and I don’t plan to enable it.

Have you tried testing MSFS audio over HDMI with a BT 5 dongle hanging off the monitor headphone socket? I believe the latest have improved multi channeling although I only have 5.1 and use stereo headphones … never a glitch

1 Like

I went back to my Native Instruments for soundcard. 2 flights in a row no CTD. My UAD one requires ilok. This might be the culprit.

Got a few flights in without ctd. tried a longer one at the hour 40 mins mark. It ctd’d around 4 miles from my landing.

I got sick of spending all my time troubleshooting and worrying to end up on my desktop so took the plunge and reinstalled my computer from scratch.

Let’s see if it was worth the time and effort…

My CTDs have stopped for the time being. I have now made 15 flights without a CTD. The longest flights were 1hr 45 min and 2Hrs. The only change I have made since the last time I had a CTD was changing the NVIDIA settings to have only MSFS runnung at high performance. Also today I downloaded and installed the DC3 mods but I had 11 complete flights without a CTD before that. I am just hoping that whatever it was fixed itself and I can make it to the next update which, I think, is coming soon.

1 Like