Constant Stuttering on the Takeoff Roll and Climbout

Hello,

I’ve been experiencing unplayable levels of stuttering specifically on the takeoff role and climbout ever since I started using MSFS about a month ago. Once I get to about 1000 AGL the stuttering stops and landings are perfectly fine. This happens at every airport I fly out of and every aircraft I use, regardless of if it’s default or 3rd party.

I’ve spent hours this past week troubleshooting and reading forum posts, going down every possible avenue, and I still can’t pin down the problem.

Setup:
i7-12700k
Asus RTX 4060 Dual OC
Asus TUF Z790 Plus WIFI
Corsair Vengeance 32GB RAM DDR5
Samsung 980 Pro 1TB
Asus Rog Strix LC II 360 AIO

I’m using a Samsung 40" 4K TV as a monitor, and my internet is over 50Mb/s.

I’ve tried every setting combination, low settings, high settings, everything in between, and the stuttering persists at the same intensity. Even on the lowest settings I get virtually the same amount of stuttering. I’ve tried v-sync on/off, all different anti aliasing types, low latency on/off, still the same. I’ve deleted the cache, turned it off, no difference. I turned on the debug fps panel, it said I was limited by the main thread. I tinkered with the settings until I got smooth performance limited by GPU, still getting stutters. I just did a clean install of windows 11 and msfs, ran the game everything default, medium settings, still stutters only on takeoff and climbout. This is a deal breaker as it stands right now, getting massive stutters in a critical stage of flight.

I don’t care about the sim looking pretty, all I’m looking for is a smooth experience, so any help is greatly appreciated. Thank you.

I’m throwing in my 2 cents worth at the risk of being totally wrong since I’m a amateur here compared to many others. If you’re connected to the internet with WIFI that might be a limiting factor. Also, I can’t tell the size of your community folder. You might try starting in safe mode and while there create a manual cache of one of your troublesome airports. You could also go back to the vanilla state and try again. In any case, I hope you get this solved.

First, if you’re using WiFi, try connecting an ethernet cable to your router. Turn off WiFi and test.

Make sure your RAM is installed correctly:

image

There are other things you can experiment with:

HAGS on or off.
Gaming Mode on or off.
Enable Resizable BAR

Match your nVidia Control Panel settings to this. Make sure you turn Anisotropic Filtering OFF in the sim.

Lastly, you could try moving your M.2 drive to a different slot. It’s highly doubtful that’s the problem, but it might be worth a try. Use Task Manager Resource Manager to watch disk I/O while taking off/ climbing. See if maybe disk usage spikes.

I was having same problems and it has taken me a week to solve the problem.

This is what I did.

In windows

TURN HAGS ON
GAME MODE ON
OPTIMIZATION GAME SERVICES ON

Go into Start /Settings/ Graphic settings
Under (Choose an App To Set Preferences) Select drop down and find Microsoft Flight Simulator. Click the Options Tab and select HIGH PERFORMANCE (your graphics card) not the windows default . Save and exit.

Then play about with the graphics settings in msfs till you get the desired performance you want .

Hope this helps.

Good call…

1 Like

Try bumping your resolution down to 1440p as the 4060 is not really the best gpu to drive 4k resolution.

1 Like