Constantly Blurry ground textures

I’ve been flying mfs from the begining, on Xbox series x, and during this time everything has been stable I’ve only ever had one cdt and my imagery and photogrammetry has been satisfactory, however, the last 2 weeks the performance has been pretty much consistently terrible. I have 800meg speed and like I mentioned Ive never had an issue with streaming, cache always from the start has been off, but the consistent blurry ground textures and awful LOD is becoming increasingly annoying. However, during photogrammetry areas the ground textures are okay it’s only happening else where. I’m not sure if these problems are arising because of the ongoing beta which I’m not part off, probably nothing to do with this, but I can’t think why this consistently bad performance is not seeing any resolve.

We’ve moved your topic into Scenery & Airports

The Bug Reporting Hub is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug report. Using the template or providing all the relevant information about your bug and sim setup is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the User Support Hub category. If the community can replicate your issue, first search the Bug category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report and no duplicate exists, then create a new bug topic using the provided topic template.

All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.