Content manager broken after latest update

After the latest MSFS update (yesterday) my content manager never finish to load I am stuck with the wait cursor. What to do ?

Reported by others as well:

I have this problem all the time too. In the content manager there may only be around 1000 entries. Unfortunately, the value there also varies. This means that it can change temporarily if you change the aircraft, for example. After a restart it can be ok again. be.
If then the community folder has too many entries, nothing works anymore.
My recommendation: Use the “add on collector” or the add on linker to move only currently used add ons in the community folder.
In my experience, there shouldn’t be more than about 800 entries in the content manager. Otherwise problems will arise sooner or later.

I have the same problem for a long time. It is caused by a broken mod in the community folder. My workaround is to rename the community folder everytime I want to access the content manager, load the sim, open the content manager, manage the content, close the sim and rename the folder again.

I tried the suggestions in that thread by renaming community folder. Then the content manager loaded as it should. But then the Nordic update always fails and is listed as partially installed.
My current version is

But when I put back my community content the problem pops up again

And what mod would that be ?

I saw that the nordic update Failed or partially downloaded a few time. Eventually it decided to go through. It was rather wierd.

uninstall nordic update, restart sim, install nordic update.
I also had the problem. should actually help.

I never found out. I am too lazy because I have over 1400 items in the community folder and would have to check every single one which would take forever. I just accepted it and follow my “walkaround” everytime I want to work with the content manager.

I had the same issue with WU 10, which I have not experienced before. I cleared out the community folder as usual before starting the update but during the process of updating a number of elements including the Nordic update but also the Maverick content and several bush trips and other content updates all showed up as failed to install or only partially installed.

I let it run through and install what it could, then went back a couple of times and selected anything that had issues and tried to install them again. It still didn’t work completely, so I exited the sim and restarted it. The content manager then successfully installed all the missing or partial updates including the US update, and it all seems good now. I wonder if this was perhaps caused by the servers being overloaded, but at least it’s resolved now.

It happen the same to me after SU11, never before. Pilot profile, Logbook and Hangar working fine.
Windows 11 up to date, good hardware. Also cannot access MARKETPLACE (unavailable)

I’have had the same problem. Indipendent from any SUs. It appeared after about the 1500th addon, liverie, addon… I have copied to the community folder.
After a long research, organizing in different folders with the addon linker, try and error and so on… I finally found the solution! (for me):

It was caused by douplicate scenery entries in the community folder. I solved it by checking for doublicate ICAOs with the addon linker. And there were some! This happend to me by having some freeware airports and then after some time buying the same payware without deleting the previous freeware one.
After deleting the addon / douplicated ICAO I don’t want to use, the content manager works fine and is now listing about over 2000 addons.

Check that FS is online! I spent a lot of time troubleshooting only to find it was only because FS was offline.

On the home screen, click on OPTIONS then GENERAL OPTIONS then DATA and then confirm ONLINE FUNCTIONALITY is set to ON.

Thanks so much for the info Peteris 1962 I tried it and it worked.

1 Like