Content Manager Freezes

Months ago I had purchased KDEN by Flightbeam from the MS Marketplace. Was working perfectly. Yesterday, there was an update for KDEN released on the marketplace. When I tried to install the update it appeared to download properly BUT after downloading the content manager gets stuck say “Please wait” on the lower left side and FS is frozen. Need to shut down from the task manager to close FS–it is locked solid with CPU @ 0%.

Ideas? Of course, Flightbeam says it is a problem with Content Manager. I kind of believe them given the entire app freezes up.

Strangely, I have exactly the same behavior with today’s release

There were about 30 Aviators liveries to update after the release installed

Each time I select one and click install, it downloads, seems to install correctly, and then immediately freezes the UI.
The background animation is still alive, but the mouse is totally inoperant. Impossible to do anything else than Alt-F4 to kill the sim

I will open a Zendesk ticket

I did a bunch of testing (with some help from others on this forum) on this and resolved that the installs were actually completed before it froze. If you SELECT ALL 30 at once does it only freeze after the 30th? If so, you are probably good to go.

Unfortunately, if you select multiple at the same time, it freezes randomly after installing a bunch of those packages, but hopefully, it always freezes just after installing a package, and before starting to install the next package

So it does not mess up global installation

But restarting dozens of times the sim to install the 30 packages is a real nightmare

I had the same problem. I restarted the Sim and installed each aircraft update on Content Manager individually and it seemed to work ok.

Definitely not fun especially since each restart takes a few minutes. Good luck.

I’m trying to download those installs right now and I’ve been getting this problem. That I had to close it out. Reopen the sim and delete all the installs and retry downloading them again. Try that it worked for me. Also submit a ticket regardless if its fixed. It could be a bug lurking.

Same issue here. Even downloading the items individually wont help. restarting every time and still it will freeze

I have the same issue. After downloading files in the content manager it freezes. Have to end the task by task manager. Can you please fix it?

Ahm, me again. I think you can avoid the freezes when you go out of the content manager before the installation ends.

I just started having this issue after World update 5. There are 7 packages I see for update. After selecting all 7 FS froze. I killed from the task manager and restarted. I started to DL one at a time. The first installed quickly. The second one while small in size took maybe 5 minutes and FS came back responsive. Now on the third. For each package FS seems to sit there for a while. Now 3 for 3. Try one at a time.

I acknowledge this should not be the case but hope this will help someone.

Ahh, all of the slow items were from Asobo Studio. The others went quick.

Yep, I had downloaded 7 things. Tried to download 7 and froze after 2. I then tried 2 at a time and froze after the first one. Downloading one at a time is a huge pain.

I was having issues with the content manager freezing but with deleting, not installing files. I did a complete reinstall and also just selected everything and updated it in the content manager to download the rest forgetting about the aviators club and test liveries so I went to delete them and selected all then hit delete. Content manager froze. Stopped the process and went back in, it annoyingly redownloaded a few liveries I had just deleted. Started deleting one by one and it went okay until the 4th or 5th when it froze again but I left it and after a minute or two it was okay. Deleted the aviator’s club liveries and it took absolutely forever, like well over 10 minutes but it actually did it. When I went to delete the test liveries I actually timed it and to delete 2gb of liveries it took 13 minutes! Ridiculous.

I have had to resort to closing the sim when each individual update downloads, says Please Wait then freezes. Clearly there is an issue but frankly I just had enough of reporting bugs to Asobo just to get platitudes but nothing ever getting done to address them. Its like pulling teeth at times, this sim.

I can honestly say that this is the worst software I have ever had where updates and reliability are concerned, its really is terrible.