Content Manager - removed Marketplace aircraft but they keep coming back - RESOLVED with 1.27.13.0

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

No

Brief description of the issue:

Before downloading SU 10 I used Content Manager to remove most of my Marketplace purchases to reduce potential conflicts. A day or two later I saw aircraft I had removed were listed on the World Map Aircraft Selection page. I removed them again but noticed they reappeared later.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Start MSFS. Go to Profile, Content Manager, search for Carenado, select M20R Ovation and D17 Staggerwing, press Delete and confirm. The items show “Not Installed” and are not shown in World Map Aircraft Selection list. Quit to Desktop. Restart MSFS. Removed aircraft are found in World Map Aircraft Selection list and show in Content Manager as “Installed”.

PC specs and/or peripheral set up if relevant:

PC with Windows 10 64bit 21H2 OS Build 19044.1766, DirectX 11, Intel i9-10900, RTX 3060, 32Gb RAM, 1TB NVMe (OS and MSFS) + 2TB 7200 rpm drive.
MSFS 1.27.9.0. Primary MSFS monitor is 4K Samsung 43" TV, two other monitors are 23" HD. All running at 1080p.
Honeycomb Alpha Yoke, Honeycomb Bravo Throttle Quadrant, Logitech/Saitek Rudder Pedals, Tobii Eye Tracker 5.


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Are you maybe using addon linker?

EDIT: These are Marketplace purchased and not managed by MSFS Addons Linker. I currently only have one non-Marketplace item installed (Just Flight Warrior II).

Also, I have attempted to delete these items multiple (more than 5) times with the same results.

I restarted MSFS to find the M20R Ovation and D17 Staggerwing again show as “Installed”. Other previously installed Marketplace items which were removed before SU 10 beta install remain “Not Installed”. These include the D77-TC Pelican, CT182T Skylane, and Garmin G1000 NXi.

About 2 hours ago I installed SU 10 beta on my Xbox Series S, updated all content, removed the same items, quit MSFS then turned off the console. When I restarted MSFS on the Xbox these items all show “Not Installed” as expected.

This appears to be corrected. Yesterday I installed MSFS 1.27.13.0 and removed these aircraft. After restarting a few times for fights I find the marketplace items all show “Not Installed” as expected.