Controller profiles not saving

I got it to work by un/reinstalling the whole game. Controller profiles are now saved and usable but i noticed my AP master toggle or secondary/tertiary interactions don’t work.

2 Likes

I have had the following response from Microsoft support:

Thank you for bringing this matter to our attention. We just want to confirm that this issue has been tracked in our internal bug tracker. Since this issue will need to be addressed in a patch, we are going to close this report.

I did delete and reinstall the sim, and that has worked for me. I was very reluctant to do it because of the 200gb of data I had to download and the time it took. But I now have full control of profile creation and saving.

I suggested to the developers that they try and overcome this issue because it’s not the first time it’s happened with an update.

So you have a choice, do a complete install - this worked for me but no guarantee for anyone else or wait for the patch, developers haven’t given a timeframe for this.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

After the 40th Edition Update on Xbox S was updated and the prior version of Velocity One Firmware installed I DID NOT experience any issues other than getting familiar with new aircraft and creating a profile for the DC3. I attempted to create a helicopter profile. Abandoned that profile after realizing I had limited knowledge of creating proper functions for the Helicopter (which did not respond well). After changing to a proven Aircraft and applying it’s associated profile, the flight properties were somewhat erratic. Realizing there might have be a compatibility issue with 40th edition and VF1, I checked for a firmware update,(1.4.0) which I installed. That’s when I experienced the loss of profiles and inability to retain them. Those profiles had been reinstalled in the past after bugs related to FS and VF1 which they had resolved.
After installing new VF1 Firmware V.1.4.0 neither Duplicating nor creating New profile settings are retained.
It should be noted that Prior Settings of the FMD (Flight Management Display) of the VF1 needed to be reset after the Firmware 1.4.0 Update, which hints at the issues being more related to Turtle Beach than Flight Simulator. Those FMD settings which had changed included colors, brightness, etc. Experimenting with setting the 3 FMD Profiles “Default”, “Single-Eng. Prop”, or “Twin-Eng. Jet” help not at all. Those settings interaction implications & relationship with MSFS were never well documented from the beginning. Being there was a strong relationship between Turtle Beach’s VF1 and Microsoft based on the patented and authorized Xbox Logo dead center on the Yoke, one would think that serious “bugs” would have been explored and ironed out by the two entities. Patience is a virtue, but my daily flights are a no go while my planes remain in the hangar. Help!

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Thank you for your comment.
I have an ADSL connection and uninstalling then reinstalling everything without warranty will take me too long.
I’m waiting for the fix.
Until then I won’t fly anymore…

2 Likes

Yes. Presently Flying with “Single Eng. Prop” profile until a fix (likely VF1 firmware compatibility issue)

1 Like

Thanks for your patience and diligence in reporting this. I have been communicating this issue with “Huddison” of Sim Hangar fame on YouTube. This is the latest reply I relayed to him:
Unable to duplicate or create a new profile, I was able to modify the “Default” profile, yesterday, which appeared to “stick” (for a while). Primarily using the game pad with some interaction with a wired mouse (which has worked in the past). While testing settings on the tarmac my X Box controller “timed out”. Upon reactivating it some issues returned. I suspect the mouse may now be the culprit since the FS & Firmware updates. Being today is a holiday I will be taking a break from Simulator troubleshooting. If and when I learn more I will report back to you and your viewers and at the FS Forum.

Being you have had some response from Microsoft support, if you would like to relay anything I’ve mentioned it would be much appreciated. I do not plan to reinstall Flt. Sim. I’ll know more about whether the Wired Mouse was the issue soon enough. It was encouraging to stumble onto some temporary but partial solution to the problem.
Whenever I hear the word “patch” I shudder, because it’s usually the result of poor coding on someone’s part. “Spaghetti Programing”. Thanks Again.

1 Like

Hi guys as follow up to my issue with control settings not saving.

I did some searching and decided to try a complete delete of SIM and reinstall of MSFS on my Xbox.
156GB later … I now have full controller profiles saving and i also have my rolling cache options back.

So all in all back to hire it was for me. Very happy and flying again.

2 Likes

Don’t even, I deleted my whole data and, as expected, it did NOT work. Back to 0 flight time hours now and every setting to default.

I’m amazed the devs even suggested that as a possible fix (who knows who came up with that idea) and I’m even more amazed I followed it thinking it could fix the issue :clown_face:

1 Like

Good and well I finally decided to uninstall MSFS but not the data saved on the cloud because I wonder when the patch will be released with Thanksgiving.
With connection sharing with my 5G phone, I reinstalled everything in a few hours. And I lost none of my flight hours and I can now create and save a profile that suits me!!
For me it worked.
Thanks for your advice guy

2 Likes

Do you have the same issue if you follow the OP’s steps to reproduce it?

YES
Provide extra information to complete the original description of the issue:

Happens with all controllers including xbox controller. started immediately after the 40th anniversary update

If relevant, provide additional screenshots/video:

1 Like

Try this link below

2 Likes

Thanks for this info. Before I try, being I have FS stored on a Storage Expansion Card, would the “Internal Storage” be the correct path.

1 Like

Hi, not sure tbh. I used this process to solve the issue on Xbox series x.

1 Like

Just had an update to FSim yesterday (about an hour at approx. 6+mbps). Followed by 2 additional updates once Sim launched . . . one was Australia update which was quite lengthy.
No patch correction included with the initial update.
Will relook at your solution again as had no positive results 1st time around. Thanks for the response. In the interim, took a couple of flights with the Default “Single Engine Prop”. One thing worth noting is that the sensitivities on that stock profile seem quite good.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

Not only does a new custom profile fail to save, but all existing custom profiles have vanished. Xbox Cloud Gaming Beta following 40th Anniversary update.

If relevant, provide additional screenshots/video:

1 Like

I also have the same problem,

I uninstalled and reinstalled msfs overnight then another 3 hours to instal from the content manager.

Every time I shut down the sim all controller settings disappear.

I restart the sim and the graphics settings page pops up, press next and the satellite dats page pops up, then control settings, this happens every start up.

I am using logitech yoke and two throttle quadrants with logitech rudder pedals and saitek av8r joy stick.

This has never happened until now.

Also the community folder was removed before the reinstall.

Somebody please help, I can’t play the sim.

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes
Provide extra information to complete the original description of the issue:

Exactly the same
If relevant, provide additional screenshots/video:

1 Like

The same thing happening to myself, I am on Xbox One S Cloud Gaming, after every major update all of my settings, control profiles, and custom controller bindings get reset to a messed up default state. Anytime I save my binds and go back into the control options menu, they get completely deleted. PLEASE FIX THIS