Cowan Simulation MD 500 E helicopter

Well that was sad!
Was certain this was the week!
No airplanes either today!

The LA police helipads seems cool, but since I basically cant land any of the current choppers in any sort of precision, its just wasted money.

What is the absolute best hardware for heliflying that works on xbox?!
I am on cloud, but if I bought a series x.

There is a very big problem with the marketplace. There are people working in the Microsoft team who don’t understand anything and have no idea about developers.

A person and developer as famous as Cowan, who makes high-quality models, should be taken in advance. Take precedence! There are very weak developers who are hired in advance, even though they make garbage.

This shows that the employees of the marketplace do not know who has a high-quality product and which developer’s work the users expect. They don’t even read a forum to learn from it.

Milviz updated its PC 6 aircraft in December 2022. It was added to the simulator marketplace on March 17, 2023. Why did you have to wait 3 months?

1 Like

Because they didn’t actually submit it to Microsoft until March 3rd by their own admission.

I thought Milviz already submitted the update to the marketplace in January 2023. I was disappointed in them…

Does anyone know how to modify runway.FLT to start this helicopter in C&D state on helipads? MSFS sees helipads as runways, so all helicopters are in hot state by default. I modified runway.FLT so MD500E now starts with engine off, left door open, rotor brake engaged, all systems off except of two switches - Battery and Avionics master switch. I have no idea how to set them to OFF position. So far I tried:




None of these settings seem to work. The helicopter still spawns with Battery and Avionics turned ON.
I also tried coping all the settings from apron.FLT to runway.FLT but it didn’t work either, although the helicopter starts in C&D when spawned on a parking spot.

Any ideas? Maybe Cowansim would be so kind and provide runway.FLT in C&D state? :).


I’ve found that editing the runway.flt is real hit and miss. Asobo dropped the ball by not having helipads use their own unique flt file.

1 Like

Hi guys,

I haven’t had the time myself to try out SU12 yet.
But I wonder if this SU made it possible to bind the throttle to a key.
Did anyone tried this, figured it out?

Cheers Mark

1 Like

Something has changed in SU 12. I tested a Cowan Bell 206 helicopter after the simulator update. At a certain altitude, the helicopter accelerates to 130 kts with 50% torque. Something is very wrong… Bell 407 helicopter also does interesting things… Simulator updates only bring trouble… Developers will have their work cut out for them. I have not tried MD 500 E. Don’t expect any change until Josh updates the helicopters. He promised by April.


Thanks for the heads up. :+1:

Marvellous. But, what a surprise. Look at my surprised face :expressionless:


Yeah I am tired of complaining everywhere but the only positive thing with any helicopter after this update thst I can find is that the 407 now has a weak but functioning left antitorque pedal!
But other then that its made all helicopters worse.
Not much but enough to not wanna fly any of them, and the poor mini 500 is bugged on xbox sadly, and cabri lost its ”thing” whatever that was, so its not as enjoyable or controllable either.
Since helis came out I have almost completely gone over to flying helis.
So now I might as well cancel my gamepass and wait 6 month and hope somebody bothered to find out how a chopper actually flies and made all of them flyable.
And I am sorry to say but those who flew 407 in beta and said it was good now… please dont play more betas!
The cyclic throws the heli right, basically whatever way you point it, how can that NOT have been fixed? Instead its worse now!


After SU12 not possible anymore startint the hely unless mapping a switch to “starters on” function and (used also for props) “Magneto 1 start”.

Besides, I’ve noticed the impossibility to engage the governor, even positioning the throttle handle full open. Rotor Rpm indicator needle go full scale without control and moving the collective seems directly linked to rotor rpm decrease, of course due to rotor load increase. Nothing of this was happening - to me - before SU12.

Then, during this phase, strangely, if I click on handle front position switch - hidden one, where tooltip text says “STARTER” - it engages the governor mode and rotor rpm remain controlled correctly.

Where I’m wrong and/or what SU12 changed on this hely?

Thanks all

I have been flying it under SU12 for a while and it is flyable but Josh will be working on an update to utilize the new helicopter features introduced with SU12 associated with the throttle and governor. I expect that it will be released shortly on his website.


Good to know.

Anyway, following the start-up procedure, as soon as I set the throttle grip full open, I have rpm and engine reaching its max, tot overtemp and so on.

Then, pressing the start hidden button on the collective grip front, strangely it seems enging the governor and all goeas back to normal, still with too high TOT etc.

Pretty sure new incoming version will have these fixes done. :wink:

1 Like

Start on a parking space instead, if you are desperate to use a helipad ( like a lighthouse) then start on it and shut down then use flight recorder and record 30 seconds or so of you on the helipad cold and dark. then restart flight on a parking space nearby and then press replay on the flight recorder this willplace you on the helipad or anywhere else you want really in cold and dark situation

The floats don’t… float

sadly, all “rotorcraft” set types are doing that right now.

They work on the R44 and the KA-10M, someone also said it works on the H125.