Crash on initial loading screen (Works Offline, but not Online)

Also, just to verify, Do I have everything C++ related installed on my PC?:
I have noticed some people have more than I do.

New discovery: I actually can play the game while connected to the internet. I started the game while disconnected from the internet. While in game, I went to General Options > Data and I turned ‘Online Functionality’ OFF. So basically I can play the game while online but missing out on a lot of the online features. I think its safe to assume that all of the obvious things I have seen in these forums such, US Language pack, C++ downloads Reloading etc. are not causes. must be something else.

Glad I can at least do this to enjoy the game I haven’t been able to play in 6 months. However, I would really love to have the online features. Maybe someone may have some insight with this new knowledge?

Well I’m back to still troubleshooting. I am still able to play offline, but it is hit or miss when I turn the data option on. Even when it does run with the data options turned on still seems like its not running the best it could. I just want to play this game with all its features…

1 Like

I have the exact same issue on the steam version since sim update 5 released. It worked for 600h without any issues and only one or two CTD before the update.

I also tried installing the game pass version for the 1$ trial month to check if something is wrong with my system and to be able to fly again. Game pass works fine without problems but I don’t want to loose my market place buys and pay for the game again or the game pass each month…

I run the steam version of MSFS 2020 on 2 computers. One runs perfectly the other CTD’s as described. To get the failing PC to run the programme, I leave the internet connected but run steam in offline mode. It then runs flawlessly. Very strange!

Exact same issue here. Same error, CTD on initial load, tried all sorts of suggestions, eventually came across this thread and found that blocking the app via firewall to force it to run offline allows it to load fine…
Running the steam version, worked fine previously. Not played for probably a couple months so seems to be one of the recent updates that has borked it.

Hi, just thought I’d chip in: After playing since release I suddenly got these crashes on the initial loading screen as well. Before today, I had a nicely working current version of the simulator including the latest hotifx. Today I wanted to do a quick flight but always crashed at ~50 % on the initial loading screen. I must have tried it 5-10 times over the course of one hour, changing various settings, unplugging peripherals, etc. No dice. But I had upgraded my Nvidia drivers and my BIOS since the last time I played, so there were a few variables to check.

In the end, it turns out that limiting the FPS with the Nvidia control panel was somehow triggering my crashes. I had set it to 140 fps (I have a 165 Hz Gsync monitor) in order to cap framerates for the MSFS updates. And this worked fine until today but due to whatever reason, this suddenly created problems. So I set this to 30 fps and the simulator finally made it past 50 % on the initial loading screen. I exited the simulator and set the limit to 120 fps and it was still working. Exited the simulator, set it back to 140 fps again and it was still (!) working.

So, I am not sure whether the fps lock specifically caused the problem, or if it all was just coincidence, or if MSFS simply had to make it through one single started process after upgrading my BIOS and drivers (+ some recent Windows updates) for the issue to go away. But now it’s working. Worth a try for anyone with that problem, I guess.

1 Like

I have the same probleme same error but with all tweaks, it’s all the time the same CTD during the startup.
A guy from MFS2020 told me to wait the next patch … it’s just unprofessional …

1 Like

If you get him the same info as us here in forum, not wonder that you get such an answer.

We ask you already for more informations , in case you want helpfully hint from the community.

On example:

Lol more information for what it’s a CTD without any solutions … you can check on every topics, you can see only : download pack language and disable some services like discord , seagate etc … wow so good ^^

Not sure if this has been mentioned. Was crashing during initial loading after the update screen. I discovered in the Microsoft Store that my Digital Ownership app was not installed for some reason. I quickly updated and now MSFS is again starting up properly.

1 Like

Don’t know if it was mentioned already or tried already, but can not hurt to post:
356188 Steam Cloud Save and 386252/5 No CTD without internet → try this, other solutions may be found here.

This was a good idea I will say, but mine still crashed even when I set it to 30FPS :frowning:

Tried these as well. No luck :frowning:

I have this on steam. not the Microsoft store.

I have the same issue. Steam version…so far I realized that you can disconnect the internet, start the MSFS and then in the options I deactivated data…then you can reconnect the internet and it will not crash. I tried to investigate the settings, made a new xbox live account and it still didnt solve the problem. It has to be definitely something with the connection to their servers. I just dont get it, till august everything was fine until they started to integrate the XBOX functionalities and now for more than 3 months I cannot play the game as it was promised on my PC. I will try to get the game refunded…I am very dissapointed about this piece of sheet that has been produced…switching back to XPlane and MSFS will never see me again!

Probably your steam cloud save data got corrupted.

Turn off steam cloud for msfs.


Hi @TenPatrol , I tried this one allready (I think I read it somewhere from you on the forum), but it wasnt helping. I found a very complicated workaround, but it is working now, allthough im not pleased.
I opened up another steam account and I did a “family-share” of MSFS, then I entered a new user in MSFS-XBox Live, since MSFS was saying that the existing user is allready linked to another steam account. Now it is working, but everytime I will need to switch the steam accounts, when I will want to play MSFS…its an outrage what Asobo / Microsoft did with the update in august, I am so ■■■■■■!

So maybe smth is wrong with xbox cloud data.

For testing purpose:

Launch msfs.

1 Like

Well…I made a new account for everything…the point is, when msfs is starting on the new windows account, it asks to download >100GB of data, which I will not do again.
I can live with the workaround where I creates a 2nd steam account, family link it to the original steam account and to start from the new steam account the MSFS…still quite dissapointed that MS and Asobo did such a lousy job…
TIll the update in august everything was working fine…