Crash to Desktop Memory Error

Hello,

I was wondering if anyone has already seen the error message in the attached screenshot ?
I was streaming this morning and had a crash to desktop after around 2.5 hours of flight, while on arrival into LAX.
I don’t really know where to start looking for this one. Is the the Sim ? Is it something from Windows ?

Any pointer would be great.

Thanks a lot,
Michael

Hey @ATPL2006. I haven’t personally seen this message.

But, there are quite a few threads on the forums where people are reporting crash to desktops and it seems there is no one single cause. Reports indicate that the ‘fix’ for one user doesn’t work for another user etc. Tracking down the cause is very time consuming. I suggest maybe using the forum search function to find other threads for this issue. If you wanted to be brave, even though it is time consuming, you could take the plunge and go ahead and reinstall windows. It might actually save you time in the long run. However, it doesn’t guarantee that it will solve your problem if the CTD is caused by hardware weaknesses (unlikely but possible) or driver issues.

To get you started, here are two links (Link1, Link2) to existing mega-threads about CTDs.

It would also be a good idea to check out the known issues post to see if you are affected by one of those.

For advanced troubleshooting, if none of the other fixes seem to work, then there may also be some useful information contained in this detailed thread: Community Troubleshooting Guide.

2 Likes

Excellent info @Sartanius !
Thanks a lot for the help. I searched around in the forums, and yeah, there are so many reports that you don’t even know where to start :slight_smile:
Thanks a lot though. I will go through certain threads and see if I find anything.

1 Like

just two quick shots:

*) sfc /scannow via cmd.exe
*) did you run out of memory while going on the arrival?

the error message is correct, though. what was being tried there cannot work out.

Two scenarios:

  • the software tries to write to a memory cell that shouldn’t exist -> faulty software
  • the software tries to write to a memory cell that should exist but doesn’t -> faulty RAM
1 Like

dereferenced null pointer.

i don’t really think that it’s the hardware’s fault, though but in the end i’m just guessing either.

Never hurts to test one’s memory, though. Normal DRAM isn’t as failsafe as one might imagine.

2 Likes

right.
and not even ecc is 100% right all the time.

1 Like

Hello,

Thanks a lot for this. I will try the scan. I don’t think I ran out of memory. I have 32GB. That should be fine, right ?
I will try the other option though. Thanks for the info

yes. but i’ve seen people around here with quite a lot of custom addons where the game in the end has even torn the 32GB line.

I am actually thinking along the same lines here.
Thanks

you’re welcome.

1 Like