Crash to desktop when I click general settings

Ok, I need some help here please. This never happened before and I play this game from day 0 on the same pc.
The game starts fine, I can play, I can enter the world map and fly all planes, I can do everything but when I try to enter General Settings the game Crash to desktop. If I try to enter every other setting is all good. But if I click General Settings boom crash to desktop immediatly.

What I tried and didn’t work:

  1. Enter safe mode.
  2. Install English (US) language in Windows.
  3. Change windows language from spanish to english.
  4. Disable GPU overclock.
  5. Check in config file directx12 is disabled.

The game is and always was in english language, I play MSFS 2020 from day 0 on the same PC and never had a single crash. This is a fresh Windows 11 install and I’ve just installed the game (I was waiting for FSR).

-Windows11 (I played on W10 and W11 before and always worked like a charm).
-4790K
-GTX970
-Keyboard and mouse only
-Steam

Thanks everyone.

Did you try deleting your Steam cloud settings save?

1 Like

I didn’t try that. But earlier today I formatted and reinstalled W10. It works now, so probably something was wrong with W11 and my pc settings.

Thanks, you can close this if you want. :+1:t5:

1 Like

Hi, i have the same issue as you, im on Windows 10 and have it on Microsoft store. still no fix any idea???

Hi @TheSevenflyer , when I open up general settings on MSFS2020 it crashes to desktop. I’m on windows 10 and bought the game off Microsoft store I have done all the things that the person you replied to did! its been like this for months I don’t know why its just happened I think I 1st noticed it after sim update 10. could you pass this onto higher ups it really needs fixing I cant go into settings!

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

im using normal mode

Have you disabled/removed all your mods and addons?

no

Brief description of the issue:

when i click General settings, crashes to desktop

Provide Screenshot(s)/video(s) of the issue encountered:

dont need a vid or pic it just crashes

Detailed steps to reproduce the issue encountered:

load up sim… click options… click general options… Crashes been doing it since sim update 10

PC specs and/or peripheral set up if relevant:

gpu 3060ti

Build Version # when you first started experiencing this issue:

Sim update 10

Hi, sorry for not answering earlier. Sadly I didn’t find a solution, I didn’t try @TheSevenflyer solution because I already have reinstalled everything from scratch. I was using W11 and now W10. So I don’t know what is the problem.

(Probably something related to privacy or telemetry of Windows because I always try to disable that but I really didn’t find a solution)

thanks for replying, yeah i cannot reset whole of windows that too much lol, could you tell me more about the ‘Probably something related to privacy or telemetry of Windows because I always try to disable that’ where do i disable stuff?

In this thread, that was only delete your cloud save.
What all else have you tried?

I mean, everytime I install a fresh windows I disable all telemetry using a program called “ShutUp10++”. I did the same with W11, but this time I didn’t use it with the fresh W10 installed. So probably that was the problem. Or using CCleaner could be too. I guess I will never know.

HI @TheSevenflyer I have tried to start-up in safe mode {did not work} I have added English to windows because that could of been a fix {Did not work} Pressed fix program on windows settings {did not work} … Is there anything in windows settings that could be blocking it from opening settings? {I don’t want to delete MSFS2020 and don’t want to reinstall windows 10] Thanks.

This sim can indeed be fussy when issues arise.
I don’t know what all you have tried, so I’ll point you to a link for general CTD issues.

Some of the steps in this checklist you indicated you have tried, so obviously just do those that you haven’t.
If you haven’t found a solution by the end of this list, at the end there are links to three other checklists, follow the steps in these.
If you continue to experience the issue, I would also recommend you enter a Zendesk support request from the “Support” tab at the top of the page.

1 Like

thanks i have tried all of this but still it crashes when i open general options. is there anyway i can fix it? thats not listed there?

It may not be an easy fix.
I would delete the cloud save (again), and then uninstall the sim.
After that, remove all the residual files on your PC from the sim.
Reboot, then do a reinstall of the sim.

That will prove if this is a sim issue, or something in your PC.

I’m so glad I didn’t uninstall the only thing i did and it worked is switch from windows 10 to windows 11 so must of been a windows issue

2 Likes

Glad to see you found the issue.
Good flights!!