Crash to desktop when onboarding after installed Top Gun DLC

I normally entered MSFS and installed Top Gun DLC the day before yesterday.Then I tried new F/A18E and quitted the game normally.This is my last time successful enter the game because it alway crash on this page.


I tried safe mode but it not useful too.

@FSWZX I am sorry to read about this.
(I moved the thread to the CTD category)

I do remember seeing a similar post from another forum member in the feedback thread for the Top Gun DLC
https://forums.flightsimulator.com/t/official-discussion-top-gun-maverick-dlc/520460/548
https://forums.flightsimulator.com/t/official-discussion-top-gun-maverick-dlc/520460/643

1 Like

Same for me. I tried everything and ended up re-installing the game :frowning:

Hi friend, I have the same problem. reinstalled 2 times, deleted everything from the community and nothing helps. PC Steam version.

Same. I also fly on PC-Steam version. Have tried everything I can find including All Versions Loading Issues - Checklist from the FAQs - nothing working. I get the Maverick loading page and then CTD at about 80%. Restored MSFS2020 to vanilla state, emptied/renamed community folder, reinstalled from Steam several times, etc. I’m hoping someone is working on it…(?) Too much invested in this to just give it up for XPlane or something else. It was a great sim!

Forgot to mention - everything was working great until SU9.

I just found a solution. you can try to delete this folder: your MSFS folder/Official/OneStore/Asobo-effects-mrk. Hope it can help you.

Try to delete this folder: your MSFS folder/Official/OneStore/Asobo-effects-mrk. Hope it can help you.

What I did was re installing the game on Steam (900mb), re dowloading the main 190gb folder, and clean 02 Microsoftflightsimulator folders in the Appdata folder. But i kept the config files there somewhere and copy them back after made sure the game launch fine to the main menu, so i dont have to re config everything again.

For some reasons when you uninstall the game, those files and folders in Appdata are still there. We need to clean everything.

One more thing I notice is that when you stuck at loading from 50 to 95%, the game has problem.
But when you stuck at 99 or 100%, it’s the internet problem.

I hope this help.

Thank you for the solution. I already spent one day re installing everything. Haha.
This game is so great I cannot deny. But it’s a loading, updating, and re installing simulator.

nothing helped me, reinstalling and deleting folders did not give any result

I don’t seem to have this folder. I’m assuming because I’m playing through Steam(?).

The default packages directory with Steam is at

%appdata%\Microsoft Flight Simulator\Packages\Official\Steam

There you will find the Asobo-effects-mrk folder inside.

Ahhhh, thank you so much!