Crash to desktop without error message

Ok thanks. A bit annoying but I can live with that.

I thought I was on to something with the temperatures. I noticed my graphics card was regularly getting up to 83° before the crash. After some Googling I found that my card throttles down in power after reaching 83°… so I thought that must be it!

Sadly I ran a fan profile on my last flight, which kept the card below 75°… but the sim still crashed with the same error. :frowning:

Back to the drawing board. Getting sick of this.

I’ve come back with something particularly…Odd for my crashing. My game will be perfectly stable and working for a good period. I’ll have no problems. I use OnAir so I’m trying to explore more planes to use a stepping stone between the TBM and the Longitude.

I’ve come to realize this occurred last time I had spontaneous, no-error crashes as well. My game will be operating normally at any and all points until I try to fly the Grand Caravan. If I try to use the Grand Caravan at all, regardless of community content or…Anything, really. I’ll have a CTD within 30 minutes of launch.

These crashes will persist for an indeterminate amount of time, regardless of what plane I try to use after that. They also persist through full game reinstalls, and Windows update flashes/reinstalls. Basically, I found if I left the game alone for a few days, if I came back and avoid the Grand Caravan, everything was working fine again.

Sooo yeah. No matter what happens, if I touch that plane, I’ll have crashes for… I have no idea what extent. I haven’t been able to properly test it because I get frustrated. If anyone knows anything about this particular issue, it’d be wonderful to have an idea of what’s happening!

Wow. Almost 2.5k replies to this thread and still not a “known issue” or any acknolwdgement from Asobo of MS.

I just did a 5 hour flight from Montreal to LAX and the game CTD with the same Exception code: 0x80000003 on final.

No GPU throttling. I have a 3060 Ti and the temperature was a steady 60-70 degrees (which is completely normal for my card and wouldn’t throttle until at least 85-90.

Fresh Windows install, fresh MSFS install, no mods, all .net, all V C++ runtime packages installed.

Seems to be the game for certain.

One more random CTD… My specs:
Intel Core i5-9600KF 3.7 GHz
MSI GeForce RTX 2060 Super Gaming X 8GB GDDR6
MSI Mpg Z390 Gaming Plus
Corsair Vengeance RGB Pro DDR4 3200 PC4-25600 32GB 2x16GB CL16
PNY XLR8 CS3030 1TB M.2 3D TLC NVMe PCI-Express

Clean Windows installation, nothing in community folder…

you are completly wrong… read the posts before you bring such theses into the world.

Also without any knowledge of your system I would assume you own 16Gig RAM. Or ?

I’m sorry, please clarify. On which point do you refer to as being ‘completely wrong’?

There is no mention of CTD’s in the known issue list here

There are also 2,422 replies in this threat (which by my maths is nearly 2.5k.)

And I have 32GB of DDR4.

image

3 Likes

because in many cases the issue is at the users system and there is no general known issue about that.

If you own 32gig RAM, then you have to give us, the community, more informations that we can disuss your special issue.
( I assume you read former posts, eg. about well know issues for SOME , means not all, users since 1.12.13.0 )

Otherwise you can former check the existing FAQ:

https://flightsimulator.zendesk.com/hc/en-us/articles/360015893879-How-to-troubleshoot-crashes-CTDs

1 Like

And how many of those 2422 replies are…

  • Users assisting those with CTD issues?
  • Back and forth communication between those two groups?
  • Users responding with positive results to the troubleshooting?
  • Unique user posts?
  • Off topic replies? ( like these last 4 or 5 )

Rather than trying to be inflammatory, If you are experiencing an issue and would like some assistance trying to find out if it is a system caused issue or an actual bug, then please provide some details on your system and the CTD you are experiencing. There are a number of proven fixes, not workarounds, fixes, that may eliminate your problem. The alternative would be to read through the posts above and you may find your solution there.

1 Like

I’ve already said I don’t have any mods or anything that uses SimConnect.

And I’m not being inflammatory, I, like many others am frustrated that my £90 sim (regardless of version) has breaking issues. I’ve been through the troubleshooting multiple times (hence why I’m running an entirely vanilla OS and install of the sim).

Also how many of those (now) 2427 posts are Asobo or Microsoft communicating with the community?

1 Like

still waiting for informations… usefull informations…

But, we are helper community and thus I add another question:

  • how is your windows virtual memory setting ?

To be fair, a lot of forums are run like this. We engage with Community Managers, not programmers. They pass on our concerns, and they feed responses back to us via the usual update methods.

1 Like

No network stuff running? Live Traffic and Multiplayer Traffic are off?

Further to my last update, I have rolled back my Nvidia drivers back to December, still the CTD exists.

Crashes to desktop have started happening to me the last couple of days. All I can think is different on my setup recently is installing addons linker from flightsim.to which places the additional content in the community folder as shortcuts.

Going to try removing this and adding them in as normal to see if it helps with resolving the issue.

Possible, but more likely it is related to one of the addons itself.

Adding to the CTD discussion:

Rig is:

  • AMD 5600x
  • 32GB 3200 Corsair RAM
  • RTX3090
  • Open Loop Watercooling
  • Windows and FS installed on PCIe m.2
  • Gigabit Fibre Internet (Wired connection to PC)
  • Single Monitor

This is a newly built machine with clean windows install and minimal ■■■■ is installed. Machine runs cool and stable in Memtest and 3DMark stress tests (Port Royal for 24hrs), Prime95 for multiple hours with no errors) and CPU and GPU temps do not exceed 60c (Prime95 gets CPU to stabilise at about 68c but that is extreme CPU loading). I have been monitoring these and there are no spikes etc. Flight Sim puts less load on my system than Fallout4VR which runs stably (which is rare given how buggy that game is) for many many hours. All Flightsim testing recently has been in 2d and VR headset is disconnected from the machine.

Since the last patch and/or installing the Premium Deluxe upgrade, I get consistent CTDs either at 10-20minutes into the flight or at a random point often near the end of a flight/getting close to an airport. I have tested flights all over the planet, flights are long as I’ve been trying to get the Saddle Sore achievement, but the most I’ve managed is 5.5hrs. I had no issues and only crashes related to known issues like the VFR map prior to the latest patch. With over 100hrs flying time and most of that on the new machine.

I got the Premium Deluxe upgrade recently and crashes have started since that or the last patch, I don’t know for certain which. So I am raising as a potential point of differential between those having issues and those who are insisting that it is system based.

I have no mods, and an empty community folder, I have not had any mods installed at any point. No Simconnect or FSUIPC type stuff ever installed used etc. I repeat, no mods used, ever! All Flight Sim content is installed from content manager and updated.

I have tried, in a controlled manner changing one element at a time:

  • Changing graphics settings up and down.

  • AI Offline, Live Traffic and Off

  • Multiplayer On and Off

  • Live Weather or preset

  • Live time or preset

  • Turning ATC sound off (no Text to speech)

  • Clearing rolling cache, and no rolling cache

  • Different planes (all props for this but both vanilla and deluxe)

  • Underclocking memory and turning XMP off.

  • Turning off afterburner or any other OC and running at “stock”

  • Ensuring all drivers etc are up to date

  • Windows integrity tests sfc/DISM etc

  • Disabling the Nvidia Audio Driver

  • Windows Update (all applied)

  • Disabling Windows Defender (only AV used)

  • IPv6 is OFF

  • Resetting Router

  • Clean install of .NET and C Redist libraries

  • DDU uninstall of Graphics drivers and clean install, running 461.09

  • Manually configuring SWAP or setting system control( Noting RAM usage rarely goes above 16GB anyway)

None of the above has resulted in a reduction in CTDs.

Most of my CTDs are reported with the VCRUNTIME140.dll
Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5fda32ba
Faulting module name: VCRUNTIME140.dll, version

Some are just Flightsimulator.exe

Those I catch are often proceeded with the sound stutter.

Reading through the threads on the forums it is clear that people are trying to help but there is something that has been introduced in recent patches that is causing issues.

1 Like

I’ve not fully tested…but use to get random cdt whilst loading or mostly title screen and if I was lucky I could get a few min VR flight until a CDT
after trying everything suggested to no avail, I was testing stability using prime95. Using a blend test i noticed that workers 4,5,11,12 failed straight away. I used ryzen master and downclocked my r5 3600 from 4.2 boost to 4.0ghz. I then re run prime95 and all workers seemed to run until I stopped after a 10min test. I then tried msfs, loaded a flight up…took off in a 152 and left in the air whilst i popped out to shops…came back and all still good. I then setup a flight from Gatwick to Heathrow and flew a VR flight and landed Heathrow after a smoothish experience for around 25mins.
I’m not sure if a CDT will happen again until more testing, but also this is the most success I’ve had. Gutted that I’ve had to reduce clock boost, and not sure if my cpu is at fault or not

I have I7 7800 8Gb ram Nvidia GTX1060 4Gb. Just about 2 weeks ago I could run the game perfectly in Ultra settings, no lag no CTD’s.
The problem I had was just the controls with flightstick.
But when the game last updated i have tried 2 different flight scenarios.
Over Madagaskar with clear weather and Live weather (with a huge storm today about 16:00 CET. Worked perfectly. (well it have a huge lag)
A flight from Arlanda 19:30 CET with flight time about 9am in the morning. I high altitude it was lagging and when I dive to about 1000 feet just entering Stockholm the game goes CTD. No fault codes or similar.
So there is something wrong with the last update.
I have an old Laptop so I guess the Graphic memory is the issue here for everyone.

Anyone can relate to this?

Sorry my English is terrible but I hope you understand anyway

what is your window virtual memory setting ?

You need overall at least 32Gig of memory.

Otherwise scroll some post back where you find a link to a topic like “since 1.12.13.0”…

and a more generaly:

ULTRA Setting seems “a bit” to much for your system specs :wink: