Crash to desktop without error message

I uninstalled and reinstalled all my Visual C++ Redistributable files and it magically got past the Cessna 172 load screen and let me fly the 172 for 2 hours - very realistic - but more importantly, the sim actually worked for the first time since release. No guarantee it will work the next time I bring it up, but it is amazing. Fingers crossed. Just another thing to try . . .

And IF this continues to operate, the next step: get a 737 model released and tie my Jetmax flightdeck back in - its a very expensive hunk of metal sitting in front of monitors now.

Right, well I was having CTDs (no error messages) usually after about 15 -20 mins of flight. The tutorials would crash after each one without question. I changed my powered usb hub from the front of my case to a port at the back (This runs H/comb Yoke, CH Quad Throttle, TM Pedals, Xbox controller, Mic and headphones). I also disabled all of my usb ports from powering down in windows 10.
I have just had a 45 minute flight and can now continue with tutorials without a CTD. Yay!
I did turn AI traffic to off but I’m pretty sure a lot of this is to do with USB probs. I wouldn’t be surprised to see another CTD but maybe this might help some? Oh, running on medium with a 1080ti & 32GB ram. Might fiddle with increase later. Also turned off steam overlay for this sim.

BIOS update, and regressing the nVidia drivers to an earlier driver version did it for me. GeForce experience /overlay was not installed.

Runs in ultra with a wireless usb mouse on my laptop, with other peripherals on an old usb hub connected to it.

5G rolling cache file, and sys managed 16G swap.

It also runs on my PC with an OLDER nvidia card ( 970 ) running the LATEST nvidia drivers, in medium, mode with NO crashes to desktop…again with a rolling cache of 50G on a seperate drive. Again, with a wireless keyboard and mouse ( usb ).

I use the same gamertag, but have different control profiles for when playing on the laptop, and on the pc. It works… including the install on 2 machines which was painful coz you can only install or play one at a time.

It can work! It does work!

It is hypersensitive to usb and device activity

1 Like

Doesn’t make a difference. Can confirm, reinstalled from D Drive to C Drive and still crashes.

2 Likes

Regarding the Turning on/off bluetooth or wireless device crash, they finally responded to the zendesk ticket. They said they are now aware of the issue and working on a fix. So we just have to wait! :smiley:

2 Likes

Is this the same as My game keeps crashing every time it loads

1 Like

I got this error…

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f2ed221
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x5f2ed221
Exception code: 0xc0000005
Fault offset: 0x0000000000c8bf1c
Faulting process id: 0x2308
Faulting application start time: 0x01d6775c9bec6990
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Report Id: dce6cf22-b00f-4c7c-a6a5-c08e579680a7
Faulting package full name: Microsoft.FlightSimulator_1.7.12.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App

Gents in this or another thread someone suggested removing all overclocking related to your memory. For me in the BIOS that was changing my AI Overclock Tuner from D.O.C.P to Auto. The resulted in my memory speed being reduced from 3200mhz (which is the advertised speed) to 2133mhz. However the sim appears to be rock solid with that change. I left the 747 at a gate at KLAX for over 9 hours and came home and did a flight from KLAX to KSFO with no CTD and very smooth performance.

Looking at the latest development update it seems a patch won’t be released before the 27th. They say they will release a date then for the first patch.

On the first day I couldn’t play the game at all due to the CTD at the Cessna Loading screen, but I found a workaround.

  1. Set graphics to low-end on main menu and start a flight.

  2. On the starting runway/airspace go to settings and change to your desired graphic setting.

I only experience crashes when I fly over NYC sometimes. But I can play the game 95% of the time with this method.

I think this is an issue of how the game handles the data on and off the RAM, so until they patch this, I will do my method above!

Nope I was on 1909 and had CTD after clicking Fly button. Tried updating to 2004 and still the exact same thing.

That didn’t really work for me. Even if I keep settings on low or medium it crashes.

Are they serious?
In their update they do not even mention CTDs. And then we’ll need to wait a week without knowing if they will even adress the issue?

4 Likes

Another thing: Do you have special characters in your user name? I realized that while installing MSFS, suddenly I got a second user in my AppData folder. When I normally have a german “ö” in my name, the second user replaced the “ö” by some very strange ASCII letters. I think, the problem is, that MSFS can´t deal with other than normal characters. I set up a new windows local user with administration rights and no special characters, I manually deinstalled everything correlating with MSFS and did a wsreset. Updated Win10 to 2004 and Nvidia driver to newest driver.
Afterwards I installed MSFS using the new local user.
It took a while longer than with my MS account user, but after installation - taTAAA - in a quick view, all the problems - CTD when starting free flight or manual cache - were gone. Was not able to to a long time test, will follow Sat or Sun. Work´s due. Looks fantastic.
I believe, due to the problems with special chars MSFS could not allocate the cache, thats why it crashed.
Still, cannot understand that issue: Asobo ist french, their language is full of special chars either… :smirk:

Increase the Virtual Memory (Pagefile) on your system

  • In the Windows Seach bar, type Advanced system settings and open the Control Panel .
  • Make sure you’re on the Advanced tab .
  • Click the Settings button from under the Performance
  • On the Performance Options box , go to the Advanced tab > Performance
  • Click on Settings
  • On the Virtual Memory box, uncheck the Automatically manage paging file size for all drives
  • Click to select the drive on which Windows 10 is installed (by default C:)
  • Click to select the Custom size radio button.
  • In the now-enabled fields, type the minimum and maximum size of the Pagefile in megabytes (MB) according to the physical memory present in your computer.
  • Click Set and then click OK .
  • Restart your computer.

Ok my problem is resolved. I believe the installation was not 100 % correct due to me having special characters (ä) in name of my windows user -folder where the game also creates some game related folders.

When I created a new local user with no special characters on my PC without special characters and launched game from there - game loaded the ~300 GiB of content packages and then launched without any issues. Game functions without crashes now.

Not ideal to have a different account on my PC for FS alone but at least I can play now… Maybe they’ll fix the special character issue at some poin

Same Problem with me, as posted by me before. This is something that ties Finland and Germany together (and possibly Hungary and Turkey).
Wish you lots of fun with MSFS!
BTW, I have other strong ties to Finland, we´ve got friends near Turku.

Terveiset, Uwe

Also this was confirmed by support when I told them of the suspected problem and workaround:

Support (Microsoft Flight Simulator)

Aug 21, 2020, 10:01 AM GMT+2

Hi,

Thank you for the follow up.

This is a known issue we’re strongly working on it.

You can find here a list of other known issues and solutions:

1 Like

Not sure what they are working on, but most crashes reported here are not because of Bluetooth accessories. The issue is just in their code if you talk about the crash exception code: 0xc0000005

Also, I had the same crashes in the Beta, the forum also reported this before the actual release

New day, new testing, new crashing…

This morning I was accessing my pC via RDP from my work-laptop. I realized that when I experienced a crash that also the remote connection was killed.
No idea but maybe this gives a hint on network being also involved into the crash issue?

Carrying on…