Crash to desktop without error message

, ,

No luck. Crashes even if i turn it off completely.

The crash situation isn’t better afer the update. I deside, that I will report every crash with attaching a msinfo and dxdiag file to zendesk.

It isn’t the community that has to solve the problem. It’s Microsoft’s job, they got my money too. * annoyed *

5 Likes

I am finally succeeding in completing FS Economy jobs in MSFS. I had to disable the G1000 and G3000 mods to do it. And I discovered that a Windows update had set my USB ports to sleep and save energy. I had turned all that off a long time ago, but it got turned on again. So with those changes, I completed flights without CTDs. I was getting a CTD by touching buttons in the cockpit. My passengers didn’t appreciate it - nor did they care for my language!

Windows allocates the page file at system start. Setting the min/max size the same avoided Windows having to grow the page file each time additional pages were needed. This impacted performance in pre-Windows 10 systems without any SSDs.

Defrag moves data blocks around on a disk to improve performance. Since SSDs don’t have moving parts, it is not needed and should be avoided for SSDs.

The reason is not because they don’t have moving parts, specifically. It’s because the access time is much, much faster than an HDD, and that aspect is because it has no moving parts. You don’t have to wait for the head to move, or for the disk to rotate to the part of the disks surface you need to access.

1 Like

this is what we expect… more Tickets, more data, more Prio… :wink:


I’am shocked that there are still users which not know the rule number one in case of CTD:

  • remove ALL Mods

Also the link to the “README First”:


not only, otherwise the max value would be useless :joy:
It created the pagefile with minimun size at system start, if not already exist.

data can be still fragmented, and in special if a pagefile must be increased at runtime. There is no new file system which avoid fragmentation of files/data :wink:

The “Defrag TOOL” defragment this data, but this should never be done at a SSD ( limited write cycle => limited lifetime ) and it is not necessary to do that at a SSD ( there is no lose of performance ) .
Therefore Windows itself do in meanwhile a TRIM if you let Defrag the SSD.
And therefore I wrote “old trick for HDD” and NOT “old trick for SSD”.

I mentioned min/max same as the reason to ENSURE that you get what you set as max value - what is not the case if you have limited free space on disc.

Okay folks,

i had afterburner installed. But it was deactivated all the time. So i did not payed any attention to it.
Now i deinstalled it completely for testing purposes and could flight 2 times without any hassle. Seems, that i have found the issue (until now). I’ll have some further test filgts, until i can be sure about this.

So everyone who has maybe the MSI Afterburner installed, try to deinstall it. Maybe this will help you out.

1 Like

would like make a link :slight_smile: :

2 Likes

Third Flight over photogrammed City - absolutely stable. No crashes. I’m happy! :smiley:

1 Like

Just as an FYI, I apologize as my level of frustration with these errors has hit my boiling point.

Good luck everyone, I hope this gets resolved soon as I would like to be flying again but until something gets done I’m shelfing the sim.

MichaMMA sorry I called you out. Nothing personal, again just at level 9000 with frustration.

MechDonald, glad that seemed to work for you for now. I, as well as a lot of other simmers, don’t have Afterburner installed so while I’m glad this worked for you I have a feeling it’s just delaying the issue. Best of luck!

2 Likes

Thanks! I hope you can fly as well soon wihout errors! :+1:

2 Likes

Thanks @DracoRPG3979 … I thought so…

Trust me, we all are not happy about Issues and we all wrote from time to time bit more harder words / critism. I was just a bit shocked that you attacked me in this way, and I not known why me. Sometime the hints are helpfull and users are happy that there is/was a user that have some solutions/posts in mind.
Alteranative: waiting that the ZenDesk ticket can be analysed by a developer.
But also for some kind of issues the developers can never find the reason, this can only do a community like this here. As example the “MSI Afterburner” issue. Therefore we ask about things and try to give hints. Often are solutions found in PN threads and we post then only the ( e.g. als in case with @MechDonald ).
Of course, we not find for each case a solution/workaround and of course there is also allways a chance for in-game Bug.

And why I do that ?
not because I have a Job by one of these companies, or get goodies, or something else. I do it because I like to help in this way… ( don’t know what I should say :wink: ).

I realy hope that you can find in a thread a possible fix/workaround/… for the issue ( and share it then to help others ). Otherwise we must hope for next release ( which would be, for me, the worst case ).

5 Likes

No problem, mate. Again, sorry, as I know you are trying to help as well as other people on here. I was in IT for over 20 years and worked at companies that would write horrible code and then expect the support guys to take the calls and log the errors while the engineers all hid behind their desks to see what happened just to then turn around and blame support for not helping the customers. I’ve seen a few companies go out of business and a lot of people lose their jobs because of bad planning and execution of software products. I got out of that business as I was tired of having to be the one to break the news to people that they were losing their jobs.

So again, I apologize I know you’re trying to help. I know we all want to help and try to find the silver bullet that will fix these problems once and for all but it’s not on us anymore and we shouldn’t have to do this.

Best of luck!

5 Likes

Okay. Just a small update:

I flew along the eastern coastline of england with Cessna 172. No crashes. Just a beautiful english coastline. So now i can be sure about that: MSI Afterburner was the issue with the UK-update. It is NOT ENOUGH just to deactivate it. It has to be deinstalled!

Thank you guys for your help! Especially @MichaMMA, who spent much time trying to help people! Great people! :+1: :slight_smile:

2 Likes

I use Afterburner and RTSS for real-time monitoring of my entire system and it hasn’t caused a single issue in any game that I’ve ever played. Uninstalling it isn’t a fix and shouldn’t be confused for one.

1 Like

So here’s a brief observation I made. I played “a game” did some work things on my PC, watched a couple of videos on YouTube, etc. then thought “hey, I’ll play Skypark for a quick run.” Picked a short flight made it to about 10 mins into the flight and CTD with same exception error.

I did a restart and didn’t start anything other game before hand, no iTunes for music, no videos, nothing. Started Skypark and restarted my flight and not a single problem. I then exited MSFS, didn’t start another game of any type for about 2 hours, jumped back into MSFS and flew around with people live streaming - no issues (maybe about 30 minutes of flying for me total during the stream just to see what would happen). Everything was fine.

My thinking is that some kind of program that is starting with some software is either hanging up when that software shuts down (like another game) or some kind of conflict is going on with other pieces of software that you don’t realize you are not starting up again after you uninstall “X” software - so you are changing the environment in which you are booting MSFS up into. In my case it was not playing a little ESO , closing it, having iTunes shut down, but having Twitch and Discord running and I didn’t have any issue. I also run dual monitors but again I think it has something to do with a piece of software running in the background that is causing some kind of a conflict.

Then again, I could be completely wrong as I’m not an engineer but I’m starting to see some patterns emerge.

1 Like

So i just got a new type of CTD after new update.
in the old update even if i got CTD the game still manage to add the flight data to log book, but after new update, after i got CTD, there is just nothing on the log book, it kinda hurt me when i already fly for 3 hour and nothing saved onto the log book.
PS: i already solved CTD 3 times and this is the fourth time i got a new CTD

Having the same issues too. Ms and asobo needs to look into this, or else it would be another “fsw” or “microsoft flight”. This has caused a lot of us to run back to the other sims, even you tubers and hard-core simmers like myself too.thank God I didn’t get blown away by the hype and kept my other sims installed!

1 Like

Am I alone in getting the impression a lot of this has to do with underlying Windows 10? Things just stop working all of a sudden even though I was happily flying the previous day.

I am sitting at a situation where sim wont launch at all after the base 1.4 Gig install to get remaining packages close to all 100 Gigs of it.

MSFS is the only program I have had that crashes for me, in recent memory at least, and certainly since August 18th. Windows 10 isn’t at fault here, I suspect. That said, since the UK update dropped I have not had a single CTD!

I have had one permanent freeze though. This was due to that bug where you manipulate rotaries too fast. I have had this happen with the modded GNS530 a few times, and you just cease making inputs till it recovers, usually a minute or so is enough.

My last freeze was with the WT 0.3.4 G1000. I was rotating the lower right knob, and it froze. I left it for about half an hour, and it still didn’t recover. I’ve never seen it do that before.