Crash to desktop without error message

hmm… yes… "Software Version: "… may be you can check whether you have realy installed 64bit version, if not already done :slight_smile:
But I also searched a bit for a topic what I had in mind… not sure whether I found the one I searched, but here users also discuss about: Logitech Pro Flight Yoke System Issues

only installed English Language Pack US is necessary, not changing your windows langugae in generally.

Another reason was sometime that firewall or anti-virus solution blocks somewhat… Otherwise try to search a bit in forum with these two keywords, we have realy some topics about.

1 Like

Well I tried a few things, but didn’t have too much time, so I wouldn’t make consequences yet. It looks like the yoke driver is fine, at least for me and for my 3 flights.

I could fly with my yoke, throttle and pedals totally fine. If I connect the switch panel and install the plugin for that, it crashes. The plugin starts with MSFS automatically and uses simconnect, and that’s the point, when CTDs happen.

I also tried one scenario: Yoke+throttle+pedals only, but flying with OnAir. It is a 3rd party “role play” add on, where you fly for your own company, it adds some economy to the sim. OnAir uses simconnect too, to extract a ton of data, like fuel, weight, position, speed, altitude, radio altitude, engine rpm, g-forces and so on. It looked fine, I started my flight from Italy to Greece, everything was okay until I turned from base to final. Normally at that point OnAir detects that you are landing at your destination, extracts the local weather and the announcer tells you the wind direction and speed. That was the point when I had a CTD. So it is very suspicious, that simconnect needs an update or MSFS needs to handle the data stream through simconnect better. (It was totally fine since november until SU5 happened)

Tomorrow I want to try one more thing: As 0xc0000005 is an acccess violation error, I will try to start both the Logitech plugin manually and MSFS as administrator. I don’t expect too much, but who knows.

1 Like

Hi All,

My flight sim crashes on the startup screen with the loading bar at approx 80%. While displaying the FPS in developer it displayed a manipulator limit (red) followed by a main thread limit (red). The sim then crashes to desktop. I have tried numerous times and can’t seem to find a fix. The sim has worked for over a year now and this has never been an issue. Everything is up to date and I have made no significant changes that would result in the change of the sims functionality. Anyone have any ideas?

Im running it in boot camp, mac27inch 2021, Radon AMD 5500XT.

Thank you.

Well, my installation is clean at this moment, no liveries, generic models for AI and Multiplayer.

Hi nadson27,

Is your CTD like the one described in CTD at game launch after WU5 - PC Version Deluxe Steam

If so, please add your vote so that we get attention for the “specific” issue.

have agreat day :slight_smile:

I only know about an issue with external drives and bootcamp. So, may be you are affected from the 80% issue for which some topics exist… Often a xbox relogin helps, but there are also other possible reasons. Just search a bit in forum :slight_smile:

When read through the posts according to CTD, I get the idea to get paied for bug analysing to find the cause. I have at different steps a CTD and it seems to be, that they occured randomly or not:

  • After pressing start, to get into the cockpit CTD
  • During the flight
  • Retrun to main menu
  • When I walk around on the world map

Does anyone have clue what will work? So what I tried so far:

  • Checking drivers for updates
  • MSFS updated
  • Windows Update
  • Lunching with and without empty community folder

It is a beautiful game, but my last flight with a duration of 1h is two or three month ago. Very sad. Even there a lot of nice sceneries, but in my opionion - why should I buy? I can`t use them.

So I`m very happy, when anyone has an idea…

Have a great day :slight_smile:

Officially, no solutions offered have worked. Whatever progress we see is thanks to the R&D done by our fellow Simmers, who give suggestions which “might” help.

It’s over 60 days now and some (many?) can’t even launch FS2020 without a CTD! Not a word said by MS or ASOBO on what they are doing to address the CTD issues…

Losing hope very fast…

Check temperatures and enjoy your lunch

1 Like

Hey guys!

The display driver nvlddmkm stopped responding and has SUCCESSFULLY recovered!

Thank goodness it was successful the umpteenth time it’s crashed the game!

I know MichaMMA, do this do that.

Just wish they would fix this with some clarity.

Hi MichaMMA,

Thank you. Sorry I forgot to mention I have MSFS installed on an external SSD. Could this be contributing to the issue? I still don’t understand how randomly it stops working. Thank you for your help. :slightly_smiling_face:

Cockpit screens going out and then CTD on Xbox series s and x

They don’t want to fixed CTDs cockpit screens going out on Xbox series x and s PC version don’t I wish Microsoft teams play Xbox version for 4 hours flight and see what we are talking about

That depends very much on the external SSD’s specs AND the cable connecting, basically it must be the one that came with it. Use a high performance power plan or game mode in Windows to stop it going to sleep.

Hi All,

I have been bugged with lots of CTD’s for a long time. Now on latest version I think. What solved it for me is to limit my frames with V-Sync to 30 frames. Rest settigns on ultra but only 30 frames.
Looks great and is smooth enough. Definitly a workaround until there is a fix.
I have community addons installed and it still works.
Hope this helps. Mmight be worth a try.

AMD 5900x
RTX 3070

That sounds like you might benefit from better cooling, maybe an extra fan directed towards your gpu or a backplate solution.

I have monitored my GPU and almost never get over 70°. But might worth a try. I have a left over. Will keep you updated.

of course… there are the points which @DensestSnail693 mentioned , but very often are also external drives format in exFAT format which cause trouble with MSFS. About relation to the “80% issue” I’am not sure…

Finally I was able to fix the CTDs errors by terminating Explorer.exe in the task manager before starting the simulator.
This was the best tip here on the forum.
MANY THANKS! :star_struck:

All other suggestions such as drivers, OC settings, 3’rd party SW, BIOS have not worked even with a fresh install of Windows including all patches, and multiple FS installs.