Crash to desktop without error message

When I get them, there seems to be no rhyme or reason. Even had one ending a flight. Shut off engine, shut off alternator/avionics, boom back to desktop. Yesterday night seemed to go OK, got a flight or two in trouble free. But that, as i’ve seen, doesn’t mean im cured

Sudden Freeze–> than CTD
after 30min or less gameplay

Microsoft and Asobo, this is a joke!
Xplane was programmed by 15 people, never had this issues and so many of them!

Microsoft Flight Sim was releasend in August!!!

2 Likes

And the funny thing is that almost 8 months later the CTDs have worsened instead of decreasing. Between November and early March (with my older GPU) I had zero CTDs. After the early March patch it’s hell on earth. I’ve been playing games for 35 years and frankly I have never seen a software title that crashes as often and in so many different ways as MSFS.

The sole fact that there are so many random workarounds suggested officially in the zendesk site (and many more unofficial in these forums), all of which are irrelevant to each other, speaks volumes of the stability of this game (rather, the lack of it).

Just think of this: in my case I have a clean WIndows installation with all patches and updates. I have the latest version of MSFS, all updates in all apps of MS Store, the latest chipset drivers, the latest BIOS, the latest GPU drivers, no overclock, no issues with any other game, a sufficiently powerful PC (5600x, 6800XT, 32GB RAM, 1TB NVME SSD, 1000W PSU and so on). I have even tried with dozens of older drivers versions with no results. And the only thing that made some difference was to disable Microsoft’s own Xbox Game Bar! But CTDs still persist in various occasions, it’s just that I can now finally load a flight (usually, but not always). I cannot even begin to comprehend the fail of this.

Some people, who obviously have not suffered from any of the above issues, talk about Constructive Feedback.

I say “vcruntime140.dll”.

3 Likes

i also have an very powerfull PC
5900X + 6900XT (both custom watercooled) 32gb RAM 3000mhz
NVME SSD PCIE.3.0 970 EVO

awful performance and CTD

The almost best CPU and almost the best GPU but the FlightSim is so bad programmed :sob:

2 Likes

Yup, it seems that CTDs returned. I have experienced two CTDs today. First one took place during pushback, after setting up an aircraft (FBW A320).

Another took place one hour later, when I was over Sweden cruising to Iceland. Last fix increased the FPS, yet CTDs are back.

(i7 8700k 32gb of memory & GeForce 1070gtx)

The random CTDs are definitely back again for me. 2 crashes one when loading into a flight and other just before t//d. Both CoherentUIGT.dll on event viewer.
R3800x, RTX3080, 16GB@3200

yeah I agree. The last hotfix solved this weird fps stutters, but now my sim crashes after 2-3 hours of flying… This never happened before.
specs:
1080 ti
32gb 3200mhz cl16
i7 10070k
SSD

Just keep on voting, almost 70 votes in March and counting. Unless Asobo make this their absolute and undisputed #1 priority, we’ll never see an end to these CTDs that make MSFS unplayable. I don’t care if they take a year to fix this, as long as I know that they’re actively working on the issue and are allocating as many resources to it as possible.

Been playing the game since launch (147 flight hours) and had my first CTD today. Culprit is 1.14.6.0 or just a coincidence?

Was flying Flybywire A32X to Naha Airport. On approach selected flaps 1 and then game froze followed by CTD.


My FS9 (2014) may not look as good as MSFS (Asobo) 2020 but it works with no CTDs.

I’m flying in Algarve region of Portugal and getting several CTDs in the same area. I do not get these CTDs frequently and it has been a long while since my last. Curious if anyone would care to load a flight out of LPPM and just fly west at 2000’ and see if this happens.

same I started getting CTD after the hotfix. Fine the lag spikes are almost gone, but now you cant fly complete flight without crash… deffo a bug

Crashes to desktop without any msg started just after March small update. (Initial Load times also increased dramatically at the same time). The program just disappears. I have the Steam version. I have a very high end system: Ryzen 5 5600X stock clock at 4695mhz, Nvidia RTX 3080, 32 mb Ram, 300mbp/s hard wired net connection, MSI MOBO, C: is 512GB SSD, D: is 1TB SSD. VKB Modern Combat Stick, TM Throttle, etc, etc. All OS and software up to date and NO OTHER Apps on the machine - Pure MSFS machine right now. Most settings at High or Ultra. No LIVE anything. Crashes occur only after about 1+ hr flying when selecting departing airport (Malpensa, UK AF Base…) Plane is JMB Ultralight stock supplied with MSFS. They messed up something again.

If you mean the sim dumps you on the desktop, and you have to look in your event viewer to find any evidence as to why, then its being doing it since last year, pretty much from the beginning for me, but certainly September.

I started getting them today. My 2 friends CTD’s started yesterday. I do hope the okes at Asobo and Microsoft experience the same infuriating emotion I do when I just finished a 30 min startup and configure on the FBW A320 with Pacx and have the game CTD just after take off. It really is a mood killer.

@ [hobanagerik]
I have been flying for 2 months now and last week (3/24, or so) was the first time this started happening. I don’t doubt you, it just came as an unexpected surprise. Long Loads, also. FWIW, I recently added 3rd party addons to Community folder - possibility? Is it worth it for me to submit a Zendesk ticket?

1 Like

If nothing else its another tick in a box for Asobo. Try to include the event log with your ticket.

I’m willing to bet the code is “0xc0000005”

4 Likes

Funnily enough, I just had a crash! :wink: First one in about a month.

I had just passed TUBUS:

image

Sure enough, the error code in the event view was:

Faulting application name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Faulting module name: FlightSimulator.exe, version: 0.0.0.0, time stamp: 0x60420f33
Exception code: 0xc0000005

Except I did have something just before this:

Application: FlightSimulator.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.

I don’t think I’ve seen that one before, or if I have it was last year. I haven’t made any changes to .NET Framework, other than a patch back in February:

image

No point trying to run the downloaded installer:

image

Hi all! I’m currently trying to gather some information that could help the devs out with some of these CTDs.

One thing that helps them a lot is gathering CAB GUIDs. You can find that in the Event Viewer while looking at Windows Error Reporting Events.

Here are some directions to how to get to it: https://flightsimulator.zendesk.com/hc/en-us/articles/360015913659-How-to-report-a-bug-

They are looking for CAB GUIDs that aren’t “0”. If you have a CTD and check the logs, please DM me a screenshot of your CAB GUID and I’ll pass it along to them. Please don’t post it in this thread as to respect private information. Thanks!

Here is a screenshot of where you’d find the Cab GUID after following the Event Viewer directions in the above link:

6 Likes

Restarted my computer, and was able to redo the flight without issue.

Sadly all of mine were Cab=0.

Hopefully others here have that information. I’ll go back through my event log to see if I have others in there.

1 Like