Crash to desktop without error message

have you created own keybinding profiles ?..

Are the error numbers ( and the dll’s ) in case for both situations the same ?

1 Like

I have one keybinding profile for the Airbus stick (and it still crashes even when I am not using any peripheral, the error message though makes no mention of any dll.

The error number is always the 000005 one.

oh… the second post where I read that user wrote that a “move to another drive” helped… hmmm…
I still assume that Steam do in case of “move” also a ‘verify’ ( may be other things too ) of the application files and fixed somewhat.

1 Like

sorry wong explanation i did uninstall the base game and re install it on my maine drive

1 Like

may be the keybinding cause issues. My manual created mouse-profile becomes more or less useless with the update and I use again the normal “default” profiles for mouse ( I only disabled zoom, but the update makes more invalid ).

I just wondered a bit about your posts related to the world-map ( and also the keybinding ).

Random CTD is one thing, but that you can do nothing is may be a different issue.
You tried all the usually things… Like: closing ALL apps running in parallel ? disconnected the Airbus Stick ? Rolling Cache deleted ? etc. ?

1 Like

sounds similar to a steam move :wink: ( more exact: these kind of re-install which it do )

1 Like


Regarding the Airbus it crashes even when only the mouse is connected (the keybindings for the mouse are the default ones).

I’ve gotten the exact same crash twice in a row now trying to fly the FBW A32NX (latest dev version as of this minute). Are you also using the mod, or some other plane?

I for one are leaving these Airbus mod’s alone at the moment.


Difficult to say, there have been so many CTD’s, both with the Community Folder empty and using just the default planes, and with just the latest Dev FBW in the Community Folder, it could well have been with that plane in.

I meant did you try to fly it? It shouldn’t cause crashes from just being installed.
I got it to work on the third try, possibly because I deleted the files from LocalState\packages\flybywire-aircraft-a320-neo prior.

As others, experiencing random CTDs when flying in various locations - Sometimes within minutes of takeoff, sometime up to 30 mins in. Windows Event Viewer always shows the issue to be related to ctr.dll or ntdll.dll. All latest Windows updates applied (21H1 and preview feature update), latest Nvidia driver for RTX2070 Super, community folder empty, AI traffic off , Nvidia frame rate limited to 30fps/unlimited etc.

Not proven yet, but so far no CTDs when flying with developer mode turned on and the FPS counter displayed…

1 Like

Had a bit of a breakthrough with my post SU5 CTDs. Because of the increased performance, I had set my graphics to Ultra. Today I went back to High and then set only clouds to Ultra. Now for the first time I have been able to get past a few minutes of flight without a CTD. Currently about half way into a flight with the default Airbus and all is good so far.

So the things that have helped for me are first updated Nvidia drivers (I couldn’t even start the sim until I did that) and backing off from all Ultra graphics settings in the sim.

1 Like

Sorry, yes, I’ve managed to fly it on 2 occasions

I have multiplayer disabled. And I dont consider the FBW 320 as classic community content any more as it is part of the marketplace (I installed it in game from the marketplace, not manually in the community folder).

1 Like

Good afternoon to all pilots!

I continue to read the forum thread and noticed that messages from colleagues are divided into two large categories:

The first group has regular disruptions, CDT, and other pleasures. Moreover, the occurrence of these failures defies any reasonable explanation. To eliminate these failures, people from the first group follow a lot of both reasonable and completely fantastic recommendations, actually taken from nowhere.
The most interesting thing is that in the process of all these attempts and experiments, it can repeatedly seem that complete success has been achieved. The causal relationship between what is being done and the likelihood of success cannot be identified. And it really looks like a placebo effect, as one of the authors famously said just above.

In the second group, everything is fine in general (although it is a little embarrassing why they even read this thread). And they share the opinion that it is worth trying different realistic and not very options, often related not even to the settings of the simulator, but to the system environment or hardware components of the computer of citizens from the first group. Moreover, not always, but sometimes the emphasis is placed precisely on inept hands and a crooked executable environment.

Well, the cherry on top is that there are even some (very rare) representatives of this group, even the opinion is voiced that this is all normal, it should be so, because the fault lies with the losers themselves and their crooked hardware / programs.

And in general, the problem will disappear by itself, as if it never existed.

I belong to the first group of losers.
So, I report that the problem has not disappeared anywhere.

To be specific, my configuration is:

i7-10700kf (nominal frequency), matherboard PRIME Z490-A, 32Gb DDR4 Kingston XMP 4300, ASUS STRIX 2070S 8Gb, SSD SandiskG5 1Gb (with simulator only… sorry, Xpane (working) is there too)
MSFS Steam Edition Deluxe, Windows 10 20H2 (with all patch). NVidia 471.41

From the periphery - a lot of game controllers.

Well what can I say!
Before SU5, I had only literally one or two unexplained CTDs in a little over 500 hours (I did not fly long, only six months, since I was waiting for VR).

At the moment, I have a guaranteed CTD (0xC … 05) that occurs within 2-3 minutes after launch (and it doesn’t matter if I managed to launch the flight or rummage through the menu in search of the best settings.

I tried many options for fixing the problem, both my own and the suggested ones. By the way, by the way, I neatly cleaned the% UserName% \ AppData \ Roaming \ Microsoft Flight Simulator folder from unnecessary dlls, including from FBW, I have never seen such advice in the thread, if someone has already written, sorry :).

An empty community folder, of course. Tried launches from different regions of the world, different default aircraft.
It is clear that there is enough free disk space, free memory and video memory too, processor load (while it is possible to measure it) - a maximum of 15-20% (Video card - up to 100%)

I have done all sane and some not so sane but harmless advice.

Some advice, mainly from the field of hardware, I did not do, for example, I’m really not sure that disabling XMP and working at nominal memory frequencies is obviously more stable (although I would understand the advice to check the memory using memtest). However, it is unclear why, since in general everything else in the system works fine, including huge virtual machines with a complex environment (not launched simultaneously with the sim, of course :))

I also did not reinstall the sim and windows (I did the integrity control). I’ve seen a lot of people who weren’t helped by this.

I also didn’t turn off my usb controllers. I’ve also seen a lot of people who weren’t helped by this.
And if it helped me, why would I need a simulator without Joysticks? :slight_smile:

I am ready to easily assume any reason, for any failures, except one - the one that causes the crash right in the main menu.
Guys - this is really weird.

And this suggests that Asobo still has a problem.

Regards AlexFly

I will support in this thread the trend of finding strange coincidences

  • The simulator crashes faster if developer mode is enabled (and the FPS window is open).
  • owners of Radeon video cards more often report successful problem solving than owners of NVidia cards

You will laugh, but while writing this sad post, PWatsonUK wrote the exact opposite - about the absence of CTD in developer mode and the FPS window :slight_smile:


Forgot to add:

I don’t always get dumped onto the desktop after two minutes.
Rarely, but it is possible to fly for fifteen minutes or even an hour.
And then it begins to seem that here it is - a miracle!

Just completed a flight. So my solution is a hardly a placebo because on each of at least 10 prior attempts I got a CTD. The only change was backing off all ulta graphics settings.

Prior to that the issue was simply loading the sim at all. Again I had no success on I would say each of 20 attempts. New graphics drivers allowed me to load the sim to the menus 100% of the time. Again, not a placebo effect.


I have tried lowering the graphics settings, assuming that the video memory used may be exceeded.
Unfortunately - it didn’t work for me

I’m not laughing, just reporting what I’ve found (so far)…

There does seem to at least two distinct categories of CTDs - Those that have them when loading/browsing menus/hitting ‘Fly Now’ and those that only experience them when actually flying. I’m in the latter camp, you’re in the former.

I have some sympathy for Asobo unpicking this mess given the wide variety of PC hardware, peripherals, installed software, sim variables etc but the common factor does seem to be SU 5? Perhaps they’ll release a patch with logging to gather info, or a standard config to try with graphics, locations, selected aircraft, weather, ToD etc all set for tests under common conditions?