Crashes on XBOx Series X while trying to update the deluxe edition upgrade pack at the main screen

I cant run the game with this update, it crashes when trying to update the deluxe upgrade pack at the main title screen, hope this gets fixed so us with the deluxe pack can also test the beta. For now i cant even use the sim. Please fix this

Tried the following steps with no luck

  1. Clear the reserved space which removed all dlc
  2. Tried to start the sim but again crashed on installing the deluxe upgrade pack
  3. Then removed the entire sim and did a hard reboot of the xbox series x
  4. Reinstalled the sim
  5. Again tried to start it but again the sim crashed when trying to install the deluxe upgrade pack

It’s all the same result that we can never start the sim when we own the deluxe upgrade pack
I asked someone without the deluxe upgrade and they had no problems

Seriously hope this gets fixed before the weekend

1 Like

Can you just install the basic sim? There’s another thread similar to this as you’ve probably seen. I wonder if there’s a link. Mine crashes off of the game pass version soon after the checking for updates screen.

I might even rollback to update 10 until this gets sorted, not sure they’ll be able to fix it in a day but they have done it before I guess.

Same here, gets to the point where it should load the main screen then CTD every time. As you say, the beta is unusable at present on Xbox, so I’ve rolled back to SU10.


[SU11 Beta does not start and gives CTD after successful checking updates, Canada tiles CTD

I’m thinking these should be or are tied together somehow @wombleway, I hope the feedback logged will go for consoles as well. All the other users in the post seem to be on PC only with the issue. Hopefully a mod or manager will pick up on this.

No idea if they are caused by the same thing though, but yes console should be logged too since we cant even start the sim

1 Like

Tried to do a clean install again but still same issue it crashes on the deluxe upgrade pack and since that pack installs from the main screen it simply can not start fhe sim

1 Like

Is the deluxe pack bundled up as one? Can you not do a base game install without having to install the other content.

No you cant, the deluxe pack installs or wants to upgrade automaticly from the main start screen, you have no option not to install it.

@patrickb1973 , please use the bug template when logging bugs. You have been asked before.

Are you using Developer Mode or made changes in it?

No because we cant on Xbox Series X

Brief description of the issue:

When launching the sim it wants to update the Deluxe Edition Upgrade Pack, this is were the problem starts during that upgrade it crashes. Also tried a clean new install but then it crashes on the same thing wanting to install the deluxe edition upgrade pack. So the problem is with the Deluxe Edition Upgrade Pack in my case.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Start the Sim and watch it crash on the Deluxe Edition Upgrade Pack update / install

PC specs and/or peripheral set up if relevant:

Xbox Series X

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:


I hope a fix comes fast for this issue, as it stands right now we are punished for having bought the deluxe version.

I have the same issue - it’s incredibly frustrating given how well the sim worked before!

I agree with SU10 it worked beautifully but now wecant even start the sim with this beta, sure hope it gets fixed soon

I have the same issue on the beta with both my Series X and Series S. Had to revert back to the last version until this is fixed.

Well I tried 10 times to do a fresh install but it keeps on crashing on the deluxe upgrade pack that it tries to install from the main screen, just like it crashed when it tried to update it. Hope this really get fixed fast so we on Xbox can also test the beta without being punished for buying the deluxe version.

Same problem for me too. Had to can su11 beta deluxe game. Reloaded entire game and only premium no issues since then.

Really hope we see a fix soon ,it’s been over a week and we still haven’t heard anything back from the team

Update today fixed it