Crashing is getting ridiculous on Xbox

I can’t fly at a single airport that has ad on scenery. It crashes EVERY SINGLE TIME. i was hoping this would be fixed, everyone seams to simply avoid it rather than address it though unfortunately. Any one else having this issue ? I’m on Xbox series x.

Me, unable to land in airports that are crowed, lime Mexico City, Los Angeles, Barajas, etc, every time I do that, the game in some point re start it self in any time , so it is very frustrating mostly happens in a final approach or taxing.

Topic moved into #bugs-and-issues:ctds

The SDK category is for discussion of the Software Development Kit.

Extremely frustrating. I made this post after finally giving up on trying to fly anymore. Spawned in 7 times at KLAS and crashed every single time. I don’t wanna be limited to the airports that aren’t reworked -.-

1 Like

MSFS Addon Compatibility List - Community / Marketplace - Microsoft Flight Simulator Forums

Game is officially broken on XSX dude. Been like this for 3 months for me. I don’t know if it’ll ever be fixed, Asobo is just not paying any attention to these issues. I just got a PC and moved on.

1 Like

Most weird how different experiences people have on same hardware… On Series S and I have had 10 CTD in a year and love the experience despite the few hiccups here and there. I don’t have any add on airports or sceneries beyond the enhanced airports by Zienetek and a few aircrafts…

I would systematically remove all your add ons and re install them one by one, especially the NXi. Wait for an issue to pop up. I run at 60HZ VRR 4kHDR, which is the max xbox can put out without graphical issues and only get a little stutter if I’m panning all over the place with the camera. I don’t consider the occasional drop-in/pop up hitch for one or two FPS dropping in textures a ‘bug’, it’s just a ton of data showing up in your view, pretty normal for any MMP big-world game(unless you get a petabyte drive maybe). I download at over 700kbs with a 5 ping(don’t think it shows lower) and you still get data burps when it drop kicks an international airport and buildings into your FOV on the horizon.

On approach to a busy complicated airport like KDCA, where you can go in the terminals and wait in line with the passengers for coffee, with full traffic and vehicles(except ground vehicle slider to 25% to keep forklifts off the runway). If I keep my camera in the typical field of vision on approach even in a complicated 3rd party aircraft it’s very smooth.

Don’t know what’s going on but yesterday there were at least 8 other aircraft on approach with live traffic and at least as many in some sort of motion on the ground(it’s usually 1 or 2) and the final and landing were still butter smooth. Never seen so much live traffic in this game yet, some times was tracking ~20 aircraft in the immediate area last night. SOMETHING is causing the issue on your xbox.

My bet is on the NXi or a set of airliner skins affecting the AI aircraft on the ground.

Load each area individually and land/fly over them one after the other and eventually you’ll find the problem, even if you aren’t currently in the area.

And CLEAR YOUR CACHE, quit the game, and full restart your xbox. Something may be hiding in there from before the last round of updates. Likely one of the updates is not playing nicely with whatever add on you have, and just reinstalling them helps out. If you don’t remember what you did when you started having issues, then you pretty much need to delete everything not native and work your way back.

1 Like

I agree, we should not be skittish in wanting to purchase add ons but, here we are. I avoid purchasing airports altogether at this point, because I know some of them will cause CTD on Xbox, we have no idea which ones. So, avoid all of the.

If they allowed us a 30 trail before purchase, we could feel more confident. But as it is right now, I’m not throwing out my money on a DLC I can’t use (already have a couple of those).

It’s a shame that we can’t enjoy the sim to its fullest potential. MS/Asobo have said they are not looking to fix DLC that are incompatible with other DLC, that is up to the vendors. The vendors blame MS/Asobo, so round and round it goes with the customer the one in the middle and out of pocket.

I have a bunch of stuff and don’t have CTD’s. The NXi simply didn’t display right, but never crashed the game.

I bought the most expensive version of the game which I thought to be a good purchase, with the reworked airports Included. Unfortunately I can’t spawn into any of them. I’m limited to fly at non reworked airport. It’s so frustrating that the problem seams to only be getting worse. I honestly am thinking about trying to get a refund on the premium deluxe version since I spent the extra money for the airports that I can’t even fly at! Simply ridiculous. FIX IT.

1 Like

I actually deleted most of the airports. Don’t fret too much about it. At least you got the Premium Deluxe planes.

Since it seems most other people aren’t having that problem, it should be something that can be fixed locally.
I’d recommend you submit a request for help from Zendesk, identifying the issue and have them help you resolve it.


With all due respect rather than posting a demand ‘FIX IT’, perhaps you could describe a little clearer what specifically happens. Providing details of your pc specs, what add-ons you are using, what hardware you are using/have connected, what you have tried to remedy the problem etc. may help someone in assisting you to resolve the problem.

My initial suggestions would be disconnect all your controllers other than keyboard and mouse, empty the community folder, run windows in a clean boot situation- Google/search how to do that, I do not simply mean reboot your PC. Run the sim and make sure you have the latest up-to-date content installed in the content manager.

Once you have done ALL of the above load a flight (not in VR or anything) at the airfield of your choice I.e. one of the enhanced Deluxe Premium ones and see what happens. I would also consider lowering all your settings just to see if that helps.

Failing that, I would suggest doing a complete CLEAN reinstall of the sim. I.e. completely uninstall it and any folders and related saved files, registry entries all of it…. Probably best to search the Zendesk/support pages of this site to find out where and what you should remove. I would also do this while windows is in a clean boot situation.
Hope this helps. :+1:


Reinstall, you will have a problem with XBox version of Digital Ownership (had that several times)

Go and buy the steam version all problems solved


Its Xbox according to the category under the title.

Noted, but it does not stop someone from providing a level of detail surrounding the issue they are experiencing or trouble shooting as best they can with the limited options available with the Xbox.
Just seems like another post to rant quite frankly. :roll_eyes:

True but to be fair if you have a closed eco system and buy a product that should work but doesnt, it must be rather irritating. Not everybody wants to jump through hoops to get a game working, they just want to play hence getting a console so I do feel sorry for Xbox players who have issues, it really should not be like that.

1 Like

I do agree with you, however I wish people (generally) would try to provide a little more information so others (including the developers) have a little more to work with to try and identify possible causes. In this case for example what aircraft, what specific locations, what settings.
It seems pretty clear the OP just wanted to let off steam out of frustration which I get, been there done that… but usually after researching an issue or trying to trouble-shoot it myself to narrow down what may be causing it.

It’s much the same as going to a mechanic to complain your car ‘does not move’ without providing any basic information.

1 Like